aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-pyqwt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-16 20:11:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-16 20:11:30 +0000
commit72285c93f76590c10ab30d63aa5873f4a9ee1591 (patch)
treeceeff2da359ed8e38e414d9a7d42306ac88b2f43 /x11-toolkits/py-pyqwt
parent62bc13f343fed76c617684dfc560982dbc95b7a4 (diff)
downloadports-72285c93f76590c10ab30d63aa5873f4a9ee1591.tar.gz
ports-72285c93f76590c10ab30d63aa5873f4a9ee1591.zip
Notes
Diffstat (limited to 'x11-toolkits/py-pyqwt')
-rw-r--r--x11-toolkits/py-pyqwt/Makefile31
-rw-r--r--x11-toolkits/py-pyqwt/distinfo3
-rw-r--r--x11-toolkits/py-pyqwt/files/patch-GNUmakefile29
-rw-r--r--x11-toolkits/py-pyqwt/pkg-descr12
-rw-r--r--x11-toolkits/py-pyqwt/pkg-plist92
5 files changed, 167 insertions, 0 deletions
diff --git a/x11-toolkits/py-pyqwt/Makefile b/x11-toolkits/py-pyqwt/Makefile
new file mode 100644
index 000000000000..ed84b8dd02d7
--- /dev/null
+++ b/x11-toolkits/py-pyqwt/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-pyqwt
+# Date created: 2009-01-20
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyqwt
+PORTVERSION= 5.1.0
+CATEGORIES= x11-toolkits python
+MASTER_SITES= SF
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyQwt-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python Bindings for the Qwt Class Library
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}qt4-core>=4.3.3:${PORTSDIR}/devel/py-qt4-core \
+ ${PYTHON_PKGNAMEPREFIX}qt4-svg>=4.3.3:${PORTSDIR}/graphics/py-qt4-svg \
+ ${PYTHON_PKGNAMEPREFIX}qt4-gui>=4.3.3:${PORTSDIR}/x11-toolkits/py-qt4-gui \
+ ${PYTHON_PKGNAMEPREFIX}qt4-qscintilla2>=2.2:${PORTSDIR}/devel/py-qt4-qscintilla2 \
+ ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+
+USE_PYTHON= 2.5+
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-pyqwt/distinfo b/x11-toolkits/py-pyqwt/distinfo
new file mode 100644
index 000000000000..a9d2a4fc0b44
--- /dev/null
+++ b/x11-toolkits/py-pyqwt/distinfo
@@ -0,0 +1,3 @@
+MD5 (PyQwt-5.1.0.tar.gz) = c9d662a0d4fc95cec75d3c526e4e748a
+SHA256 (PyQwt-5.1.0.tar.gz) = 13d90d25b3c21c5dadd5cfac1e45cd41680f3c9b7731776c5a46bb1eece12716
+SIZE (PyQwt-5.1.0.tar.gz) = 4700809
diff --git a/x11-toolkits/py-pyqwt/files/patch-GNUmakefile b/x11-toolkits/py-pyqwt/files/patch-GNUmakefile
new file mode 100644
index 000000000000..e143382214c3
--- /dev/null
+++ b/x11-toolkits/py-pyqwt/files/patch-GNUmakefile
@@ -0,0 +1,29 @@
+--- GNUmakefile.orig 2009-02-01 18:23:59.000000000 +0800
++++ GNUmakefile 2009-02-01 18:26:04.000000000 +0800
+@@ -28,7 +28,7 @@
+
+ .PHONY: dist qwt-5.0 qwt-5.1
+
+-all: 3 4
++all: 4
+
+ debug: 3d 4d
+
+@@ -41,7 +41,7 @@
+
+ 4:
+ cd configure \
+- && python configure.py -4 -Q $(QWT) -j $(JOBS) \
++ && python configure.py -4 -I/usr/local/include/qwt -L/usr/local/lib -lqwt -j $(JOBS) \
+ && $(MAKE) -j $(JOBS)
+
+
+@@ -72,7 +72,7 @@
+ install-4: 4
+ make -C configure install
+
+-install: install-3 install-4
++install: install-4
+
+ install-3d: 3d
+ make -C configure install
diff --git a/x11-toolkits/py-pyqwt/pkg-descr b/x11-toolkits/py-pyqwt/pkg-descr
new file mode 100644
index 000000000000..7263272a08e9
--- /dev/null
+++ b/x11-toolkits/py-pyqwt/pkg-descr
@@ -0,0 +1,12 @@
+PyQwt is a set of Python bindings for the Qwt C++ class library which
+extends the Qt framework with widgets for scientific and engineering
+applications. It provides a widget to plot 2-dimensional data and
+various widgets to display and control bounded or unbounded floating
+point values.
+
+PyQwt addresses the problem of integrating PyQt, Qt, Qwt, NumPy and
+optionally SciPy. Look at the Command Line Interface (CLI) examples and
+the Graphical User Interface (GUI) examples to get an idea of what you
+can do with PyQwt.
+
+WWW: http://pyqwt.sourceforge.net/
diff --git a/x11-toolkits/py-pyqwt/pkg-plist b/x11-toolkits/py-pyqwt/pkg-plist
new file mode 100644
index 000000000000..14b97444b8c6
--- /dev/null
+++ b/x11-toolkits/py-pyqwt/pkg-plist
@@ -0,0 +1,92 @@
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/_iqt.so
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/Qwt.so
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/qplt.py
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/anynumpy.py
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/__init__.py
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/grace.py
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/iqt.py
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/pythonrc.py
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/__init__.pyc
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/anynumpy.pyc
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/grace.pyc
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/iqt.pyc
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/pythonrc.pyc
+%%PYTHON_SITELIBDIR%%/PyQt4/Qwt5/qplt.pyc
+share/py-sip/Qwt5
+share/py-sip/Qwt5/qwt_arrow_button.sip
+share/py-sip/Qwt5/qwt_knob.sip
+share/py-sip/Qwt5/qwt_plot_picker.sip
+share/py-sip/Qwt5/qwt_plot_svgitem.sip
+share/py-sip/Qwt5/qwt_legend_itemmanager.sip
+share/py-sip/Qwt5/qwt_text.sip
+share/py-sip/Qwt5/qwt_plot_rasteritem.sip
+share/py-sip/Qwt5/qwt_plot_dict.sip
+share/py-sip/Qwt5/qwt_abstract_scale_draw.sip
+share/py-sip/Qwt5/qwt_plot_printfilter.sip
+share/py-sip/Qwt5/qwt_scale_map.sip
+share/py-sip/Qwt5/qwt_scale_widget.sip
+share/py-sip/Qwt5/QwtArrayInt.sip
+share/py-sip/Qwt5/qwt_dial_needle.sip
+share/py-sip/Qwt5/qwt_plot_curve.sip
+share/py-sip/Qwt5/qwt_data.sip
+share/py-sip/Qwt5/qwt_interval_data.sip
+share/py-sip/Qwt5/qwt_legend_item.sip
+share/py-sip/Qwt5/QwtArrayQwtDoublePoint.sip
+share/py-sip/Qwt5/qwt_compass_rose.sip
+share/py-sip/Qwt5/qwt_curve_fitter.sip
+share/py-sip/Qwt5/qwt_legend.sip
+share/py-sip/Qwt5/qwt_spline.sip
+share/py-sip/Qwt5/qwt_scale_engine.sip
+share/py-sip/Qwt5/qwt_thermo.sip
+share/py-sip/Qwt5/qwt_dial.sip
+share/py-sip/Qwt5/qwt_plot.sip
+share/py-sip/Qwt5/qwt_counter.sip
+share/py-sip/Qwt5/qwt_layout_metrics.sip
+share/py-sip/Qwt5/qwt_raster_data.sip
+share/py-sip/Qwt5/qwt_double_range.sip
+share/py-sip/Qwt5/qwt_painter.sip
+share/py-sip/Qwt5/qwt_abstract_slider.sip
+share/py-sip/Qwt5/qwt_plot_layout.sip
+share/py-sip/Qwt5/qwt_panner.sip
+share/py-sip/Qwt5/qwt_plot_item.sip
+share/py-sip/Qwt5/qwt_event_pattern.sip
+share/py-sip/Qwt5/qwt_magnifier.sip
+share/py-sip/Qwt5/qwt_scale_draw.sip
+share/py-sip/Qwt5/qwt_plot_spectrogram.sip
+share/py-sip/Qwt5/qwt_dyngrid_layout.sip
+share/py-sip/Qwt5/qwt_plot_marker.sip
+share/py-sip/Qwt5/qwt_plot_scaleitem.sip
+share/py-sip/Qwt5/qwt_plot_canvas.sip
+share/py-sip/Qwt5/qwt_picker_machine.sip
+share/py-sip/Qwt5/qwt_round_scale_draw.sip
+share/py-sip/Qwt5/QwtArrayQwtDoubleInterval.sip
+share/py-sip/Qwt5/qwt_scale_div.sip
+share/py-sip/Qwt5/qwt_text_engine.sip
+share/py-sip/Qwt5/QwtStack.sip
+share/py-sip/Qwt5/QwtArrayDouble.sip
+share/py-sip/Qwt5/qwt_compass.sip
+share/py-sip/Qwt5/qwt_color_map.sip
+share/py-sip/Qwt5/qwt_abstract_scale.sip
+share/py-sip/Qwt5/QwtModule.sip
+share/py-sip/Qwt5/qwt_wheel.sip
+share/py-sip/Qwt5/qwt_rect.sip
+share/py-sip/Qwt5/qwt_plot_zoomer.sip
+share/py-sip/Qwt5/qwt_picker.sip
+share/py-sip/Qwt5/qwt_slider.sip
+share/py-sip/Qwt5/qwt_symbol.sip
+share/py-sip/Qwt5/qwt_text_label.sip
+share/py-sip/Qwt5/QwtTypes.sip
+share/py-sip/Qwt5/qwt_plot_panner.sip
+share/py-sip/Qwt5/qwt_analog_clock.sip
+share/py-sip/Qwt5/qwt_double_interval.sip
+share/py-sip/Qwt5/QwtMap.sip
+share/py-sip/Qwt5/qwt_clipper.sip
+share/py-sip/Qwt5/qwt_plot_grid.sip
+share/py-sip/Qwt5/qwt_plot_magnifier.sip
+share/py-sip/Qwt5/QwtList.sip
+share/py-sip/Qwt5/qwt_scale_widget.sip
+@dirrm %%PYTHON_SITELIBDIR%%/PyQt4/Qwt5
+@dirrmtry %%PYTHON_SITELIBDIR%%/PyQt4
+@dirrm share/py-sip/Qwt5
+@dirrm share/py-sip