aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-qt5-quick
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-11-24 06:14:01 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-11-24 06:14:01 +0000
commit1c10f8c7fabac60f2871cec3c744bc23151e3025 (patch)
tree16d60225874443f521b83666baaf1ec0ba830757 /x11-toolkits/py-qt5-quick
parent826261d3803ff750bea509e13ea3cb9eaf70c094 (diff)
downloadports-1c10f8c7fabac60f2871cec3c744bc23151e3025.tar.gz
ports-1c10f8c7fabac60f2871cec3c744bc23151e3025.zip
New port: x11-toolkits/py-qt5-quick
PyQt5 is a set of Python bindings for Digia's Qt5 application framework. This package provides the QtQuick module. WWW: http://www.riverbankcomputing.co.uk/software/pyqt/ PR: 209691 Submitted by: Henry Hu <henry.hu.sh@gmail.com>
Notes
Notes: svn path=/head/; revision=426990
Diffstat (limited to 'x11-toolkits/py-qt5-quick')
-rw-r--r--x11-toolkits/py-qt5-quick/Makefile26
-rw-r--r--x11-toolkits/py-qt5-quick/pkg-descr4
-rw-r--r--x11-toolkits/py-qt5-quick/pkg-plist24
3 files changed, 54 insertions, 0 deletions
diff --git a/x11-toolkits/py-qt5-quick/Makefile b/x11-toolkits/py-qt5-quick/Makefile
new file mode 100644
index 000000000000..1ac17d9c68f5
--- /dev/null
+++ b/x11-toolkits/py-qt5-quick/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= quick
+CATEGORIES= x11-toolkits devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtQuick module
+
+CONFIGURE_ARGS= --enable QtQuick
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_PYQT= sip_build core_run gui_run
+USE_QT5= core quick qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtQuick API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-qt5-quick/pkg-descr b/x11-toolkits/py-qt5-quick/pkg-descr
new file mode 100644
index 000000000000..ed682c39e952
--- /dev/null
+++ b/x11-toolkits/py-qt5-quick/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtQuick module.
+
+WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/x11-toolkits/py-qt5-quick/pkg-plist b/x11-toolkits/py-qt5-quick/pkg-plist
new file mode 100644
index 000000000000..11af7d3ee4c9
--- /dev/null
+++ b/x11-toolkits/py-qt5-quick/pkg-plist
@@ -0,0 +1,24 @@
+%%PYTHON_SITELIBDIR%%/PyQt5/QtQuick.so
+%%PYQT_SIPDIR%%/QtQuick/QtQuickmod.sip
+%%PYQT_SIPDIR%%/QtQuick/qquickframebufferobject.sip
+%%PYQT_SIPDIR%%/QtQuick/qquickimageprovider.sip
+%%PYQT_SIPDIR%%/QtQuick/qquickitem.sip
+%%PYQT_SIPDIR%%/QtQuick/qquickitemgrabresult.sip
+%%PYQT_SIPDIR%%/QtQuick/qquickpainteditem.sip
+%%PYQT_SIPDIR%%/QtQuick/qquickrendercontrol.sip
+%%PYQT_SIPDIR%%/QtQuick/qquicktextdocument.sip
+%%PYQT_SIPDIR%%/QtQuick/qquickview.sip
+%%PYQT_SIPDIR%%/QtQuick/qquickwindow.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgabstractrenderer.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgengine.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgflatcolormaterial.sip
+%%PYQT_SIPDIR%%/QtQuick/qsggeometry.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgmaterial.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgnode.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgsimplerectnode.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgsimpletexturenode.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgtexture.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgtexturematerial.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgtextureprovider.sip
+%%PYQT_SIPDIR%%/QtQuick/qsgvertexcolormaterial.sip
+%%API%%share/qt5/qsci/api/python/QtQuick.api