aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33/Makefile
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1996-07-31 00:20:49 +0000
committerChuck Robey <chuckr@FreeBSD.org>1996-07-31 00:20:49 +0000
commit6ec920fec5ac6c67b81bb074a52ccde78771245f (patch)
tree078d01722488c216faa0200d1e4e36409cf78ec2 /x11-toolkits/qt33/Makefile
parentd5b408c66cec681ccd754293e752c8eaf063b8fa (diff)
downloadports-6ec920fec5ac6c67b81bb074a52ccde78771245f.tar.gz
ports-6ec920fec5ac6c67b81bb074a52ccde78771245f.zip
Notes
Diffstat (limited to 'x11-toolkits/qt33/Makefile')
-rw-r--r--x11-toolkits/qt33/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
new file mode 100644
index 000000000000..65a664d7d17b
--- /dev/null
+++ b/x11-toolkits/qt33/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: qt-0.98
+# Version required: 0.98
+# Date created: 30 Jul 1996
+# Whom: searle@longacre.demon.co.uk
+#
+# $Id$
+#
+
+DISTNAME= qt-0.98
+CATEGORIES+= x11
+MASTER_SITES= ftp://ftp.troll.no/qt/
+
+MAINTAINER= searle@longacre.demon.co.uk
+
+USE_GMAKE= yes
+WRKSRC= $(WRKDIR)/$(DISTNAME)/arch/freebsd-shared
+USE_X11= yes
+
+post-extract:
+ cd $(WRKDIR)/$(DISTNAME)/arch; $(GMAKE) freebsd-shared
+
+do-install:
+ install -c $(WRKDIR)/qt-0.98/bin/moc $(X11BASE)/bin
+ install -c $(WRKDIR)/qt-0.98/lib/libqt.so.0.908 $(X11BASE)/lib
+ mv $(PREFIX)/lib/libqt.so.0.908 $(PREFIX)/lib/libqt.so.0.98
+ /sbin/ldconfig -m $(PREFIX)/lib
+ mkdir -p $(PREFIX)/include/X11/qt
+ install $(WRKDIR)/qt-0.98/include/* $(PREFIX)/include/X11/qt
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf $(WRKDIR)/qt-0.98/man/man1/*.1
+ gzip -9nf $(WRKDIR)/qt-0.98/man/man3/*3qt
+.endif
+ install $(WRKDIR)/qt-0.98/man/man1/* $(PREFIX)/man/man1
+ install $(WRKDIR)/qt-0.98/man/man3/* $(PREFIX)/man/man3
+
+.include <bsd.port.mk>