aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-08-17 19:49:44 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-08-17 19:49:44 +0000
commit1b50536a035f87070945de9551a88667a5576522 (patch)
tree617246fa7a204f4436ccf0b098ef5836e4606029 /x11-toolkits/qt33
parent9f15c68bdd5260e7cc89e9583e469e5b81e1b7c3 (diff)
downloadports-1b50536a035f87070945de9551a88667a5576522.tar.gz
ports-1b50536a035f87070945de9551a88667a5576522.zip
Notes
Diffstat (limited to 'x11-toolkits/qt33')
-rw-r--r--x11-toolkits/qt33/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 125d8f1fda57..cd939272c586 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= qt
PORTVERSION?= 3.0.5
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/ \
ftp://ftp.chg.ru/pub/X11/qt/source/
@@ -28,13 +28,14 @@ IMAGELIB_TYPE= qt
PLIST_SUB+= IMAGE_PLUGINS="@comment "
.endif
-QT_PREFIX?= ${PREFIX}
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_REINPLACE= yes
-REINPLACE_ARGS= -i ""
-USE_X_PREFIX= yes
-HAS_CONFIGURE= yes
+QT_PREFIX?= ${PREFIX}
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
+USE_X_PREFIX= yes
+NO_FILTER_SHLIBS= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= -prefix ${QT_PREFIX} \
-shared -qt-gif -system-zlib \
-no-g++-exceptions -thread -no-stl \
@@ -73,10 +74,11 @@ CFLAGS+= -O0
BROKEN= "The QT 3.x port does not support any XFree86 < 4.x"
.endif
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+SLEEP=${TRUE}
+.else
SLEEP=/bin/sleep
-pre-everything:
- @${CAT} ${PKGMESSAGE}
- @${SLEEP} 10
+.endif
pre-fetch:
.if exists(${X11BASE}/include/qt2/qapp.h)