aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2003-12-13 10:21:14 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2003-12-13 10:21:14 +0000
commit64c4818f8e2cf14bd8766bb5bd48e2dc23d5ebfb (patch)
tree00786497134cc3d0118f5683e7096193cb2831b6 /x11-toolkits/qt33
parenta489b6318ebf23bacbe3e6cc3bb7ccecd5654801 (diff)
downloadports-64c4818f8e2cf14bd8766bb5bd48e2dc23d5ebfb.tar.gz
ports-64c4818f8e2cf14bd8766bb5bd48e2dc23d5ebfb.zip
Notes
Diffstat (limited to 'x11-toolkits/qt33')
-rw-r--r--x11-toolkits/qt33/Makefile117
-rw-r--r--x11-toolkits/qt33/distinfo2
-rw-r--r--x11-toolkits/qt33/files/patch-configure49
-rw-r--r--x11-toolkits/qt33/pkg-plist181
4 files changed, 106 insertions, 243 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index e3265004d74a..5e0ffaef1cc6 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME?= qt
-PORTVERSION= 3.2.1
+PORTVERSION= 3.2.3
CATEGORIES?= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/ \
ftp://ftp.silug.org/pub/qt/ \
@@ -19,6 +19,8 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
COMMENT?= A C++ X GUI toolkit
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
@@ -26,21 +28,51 @@ LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng \
CONFLICTS= linguist-0.* qt-2.* qt-designer-2.* xfmail-1.5.*
USE_BZIP2= yes
-USE_GMAKE= yes
USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
USE_X_PREFIX= yes
HAS_CONFIGURE= yes
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS=yes
+
CONFIGURE_ARGS+= -system-libpng -system-libjpeg -system-libmng \
-qt-imgfmt-png -qt-imgfmt-jpeg -qt-imgfmt-mng \
-system-zlib -no-nas-sound -sm -qt-gif -thread \
-fast -xinerama -no-g++-exceptions -no-stl \
${CUPS} -shared -prefix ${PREFIX} -datadir ${DATADIR} \
- -docdir ${DOCSDIR} -plugindir ${PREFIX}/lib/plugins
+ -verbose -docdir ${DOCSDIR} \
+ -plugindir ${PREFIX}/lib/plugins
+
+CONFIGURE_ENV?= ${ECHO} yes | QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} \
+ LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+ALL_TARGET= sub-tools
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
+ --exclude '${DISTNAME}/examples' --exclude '${DISTNAME}/tutorial' \
+ --exclude '${DISTNAME}/extensions/nsplugin/src/[^q]*' \
+ --exclude '${DISTNAME}/include/jri*' \
+ --exclude '${DISTNAME}/include/np*'
.include <bsd.port.pre.mk>
+# The previous Qt port versions installed qmake and qmake's specs under X11BASE
+# The new devel/qmake port installs them under LOCALBASE. We can use
+# either one here, but we prefer the newer:
+.for d in ${X11BASE} ${LOCALBASE}
+. if exists($d/share/qt/mkspecs/freebsd-g++)
+QTBASE=$d
+PLATFORM=${QTBASE}/share/qt/mkspecs/freebsd-g++
+. endif
+.endfor
+
+.if defined(PLATFORM)
+CONFIGURE_ARGS+= -platform ${PLATFORM}
+.else
+CONFIGURE_ARGS+= -platform ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+.endif
+
.if !defined(WITHOUT_XFT)
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/Xft
.else
@@ -51,10 +83,9 @@ CONFIGURE_ARGS+=-no-xft
CONFIGURE_ARGS+=-debug
.endif
-.if !defined(BUILD_PLUGIN_ONLY)
.if !defined(WITHOUT_OPENGL)
-USE_MESA= yes
-.else
+USE_GL= yes
+. else
CONFIGURE_ARGS+=-disable-opengl
.endif # WITHOUT_OPENGL
@@ -65,28 +96,10 @@ CUPS= -cups -L${LOCALBASE}/lib -I${LOCALBASE}/include
CUPS=
.endif
-CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
-MAKE_ENV?= QTDIR=${WRKSRC} \
- LD_LIBRARY_PATH=${WRKSRC}/lib \
- PATH=${WRKSRC}/bin:$$PATH
-ALL_TARGET= sub-tools
-.endif # !defined(BUILD_PLUGIN_ONLY)
-
.if ${MACHINE_ARCH} == "alpha"
CFLAGS+= -O0
.endif
-.if !defined(BUILD_PLUGIN_ONLY)
-.if !defined(WITHOUT_OPENGL)
-# Display WITH_OPENGL advisory.
-pre-everything::
- @${ECHO_MSG} '===> **************************************************'
- @${ECHO_MSG} '===> NOTE: Use of WITH_OPENGL is not recommended with'
- @${ECHO_MSG} '===> the NVidia drivers provided by the x11/nvidia port'
- @${ECHO_MSG} '===> If you use these drivers, we recommend you press'
- @${ECHO_MSG} '===> Ctrl-C now and set WITHOUT_OPENGL'
- @${ECHO_MSG} '===> **************************************************'
-.endif
.if !defined(WITHOUT_XFT)
pre-everything::
@${ECHO_MSG}
@@ -104,62 +117,34 @@ BROKEN= "The QT ${PORTVERSION} port does not support any XFree86 < 4.x"
BROKEN= "You have QT2 headers installed! Installing this port"
BROKEN+="will result in conflicts between QT3 and QT2!"
.endif
-.endif # !defined(BUILD_PLUGIN_ONLY)
post-patch:
-.if !defined(BUILD_PLUGIN_ONLY)
- @${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -fr
- @cd ${WRKSRC}/include; \
- ${RM} -f jri.h jri_md.h jritypes.h npapi.h npupp.h
- @cd ${WRKSRC}/extensions/nsplugin/src; \
- ${RM} -f jri.h jri_md.h jritypes.h npapi.h npupp.h \
- npunix.c npwin.cpp
+.if defined(PLATFORM)
+ @${REINPLACE_CMD} -e 's|$$outpath/bin/qmake|${QTBASE}/bin/qmake|g' \
+ ${WRKSRC}/configure
.else
- ${REINPLACE_CMD} -e \
- "s,-lmysqlclient,-L${LOCALBASE}/lib/mysql -lmysqlclient," \
- ${WRKSRC}/plugins/src/sqldrivers/mysql/mysql.pro
- @${RM} -fr ${WRKSRC}/extensions ${WRKSRC}/tools \
- ${WRKSRC}/plugins/src/styles \
- ${WRKSRC}/plugins/src/codecs \
- ${WRKSRC}/plugins/src/accessible \
- ${WRKSRC}/plugins/src/imageformats
- ${LN} -s ${X11BASE}/bin/qmake ${WRKSRC}/bin/qmake
- ${ECHO_CMD} "qmake:" > ${WRKSRC}/qmake/GNUmakefile.in
-.endif
- @${RM} -fr ${WRKSRC}/examples ${WRKSRC}/tutorial
- @${REINPLACE_CMD} -e 's,-O2,${CXXFLAGS},' \
- ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
- @${REINPLACE_CMD} -e 's,gcc,${CC},' \
- ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
- @${REINPLACE_CMD} -e 's,g++,${CXX},' \
- ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
- @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
- ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},' \
- ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
- @${REINPLACE_CMD} -e 's,release,release thread,' \
- ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
-.if ${OSVERSION} > 500016
- @${REINPLACE_CMD} -e 's,-pthread -D_THREAD_SAFE,${PTHREAD_CFLAGS},' \
- ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
- @${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},' \
- ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's|$$outpath/bin/qmake|${LOCALBASE}/bin/qmake|g' \
+ ${WRKSRC}/configure
.endif
-.if !defined(BUILD_PLUGIN_ONLY)
- @${RM} ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf.bak
+ @${REINPLACE_CMD} -e 's|^ cd qmake.*||' ${WRKSRC}/Makefile
post-build:
.for tool in makeqpf mergetr msg2qm qembed qvfb
- cd ${WRKSRC}/tools/${tool}; ${SETENV} ${MAKE_ENV} ${MAKE}
+ @cd ${WRKSRC}/tools/${tool}; ${SETENV} ${MAKE_ENV} ${MAKE}
.endfor
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${GREP} --mmap -F -l -- \
+ "${PLATFORM}" | ${XARGS} ${REINPLACE_CMD} -e "s,${PLATFORM}/qmake.conf,," \
+ -e "s,${PLATFORM},,"
# Work around qmake generated dependencies
pre-install:
- @${INSTALL_DATA} ${WRKSRC}/lib/*.prl ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/lib/*.prl ${PREFIX}/lib
${INSTALL_SCRIPT} ${WRKSRC}/bin/findtr ${PREFIX}/bin
.for tool in makeqpf mergetr msg2qm qembed qvfb
${INSTALL_PROGRAM} ${WRKSRC}/tools/${tool}/${tool} ${PREFIX}/bin
.endfor
-.endif # !defined(BUILD_PLUGIN_ONLY)
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/libqt-mt.la
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt33/distinfo b/x11-toolkits/qt33/distinfo
index e2cdecd987cc..3d346c5edda8 100644
--- a/x11-toolkits/qt33/distinfo
+++ b/x11-toolkits/qt33/distinfo
@@ -1 +1 @@
-MD5 (KDE/qt-x11-free-3.2.1.tar.bz2) = 9ae022ffe7603ec34aba150f6cca257a
+MD5 (KDE/qt-x11-free-3.2.3.tar.bz2) = cd6df28c81ac00d97d62bd9942b8da03
diff --git a/x11-toolkits/qt33/files/patch-configure b/x11-toolkits/qt33/files/patch-configure
new file mode 100644
index 000000000000..75386f4b379c
--- /dev/null
+++ b/x11-toolkits/qt33/files/patch-configure
@@ -0,0 +1,49 @@
+--- configure Mon Aug 18 09:23:53 2003
++++ configure Wed Sep 3 13:12:20 2003
+@@ -1130,10 +1130,4 @@
+ done
+
+- # symlink the mkspecs directory
+- mkdir -p $outpath/mkspecs
+- rm -f $outpath/mkspecs/*
+- ln -s $relpath/mkspecs/* $outpath/mkspecs
+- rm -f $outpath/mkspecs/default
+-
+ # symlink the linguist/doc directory (to make the assistant happy)
+ mkdir -p $outpath/tools/linguist
+@@ -1196,5 +1190,5 @@
+ # find a make command
+ MAKE=
+-for mk in gmake make; do
++for mk in make; do
+ if $WHICH $mk >/dev/null 2>&1; then
+ MAKE=`$WHICH $mk`
+@@ -1422,12 +1416,4 @@
+ fi
+
+-if [ "$PLATFORM_QWS" = "yes" -o "$PLATFORM_QNX" = "yes" ]; then
+- CFG_SM=no
+- MODULES=`echo $MODULES | sed -e 's/opengl//'`
+- PLATFORMS=`find $relpath/mkspecs/qws | sed "s,$relpath/mkspecs/qws/,,"`
+-else
+- PLATFORMS=`find $relpath/mkspecs/ -type f | grep -v qws | sed "s,$relpath/mkspecs/qws/,,"`
+-fi
+-
+ ##if [ "$OPT_CONCURRENT" = "0" ] && echo $MAKEFLAGS | grep '.* *-j[0-9]* *.*' >/dev/null 2>&1; then
+ # OPT_CONCURRENT=`echo $MAKEFLAGS | sed "s,.* *-j\([0-9]*\) *.*,\1,"`
+@@ -2334,6 +2320,5 @@
+ fi
+
+-# build qmake
+-if true; then ###[ '!' -f "$outpath/bin/qmake" ];
++if false; then
+ echo "Creating qmake. Please wait..."
+ rm -f mkspecs/default
+@@ -2713,6 +2698,5 @@
+
+ if [ '!' -z "$I_FLAGS" ]; then
+- QMAKE_VARS="$QMAKE_VARS \"QMAKE_CFLAGS+=$I_FLAGS\""
+- QMAKE_VARS="$QMAKE_VARS \"QMAKE_CXXFLAGS+=$I_FLAGS\""
++ QMAKE_VARS="$QMAKE_VARS \"INCPATH+=`echo $I_FLAGS | sed s,-I,,g`\""
+ fi
+
diff --git a/x11-toolkits/qt33/pkg-plist b/x11-toolkits/qt33/pkg-plist
index 459e195a33c2..4bf476a3cffd 100644
--- a/x11-toolkits/qt33/pkg-plist
+++ b/x11-toolkits/qt33/pkg-plist
@@ -10,12 +10,9 @@ bin/moc
bin/msg2qm
bin/qembed
bin/qm2ts
-bin/qmake
bin/qtconfig
bin/qvfb
bin/uic
-etc/settings/.qt_plugins_3.2rc.lock
-etc/settings/qt_plugins_3.2rc
include/private/qapplication_p.h
include/private/qcolor_p.h
include/private/qcom_p.h
@@ -414,7 +411,7 @@ lib/libqt-mt.prl
lib/libqt-mt.so
lib/libqt-mt.so.3
lib/libqt-mt.so.3.2
-lib/libqt-mt.so.3.2.1
+lib/libqt-mt.so.3.2.3
lib/libqui.prl
lib/libqui.so
lib/libqui.so.1
@@ -629,6 +626,7 @@ share/doc/qt/html/images.html
share/doc/qt/html/index
share/doc/qt/html/index.html
share/doc/qt/html/inputdialogs.png
+share/doc/qt/html/install-mac.html
share/doc/qt/html/install-win.html
share/doc/qt/html/install-x11.html
share/doc/qt/html/installation.html
@@ -656,7 +654,6 @@ share/doc/qt/html/listviews-example.html
share/doc/qt/html/logo32.png
share/doc/qt/html/mac-differences.html
share/doc/qt/html/mail-example.html
-share/doc/qt/html/mailinglists.html
share/doc/qt/html/mainclasses.html
share/doc/qt/html/mainwindow-w.png
share/doc/qt/html/makeqpf.html
@@ -1026,6 +1023,8 @@ share/doc/qt/html/qdatetime.html
share/doc/qt/html/qdatetimeedit-h.html
share/doc/qt/html/qdatetimeedit-members.html
share/doc/qt/html/qdatetimeedit.html
+share/doc/qt/html/qdatetimeeditbase-members.html
+share/doc/qt/html/qdatetimeeditbase.html
share/doc/qt/html/qdeepcopy-h.html
share/doc/qt/html/qdeepcopy-members.html
share/doc/qt/html/qdeepcopy.html
@@ -2128,7 +2127,6 @@ share/doc/qt/html/runion.png
share/doc/qt/html/rxor.png
share/doc/qt/html/scaling.png
share/doc/qt/html/scribble-example.html
-share/doc/qt/html/scripts.html
share/doc/qt/html/scrollview-example.html
share/doc/qt/html/search.png
share/doc/qt/html/session.html
@@ -2340,120 +2338,6 @@ share/doc/qt/html/xml-sax-walkthrough.html
share/doc/qt/html/xml-tools.html
share/doc/qt/html/xml.html
share/doc/qt/html/y2k.html
-share/qt/mkspecs/aix-g++/qmake.conf
-share/qt/mkspecs/aix-g++/qplatformdefs.h
-share/qt/mkspecs/aix-xlc-64/qmake.conf
-share/qt/mkspecs/aix-xlc-64/qplatformdefs.h
-share/qt/mkspecs/aix-xlc/qmake.conf
-share/qt/mkspecs/aix-xlc/qplatformdefs.h
-share/qt/mkspecs/bsdi-g++/qmake.conf
-share/qt/mkspecs/bsdi-g++/qplatformdefs.h
-share/qt/mkspecs/cygwin-g++/qmake.conf
-share/qt/mkspecs/cygwin-g++/qplatformdefs.h
-share/qt/mkspecs/darwin-g++/qmake.conf
-share/qt/mkspecs/darwin-g++/qplatformdefs.h
-share/qt/mkspecs/default/qmake.conf
-share/qt/mkspecs/default/qplatformdefs.h
-share/qt/mkspecs/dgux-g++/qmake.conf
-share/qt/mkspecs/dgux-g++/qplatformdefs.h
-share/qt/mkspecs/freebsd-g++/qmake.conf
-share/qt/mkspecs/freebsd-g++/qplatformdefs.h
-share/qt/mkspecs/hpux-acc-64/qmake.conf
-share/qt/mkspecs/hpux-acc-64/qplatformdefs.h
-share/qt/mkspecs/hpux-acc-o64/qmake.conf
-share/qt/mkspecs/hpux-acc-o64/qplatformdefs.h
-share/qt/mkspecs/hpux-acc/qmake.conf
-share/qt/mkspecs/hpux-acc/qplatformdefs.h
-share/qt/mkspecs/hpux-cc/qmake.conf
-share/qt/mkspecs/hpux-cc/qplatformdefs.h
-share/qt/mkspecs/hpux-g++-64/qmake.conf
-share/qt/mkspecs/hpux-g++-64/qplatformdefs.h
-share/qt/mkspecs/hpux-g++/qmake.conf
-share/qt/mkspecs/hpux-g++/qplatformdefs.h
-share/qt/mkspecs/hpuxi-acc-32/qmake.conf
-share/qt/mkspecs/hpuxi-acc-32/qplatformdefs.h
-share/qt/mkspecs/hpuxi-acc-64/qmake.conf
-share/qt/mkspecs/hpuxi-acc-64/qplatformdefs.h
-share/qt/mkspecs/hurd-g++/qmake.conf
-share/qt/mkspecs/hurd-g++/qplatformdefs.h
-share/qt/mkspecs/irix-cc-64/qmake.conf
-share/qt/mkspecs/irix-cc-64/qplatformdefs.h
-share/qt/mkspecs/irix-cc-o32/qmake.conf
-share/qt/mkspecs/irix-cc-o32/qplatformdefs.h
-share/qt/mkspecs/irix-cc/qmake.conf
-share/qt/mkspecs/irix-cc/qplatformdefs.h
-share/qt/mkspecs/irix-g++/qmake.conf
-share/qt/mkspecs/irix-g++/qplatformdefs.h
-share/qt/mkspecs/linux-cxx/qmake.conf
-share/qt/mkspecs/linux-cxx/qplatformdefs.h
-share/qt/mkspecs/linux-g++/qmake.conf
-share/qt/mkspecs/linux-g++/qplatformdefs.h
-share/qt/mkspecs/linux-icc/qmake.conf
-share/qt/mkspecs/linux-icc/qplatformdefs.h
-share/qt/mkspecs/linux-kcc/qmake.conf
-share/qt/mkspecs/linux-kcc/qplatformdefs.h
-share/qt/mkspecs/linux-kylix/qmake.conf
-share/qt/mkspecs/linux-kylix/qplatformdefs.h
-share/qt/mkspecs/linux-pgcc/qmake.conf
-share/qt/mkspecs/linux-pgcc/qplatformdefs.h
-share/qt/mkspecs/lynxos-g++/qmake.conf
-share/qt/mkspecs/lynxos-g++/qplatformdefs.h
-share/qt/mkspecs/macx-g++/Info.plist.app
-share/qt/mkspecs/macx-g++/qmake.conf
-share/qt/mkspecs/macx-g++/qplatformdefs.h
-share/qt/mkspecs/macx-mwerks/mwerkstmpl.xml
-share/qt/mkspecs/macx-mwerks/qmake.conf
-share/qt/mkspecs/macx-mwerks/qplatformdefs.h
-share/qt/mkspecs/macx-pbuilder/Info.plist.app
-share/qt/mkspecs/macx-pbuilder/qmake.conf
-share/qt/mkspecs/macx-pbuilder/qplatformdefs.h
-share/qt/mkspecs/netbsd-g++/qmake.conf
-share/qt/mkspecs/netbsd-g++/qplatformdefs.h
-share/qt/mkspecs/openbsd-g++/qmake.conf
-share/qt/mkspecs/openbsd-g++/qplatformdefs.h
-share/qt/mkspecs/qnx-g++/qmake.conf
-share/qt/mkspecs/qnx-g++/qplatformdefs.h
-share/qt/mkspecs/reliant-cds-64/qmake.conf
-share/qt/mkspecs/reliant-cds-64/qplatformdefs.h
-share/qt/mkspecs/reliant-cds/qmake.conf
-share/qt/mkspecs/reliant-cds/qplatformdefs.h
-share/qt/mkspecs/sco-cc/qmake.conf
-share/qt/mkspecs/sco-cc/qplatformdefs.h
-share/qt/mkspecs/sco-g++/qmake.conf
-share/qt/mkspecs/sco-g++/qplatformdefs.h
-share/qt/mkspecs/solaris-cc-64/qmake.conf
-share/qt/mkspecs/solaris-cc-64/qplatformdefs.h
-share/qt/mkspecs/solaris-cc/qmake.conf
-share/qt/mkspecs/solaris-cc/qplatformdefs.h
-share/qt/mkspecs/solaris-g++-64/qmake.conf
-share/qt/mkspecs/solaris-g++-64/qplatformdefs.h
-share/qt/mkspecs/solaris-g++/qmake.conf
-share/qt/mkspecs/solaris-g++/qplatformdefs.h
-share/qt/mkspecs/tru64-cxx/qmake.conf
-share/qt/mkspecs/tru64-cxx/qplatformdefs.h
-share/qt/mkspecs/tru64-g++/qmake.conf
-share/qt/mkspecs/tru64-g++/qplatformdefs.h
-share/qt/mkspecs/unixware-cc/qmake.conf
-share/qt/mkspecs/unixware-cc/qplatformdefs.h
-share/qt/mkspecs/unixware-g++/qmake.conf
-share/qt/mkspecs/unixware-g++/qplatformdefs.h
-share/qt/mkspecs/win32-borland/qmake.conf
-share/qt/mkspecs/win32-borland/qplatformdefs.h
-share/qt/mkspecs/win32-g++/qmake.conf
-share/qt/mkspecs/win32-g++/qplatformdefs.h
-share/qt/mkspecs/win32-icc/qmake.conf
-share/qt/mkspecs/win32-icc/qplatformdefs.h
-share/qt/mkspecs/win32-icc/win32app.dsp
-share/qt/mkspecs/win32-icc/win32dll.dsp
-share/qt/mkspecs/win32-icc/win32lib.dsp
-share/qt/mkspecs/win32-msvc.net/qmake.conf
-share/qt/mkspecs/win32-msvc.net/qplatformdefs.h
-share/qt/mkspecs/win32-msvc/qmake.conf
-share/qt/mkspecs/win32-msvc/qplatformdefs.h
-share/qt/mkspecs/win32-msvc/win32app.dsp
-share/qt/mkspecs/win32-msvc/win32dll.dsp
-share/qt/mkspecs/win32-msvc/win32lib.dsp
-share/qt/mkspecs/win32-watcom/qmake.conf
share/qt/phrasebooks/danish.qph
share/qt/phrasebooks/dutch.qph
share/qt/phrasebooks/finnish.qph
@@ -2477,65 +2361,10 @@ translations/qt_ru.qm
@dirrm translations
@dirrm share/qt/templates
@dirrm share/qt/phrasebooks
-@dirrm share/qt/mkspecs/win32-watcom
-@dirrm share/qt/mkspecs/win32-msvc.net
-@dirrm share/qt/mkspecs/win32-msvc
-@dirrm share/qt/mkspecs/win32-icc
-@dirrm share/qt/mkspecs/win32-g++
-@dirrm share/qt/mkspecs/win32-borland
-@dirrm share/qt/mkspecs/unixware-g++
-@dirrm share/qt/mkspecs/unixware-cc
-@dirrm share/qt/mkspecs/tru64-g++
-@dirrm share/qt/mkspecs/tru64-cxx
-@dirrm share/qt/mkspecs/solaris-g++-64
-@dirrm share/qt/mkspecs/solaris-g++
-@dirrm share/qt/mkspecs/solaris-cc-64
-@dirrm share/qt/mkspecs/solaris-cc
-@dirrm share/qt/mkspecs/sco-g++
-@dirrm share/qt/mkspecs/sco-cc
-@dirrm share/qt/mkspecs/reliant-cds-64
-@dirrm share/qt/mkspecs/reliant-cds
-@dirrm share/qt/mkspecs/qnx-g++
-@dirrm share/qt/mkspecs/openbsd-g++
-@dirrm share/qt/mkspecs/netbsd-g++
-@dirrm share/qt/mkspecs/macx-pbuilder
-@dirrm share/qt/mkspecs/macx-mwerks
-@dirrm share/qt/mkspecs/macx-g++
-@dirrm share/qt/mkspecs/lynxos-g++
-@dirrm share/qt/mkspecs/linux-pgcc
-@dirrm share/qt/mkspecs/linux-kylix
-@dirrm share/qt/mkspecs/linux-kcc
-@dirrm share/qt/mkspecs/linux-icc
-@dirrm share/qt/mkspecs/linux-g++
-@dirrm share/qt/mkspecs/linux-cxx
-@dirrm share/qt/mkspecs/irix-g++
-@dirrm share/qt/mkspecs/irix-cc-o32
-@dirrm share/qt/mkspecs/irix-cc-64
-@dirrm share/qt/mkspecs/irix-cc
-@dirrm share/qt/mkspecs/hurd-g++
-@dirrm share/qt/mkspecs/hpuxi-acc-64
-@dirrm share/qt/mkspecs/hpuxi-acc-32
-@dirrm share/qt/mkspecs/hpux-g++-64
-@dirrm share/qt/mkspecs/hpux-g++
-@dirrm share/qt/mkspecs/hpux-cc
-@dirrm share/qt/mkspecs/hpux-acc-o64
-@dirrm share/qt/mkspecs/hpux-acc-64
-@dirrm share/qt/mkspecs/hpux-acc
-@dirrm share/qt/mkspecs/freebsd-g++
-@dirrm share/qt/mkspecs/dgux-g++
-@dirrm share/qt/mkspecs/default
-@dirrm share/qt/mkspecs/darwin-g++
-@dirrm share/qt/mkspecs/cygwin-g++
-@dirrm share/qt/mkspecs/bsdi-g++
-@dirrm share/qt/mkspecs/aix-xlc-64
-@dirrm share/qt/mkspecs/aix-xlc
-@dirrm share/qt/mkspecs/aix-g++
-@dirrm share/qt/mkspecs
@dirrm share/qt
@dirrm share/doc/qt/html
@dirrm share/doc/qt
@dirrm lib/plugins/designer
@dirrm lib/plugins
-@dirrm lib/pkgconfig
+@unexec rmdir %D/lib/pkgconfig
@dirrm include/private
-@dirrm etc/settings