aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-declarative-test
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-03-08 11:35:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-03-08 11:36:03 +0000
commitf0ff6102342d15cb32b652bf743f806e28dbbf05 (patch)
tree31072ecc2b3d964897e4594a20d12eba8be818e7 /x11-toolkits/qt5-declarative-test
parent7b3c5065c5c0bb3a61aebc1e927aedbbc8fc2c4c (diff)
downloadports-f0ff6102342d15cb32b652bf743f806e28dbbf05.tar.gz
ports-f0ff6102342d15cb32b652bf743f806e28dbbf05.zip
Diffstat (limited to 'x11-toolkits/qt5-declarative-test')
-rw-r--r--x11-toolkits/qt5-declarative-test/Makefile1
-rw-r--r--x11-toolkits/qt5-declarative-test/files/patch-src_imports_imports.pro38
-rw-r--r--x11-toolkits/qt5-declarative-test/files/patch-src_src.pro7
-rw-r--r--x11-toolkits/qt5-declarative-test/pkg-plist7
4 files changed, 50 insertions, 3 deletions
diff --git a/x11-toolkits/qt5-declarative-test/Makefile b/x11-toolkits/qt5-declarative-test/Makefile
index 5f4145b1e7aa..5f2efafc6478 100644
--- a/x11-toolkits/qt5-declarative-test/Makefile
+++ b/x11-toolkits/qt5-declarative-test/Makefile
@@ -1,5 +1,6 @@
PORTNAME= declarative-test
PORTVERSION= ${QT5_VERSION}${QT5_KDE_PATCH}
+PORTREVISION= 1
CATEGORIES= x11-toolkits
PKGNAMEPREFIX= qt5-
diff --git a/x11-toolkits/qt5-declarative-test/files/patch-src_imports_imports.pro b/x11-toolkits/qt5-declarative-test/files/patch-src_imports_imports.pro
new file mode 100644
index 000000000000..2c5e5409b304
--- /dev/null
+++ b/x11-toolkits/qt5-declarative-test/files/patch-src_imports_imports.pro
@@ -0,0 +1,38 @@
+--- src/imports/imports.pro.orig 2022-03-08 11:32:59 UTC
++++ src/imports/imports.pro
+@@ -1,34 +1,4 @@
+ TEMPLATE = subdirs
+ QT_FOR_CONFIG += qml-private
+
+-SUBDIRS += \
+- builtins \
+- qtqml \
+- models \
+- labsmodels
+-
+-qtConfig(qml-itemmodel): SUBDIRS += folderlistmodel
+-qtConfig(qml-worker-script): SUBDIRS += workerscript
+-qtHaveModule(sql): SUBDIRS += localstorage
+-qtConfig(settings): SUBDIRS += settings
+-qtConfig(statemachine): SUBDIRS += statemachine
+-
+-qtHaveModule(quick) {
+- QT_FOR_CONFIG += quick-private
+-
+- SUBDIRS += \
+- labsanimation \
+- layouts \
+- qtquick2 \
+- window
+-
+- qtConfig(quick-shadereffect): SUBDIRS += wavefrontmesh
+-
+- qtHaveModule(testlib): SUBDIRS += testlib
+- qtConfig(systemsemaphore): SUBDIRS += sharedimage
+- qtConfig(quick-particles): \
+- SUBDIRS += particles
+-
+- qtConfig(quick-path): SUBDIRS += shapes
+-}
+-
++SUBDIRS= testlib
diff --git a/x11-toolkits/qt5-declarative-test/files/patch-src_src.pro b/x11-toolkits/qt5-declarative-test/files/patch-src_src.pro
index 40059dc2adb5..40804d971690 100644
--- a/x11-toolkits/qt5-declarative-test/files/patch-src_src.pro
+++ b/x11-toolkits/qt5-declarative-test/files/patch-src_src.pro
@@ -1,6 +1,6 @@
---- src/src.pro.orig 2021-09-24 07:19:35 UTC
+--- src/src.pro.orig 2021-11-16 21:43:56 UTC
+++ src/src.pro
-@@ -7,40 +7,6 @@ QT_FOR_CONFIG += qml qml-private quick-private
+@@ -7,40 +7,7 @@ QT_FOR_CONFIG += qml qml-private quick-private
# Otherwise we cannot compile qmltyperegistrar
requires(qtConfig(commandlineparser))
@@ -39,6 +39,7 @@
- QT_FOR_CONFIG += network
- qtConfig(thread):qtConfig(localserver):qtConfig(qml-debug): SUBDIRS += qmldebug
-}
-+SUBDIRS += qmltest
++SUBDIRS += qmltest \
++ imports
DISTFILES += sync.profile configure.json
diff --git a/x11-toolkits/qt5-declarative-test/pkg-plist b/x11-toolkits/qt5-declarative-test/pkg-plist
index fa23067a4040..427caa024163 100644
--- a/x11-toolkits/qt5-declarative-test/pkg-plist
+++ b/x11-toolkits/qt5-declarative-test/pkg-plist
@@ -22,4 +22,11 @@
%%QT_MKSPECDIR%%/modules/qt_lib_qmltest_private.pri
%%QT_QMLDIR%%/Qt/test/qtestroot/plugins.qmltypes
%%QT_QMLDIR%%/Qt/test/qtestroot/qmldir
+%%QT_QMLDIR%%/QtTest/SignalSpy.qml
+%%QT_QMLDIR%%/QtTest/TestCase.qml
+%%QT_QMLDIR%%/QtTest/libqmltestplugin.so
+%%QT_QMLDIR%%/QtTest/libqmltestplugin.so.debug
+%%QT_QMLDIR%%/QtTest/plugins.qmltypes
+%%QT_QMLDIR%%/QtTest/qmldir
+%%QT_QMLDIR%%/QtTest/testlogger.js
libdata/pkgconfig/Qt5QuickTest.pc