aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-gtkplatform
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-08 21:59:15 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-08 21:59:15 +0000
commitee9a6bfbf36e1471f045988c4672f7008e03ad6d (patch)
tree4f6a76ee070ed286f35be21355374644f8ca6881 /x11-toolkits/qt5-gtkplatform
parentf09f8484f08f59450273ec1a84bac6485fae19d1 (diff)
downloadports-ee9a6bfbf36e1471f045988c4672f7008e03ad6d.tar.gz
ports-ee9a6bfbf36e1471f045988c4672f7008e03ad6d.zip
New port: x11-toolkits/qt5-gtkplatform
gtkplatform is a Qt Platform Abstraction plugin providing Qt applications with the capability to use GTK+ as a host toolkit. It lets Qt applications render with native GTK+ menus, and use GTK+ for input (mouse, keyboard, touch), and getting window content on screen, the same as it uses e.g. Cocoa on macOS. WWW: https://github.com/CrimsonAS/gtkplatform PR: 224453 Submitted by: Greg V <greg@unrelenting.technology>
Notes
Notes: svn path=/head/; revision=458486
Diffstat (limited to 'x11-toolkits/qt5-gtkplatform')
-rw-r--r--x11-toolkits/qt5-gtkplatform/Makefile34
-rw-r--r--x11-toolkits/qt5-gtkplatform/distinfo3
-rw-r--r--x11-toolkits/qt5-gtkplatform/pkg-descr8
-rw-r--r--x11-toolkits/qt5-gtkplatform/pkg-plist2
4 files changed, 47 insertions, 0 deletions
diff --git a/x11-toolkits/qt5-gtkplatform/Makefile b/x11-toolkits/qt5-gtkplatform/Makefile
new file mode 100644
index 000000000000..dca8d8c816c1
--- /dev/null
+++ b/x11-toolkits/qt5-gtkplatform/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= gtkplatform
+DISTVERSION= 0.2.2
+CATEGORIES= x11-toolkits
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= GTK platform backend for Qt 5
+
+LICENSE= LGPL3 GPLv2+
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libinput.so:x11/libinput \
+ libmtdev.so:devel/libmtdev \
+ libnotify.so:devel/libnotify \
+ libudev.so:devel/libudev-devd \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= qmake:outsource pkgconfig
+USE_GNOME= gtk30 cairo gdkpixbuf2
+USE_QT5= buildtools_build core gui widgets dbus
+USE_XORG= x11 xext xrender
+USE_GL= gl egl
+
+USE_GITHUB= yes
+GH_ACCOUNT= CrimsonAS
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/qt5/plugins/platforms/libqgtk.so
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qt5-gtkplatform/distinfo b/x11-toolkits/qt5-gtkplatform/distinfo
new file mode 100644
index 000000000000..363ec12d7968
--- /dev/null
+++ b/x11-toolkits/qt5-gtkplatform/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515330807
+SHA256 (CrimsonAS-gtkplatform-0.2.2_GH0.tar.gz) = 09110aa247cf7c01fc84d2f35d02b2f9c582a7b04cbff6de0a5afb2a22eae809
+SIZE (CrimsonAS-gtkplatform-0.2.2_GH0.tar.gz) = 61045
diff --git a/x11-toolkits/qt5-gtkplatform/pkg-descr b/x11-toolkits/qt5-gtkplatform/pkg-descr
new file mode 100644
index 000000000000..e2af28b4a0a9
--- /dev/null
+++ b/x11-toolkits/qt5-gtkplatform/pkg-descr
@@ -0,0 +1,8 @@
+gtkplatform is a Qt Platform Abstraction plugin providing Qt applications with
+the capability to use GTK+ as a host toolkit.
+
+It lets Qt applications render with native GTK+ menus, and use GTK+ for input
+(mouse, keyboard, touch), and getting window content on screen, the same as it
+uses e.g. Cocoa on macOS.
+
+WWW: https://github.com/CrimsonAS/gtkplatform
diff --git a/x11-toolkits/qt5-gtkplatform/pkg-plist b/x11-toolkits/qt5-gtkplatform/pkg-plist
new file mode 100644
index 000000000000..2cee35a4e587
--- /dev/null
+++ b/x11-toolkits/qt5-gtkplatform/pkg-plist
@@ -0,0 +1,2 @@
+lib/cmake/Qt5Gui/Qt5Gui_QGtkIntegrationPlugin.cmake
+%%QT_PLUGINDIR%%/platforms/libqgtk.so