aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-gui
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-02-20 18:31:31 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-02-20 18:31:31 +0000
commit48249f104e80680f36280b54657528c9d7af120b (patch)
treebc5a2437c81ffd56cf37b5ec830b399fd83aad99 /x11-toolkits/qt5-gui
parent03ecbb08f6a48f7492b6c34b073e8ad1332c1ab8 (diff)
downloadports-48249f104e80680f36280b54657528c9d7af120b.tar.gz
ports-48249f104e80680f36280b54657528c9d7af120b.zip
Add mesa-dri dependency for qt5-gui
There are cases (headless, no xorg-server) where a qt5-gui application still needs to run. It can use swrast, but only if that is installed. Add the mesa-dri dependency to make that happen automatically. For "normal" Qt5 usage, that is, Qt5 on the desktop, xorg-server already pulls this in. The only change is for systems with no X11, no Wayland, but with Qt5 GUI applications. PR: 241490 Submitted by: madpilot Reported by: madpilot
Notes
Notes: svn path=/head/; revision=566177
Diffstat (limited to 'x11-toolkits/qt5-gui')
-rw-r--r--x11-toolkits/qt5-gui/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index 442da86d4955..019dbb030f78 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gui
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits graphics
PKGNAMEPREFIX= qt5-
@@ -27,6 +27,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libxcb.so:x11/libxcb \
libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:graphics/vulkan-headers \
+ ${LOCALBASE}/libdata/pkgconfig/dri.pc:graphics/mesa-dri \
xdg-open:devel/xdg-utils
USES= compiler:c++11-lang gl gnome jpeg localbase \