aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qtermwidget
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-08-23 15:11:50 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-08-23 15:11:50 +0000
commit0371615c830ad48aca229118b79d125b010a5a53 (patch)
tree4afe51f3365217e4ab28dbb256bdda72d54b8a33 /x11-toolkits/qtermwidget
parentb730285ee0d8c177311fe2054b453dc6762fd29a (diff)
downloadports-0371615c830ad48aca229118b79d125b010a5a53.tar.gz
ports-0371615c830ad48aca229118b79d125b010a5a53.zip
Notes
Diffstat (limited to 'x11-toolkits/qtermwidget')
-rw-r--r--x11-toolkits/qtermwidget/Makefile24
-rw-r--r--x11-toolkits/qtermwidget/distinfo3
-rw-r--r--x11-toolkits/qtermwidget/files/patch-cmake_create__pkgconfig__file.cmake10
-rw-r--r--x11-toolkits/qtermwidget/pkg-descr6
-rw-r--r--x11-toolkits/qtermwidget/pkg-plist36
5 files changed, 79 insertions, 0 deletions
diff --git a/x11-toolkits/qtermwidget/Makefile b/x11-toolkits/qtermwidget/Makefile
new file mode 100644
index 000000000000..2549fccd14ba
--- /dev/null
+++ b/x11-toolkits/qtermwidget/Makefile
@@ -0,0 +1,24 @@
+# Created by: Jason Bacon <bacon4000@gmail.com>
+# $FreeBSD$
+
+PORTNAME= qtermwidget
+PORTVERSION= 0.6.0
+CATEGORIES= x11-toolkits
+
+MAINTAINER= bacon4000@gmail.com
+COMMENT= Terminal widget for QTerminal
+
+LICENSE= GPLv2
+
+USES= cmake:outsource compiler:c++11-lang pkgconfig
+USE_LDCONFIG= yes
+USE_QT5= buildtools_build core gui qmake_build widgets
+
+CMAKE_ARGS+= -DBUILD_DESIGNER_PLUGIN:BOOL=OFF -DUSE_QT5:BOOL=ON
+
+CFLAGS+= -DHAVE_UTEMPTER
+
+USE_GITHUB= yes
+GH_ACCOUNT= lxde
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qtermwidget/distinfo b/x11-toolkits/qtermwidget/distinfo
new file mode 100644
index 000000000000..92de27ab910a
--- /dev/null
+++ b/x11-toolkits/qtermwidget/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465411660
+SHA256 (lxde-qtermwidget-0.6.0_GH0.tar.gz) = 0b2d59221881fdf3f47d3417e2edcbbe1435873754135e697df9f7f661d7620b
+SIZE (lxde-qtermwidget-0.6.0_GH0.tar.gz) = 196611
diff --git a/x11-toolkits/qtermwidget/files/patch-cmake_create__pkgconfig__file.cmake b/x11-toolkits/qtermwidget/files/patch-cmake_create__pkgconfig__file.cmake
new file mode 100644
index 000000000000..2a478ea2d530
--- /dev/null
+++ b/x11-toolkits/qtermwidget/files/patch-cmake_create__pkgconfig__file.cmake
@@ -0,0 +1,10 @@
+--- cmake/create_pkgconfig_file.cmake.orig 2014-10-21 15:47:40 UTC
++++ cmake/create_pkgconfig_file.cmake
+@@ -25,5 +25,6 @@ macro (create_pkgconfig_file name desc r
+ "\n"
+ )
+
+- install(FILES ${_pkgfname} DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
++ # Use libdata rather than CMAKE_INSTALL_LIBDIR for pkgconfig on FreeBSD
++ install(FILES ${_pkgfname} DESTINATION libdata/pkgconfig)
+ endmacro()
diff --git a/x11-toolkits/qtermwidget/pkg-descr b/x11-toolkits/qtermwidget/pkg-descr
new file mode 100644
index 000000000000..ecdfb4e0f287
--- /dev/null
+++ b/x11-toolkits/qtermwidget/pkg-descr
@@ -0,0 +1,6 @@
+QTermWidget is an opensource project originally based on KDE4 Konsole
+application. The main goal of this project is to provide unicode-enabled,
+embeddable Qt widget for using as a built-in console (or terminal emulation
+widget).
+
+WWW: https://github.com/lxde/qtermwidget
diff --git a/x11-toolkits/qtermwidget/pkg-plist b/x11-toolkits/qtermwidget/pkg-plist
new file mode 100644
index 000000000000..f71425883a06
--- /dev/null
+++ b/x11-toolkits/qtermwidget/pkg-plist
@@ -0,0 +1,36 @@
+include/qtermwidget5/Filter.h
+include/qtermwidget5/qtermwidget.h
+lib/libqtermwidget5.so
+lib/libqtermwidget5.so.0
+lib/libqtermwidget5.so.0.6.0
+libdata/pkgconfig/qtermwidget5.pc
+share/cmake/qtermwidget5/qtermwidget5-config.cmake
+share/cmake/qtermwidget5/qtermwidget5_use.cmake
+%%DATADIR%%5/color-schemes/BlackOnLightYellow.schema
+%%DATADIR%%5/color-schemes/BlackOnRandomLight.colorscheme
+%%DATADIR%%5/color-schemes/BlackOnWhite.schema
+%%DATADIR%%5/color-schemes/DarkPastels.colorscheme
+%%DATADIR%%5/color-schemes/GreenOnBlack.colorscheme
+%%DATADIR%%5/color-schemes/Linux.colorscheme
+%%DATADIR%%5/color-schemes/WhiteOnBlack.schema
+%%DATADIR%%5/color-schemes/historic/BlackOnLightColor.schema
+%%DATADIR%%5/color-schemes/historic/DarkPicture.schema
+%%DATADIR%%5/color-schemes/historic/GreenOnBlack.schema
+%%DATADIR%%5/color-schemes/historic/GreenTint.schema
+%%DATADIR%%5/color-schemes/historic/GreenTint_MC.schema
+%%DATADIR%%5/color-schemes/historic/LightPicture.schema
+%%DATADIR%%5/color-schemes/historic/Linux.schema
+%%DATADIR%%5/color-schemes/historic/Transparent.schema
+%%DATADIR%%5/color-schemes/historic/Transparent_MC.schema
+%%DATADIR%%5/color-schemes/historic/Transparent_darkbg.schema
+%%DATADIR%%5/color-schemes/historic/Transparent_lightbg.schema
+%%DATADIR%%5/color-schemes/historic/XTerm.schema
+%%DATADIR%%5/color-schemes/historic/syscolor.schema
+%%DATADIR%%5/color-schemes/historic/vim.schema
+%%DATADIR%%5/kb-layouts/default.keytab
+%%DATADIR%%5/kb-layouts/historic/vt100.keytab
+%%DATADIR%%5/kb-layouts/historic/x11r5.keytab
+%%DATADIR%%5/kb-layouts/linux.keytab
+%%DATADIR%%5/kb-layouts/macbook.keytab
+%%DATADIR%%5/kb-layouts/solaris.keytab
+%%DATADIR%%5/kb-layouts/vt420pc.keytab