aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qwt5/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-05-22 16:09:41 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-05-22 16:09:41 +0000
commitfdac53e4b13895cb4ef9f3cf6377bd493d397b76 (patch)
tree64a3a68f55b5eb3978b0b4d01b2622a0bc66a0cb /x11-toolkits/qwt5/Makefile
parentc1c2bba4cd297f49e0af3c897937224f016adde5 (diff)
Notes
Diffstat (limited to 'x11-toolkits/qwt5/Makefile')
-rw-r--r--x11-toolkits/qwt5/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/x11-toolkits/qwt5/Makefile b/x11-toolkits/qwt5/Makefile
index 79e71d16c5fb..e519216c895e 100644
--- a/x11-toolkits/qwt5/Makefile
+++ b/x11-toolkits/qwt5/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qwt
-PORTVERSION= 5.2.0
-PORTREVISION= 1
+PORTVERSION= 5.2.1
CATEGORIES= x11-toolkits
MASTER_SITES= SF
@@ -21,6 +20,7 @@ USE_GMAKE= yes
QMAKE_ARGS+= -unix -recursive PREFIX=${PREFIX}
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
OPTIONS= DESIGNER_PLUGIN "Install plugin for Qt Designer" on
@@ -39,13 +39,10 @@ PLIST_SUB+= DESIGNER_PLUGIN="@comment "
.endif
do-configure:
- (cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKE_ARGS})
-
-post-configure:
- ${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
- 's|^CC .*|CC=${CC}|; s|^CXX .*|CXX=${CXX}|; s|^LINK .*|LINK=${CXX}|'
+ (cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS})
post-install:
+ ${MKDIR} ${PREFIX}/man/man3
${INSTALL_MAN} ${WRKSRC}/doc/man/man3/Qwt* ${PREFIX}/man/man3
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
.if !defined(NOPORTDOCS)