aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/scintilla
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-01-27 23:53:31 +0000
committerSteve Wills <swills@FreeBSD.org>2019-01-27 23:53:31 +0000
commit944b17837236d3c119cd8ff15e4b12ed41d64a61 (patch)
tree8feeca563178d6d44de11b426595c8df7e33d48d /x11-toolkits/scintilla
parente154c7addda29bb11385b4e09d1232e748ccff28 (diff)
downloadports-944b17837236d3c119cd8ff15e4b12ed41d64a61.tar.gz
ports-944b17837236d3c119cd8ff15e4b12ed41d64a61.zip
x11-toolkits/scintilla: update to 4.1.0
PR: 228909 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
Notes
Notes: svn path=/head/; revision=491444
Diffstat (limited to 'x11-toolkits/scintilla')
-rw-r--r--x11-toolkits/scintilla/Makefile8
-rw-r--r--x11-toolkits/scintilla/distinfo6
-rw-r--r--x11-toolkits/scintilla/files/patch-makefile30
3 files changed, 18 insertions, 26 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 1842bfd0d4bd..65d315d232b2 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= scintilla
-DISTVERSION= 4.0.2
-PORTREVISION= 1
+DISTVERSION= 4.1.0
CATEGORIES= x11-toolkits
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= scite${PORTVERSION:S/.//g}
@@ -16,9 +15,10 @@ LICENSE_NAME= License for Scintilla and SciTE
LICENSE_FILE= ${WRKSRC}/../License.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
+USES= compiler:c++17-lang gmake iconv pkgconfig tar:tgz
-USES= compiler:c++14-lang gmake iconv pkgconfig tar:tgz
+WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
+CXXSTD= gnu++17
MAKEFILE= makefile
USE_LDCONFIG= yes
USE_GNOME= gtk20
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 56770f8d6f04..489d42556c52 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516053463
-SHA256 (scite402.tgz) = 1f9bb8eccbaed77c110c30c0e6dbaac04b3f62b751a930192b133a7b6f0f29fb
-SIZE (scite402.tgz) = 2424648
+TIMESTAMP = 1529613442
+SHA256 (scite410.tgz) = d1f9cf27b8d44b3d6bab179173a58cdfe76b44f84c8e74aeb85bf16c50148cf7
+SIZE (scite410.tgz) = 2493701
diff --git a/x11-toolkits/scintilla/files/patch-makefile b/x11-toolkits/scintilla/files/patch-makefile
index 10dd6f52b357..2751389f6403 100644
--- a/x11-toolkits/scintilla/files/patch-makefile
+++ b/x11-toolkits/scintilla/files/patch-makefile
@@ -1,24 +1,16 @@
---- makefile.orig 2017-08-16 07:34:01 UTC
+--- makefile.orig 2018-04-10 01:38:39 UTC
+++ makefile
-@@ -9,17 +9,7 @@
+@@ -11,9 +11,7 @@
srcdir ?= .
- .SUFFIXES: .cxx .c .o .h .a .list
--ifdef CLANG
+ ifdef CLANG
-CXX = clang++
CXXWARNFLAGS = -Wall -pedantic -Wno-deprecated-register -Wno-missing-braces
-CC = clang
--# Can choose aspect to sanitize: address and undefined can simply change SANITIZE but for
--# thread also need to create Position Independent Executable -> search online documentation
--SANITIZE = address
--#SANITIZE = undefined
--else
--CXXWARNFLAGS = -Wall -pedantic
--endif
- ARFLAGS = rc
- RANLIB = touch
-
-@@ -48,7 +38,12 @@ DEL = del /q
+ # Can choose aspect to sanitize: address and undefined can simply change SANITIZE but for
+ # thread also need to create Position Independent Executable -> search online documentation
+ SANITIZE = address
+@@ -49,7 +47,12 @@ DEL = del /q
COMPLIB=$(srcdir)\..\bin\scintilla.a
else
DEL = rm -f
@@ -32,16 +24,16 @@
endif
vpath %.h $(srcdir) $(srcdir)/../src $(srcdir)/../include $(srcdir)/../lexlib
-@@ -101,7 +96,7 @@ GLIB_GENMARSHAL_FLAGS = --prefix=scintil
-
- LEXOBJS:=$(addsuffix .o,$(basename $(sort $(notdir $(wildcard $(srcdir)/../lexers/Lex*.cxx)))))
+@@ -87,7 +90,7 @@ CXXTFLAGS:=--std=gnu++17 $(CTFLAGS) $(RE
+ CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
+ MARSHALLER=scintilla-marshal.o
-all: $(COMPLIB)
+all: $(COMPLIB) $(LEXRLIB)
clean:
$(DEL) *.o $(COMPLIB) *.plist
-@@ -122,9 +117,11 @@ $(COMPLIB): Accessor.o CharacterSet.o De
+@@ -123,9 +126,11 @@ $(COMPLIB): Accessor.o CharacterSet.o De
PropSetSimple.o PlatGTK.o \
KeyMap.o LineMarker.o PositionCache.o ScintillaGTK.o ScintillaGTKAccessible.o CellBuffer.o CharacterCategory.o ViewStyle.o \
RESearch.o RunStyles.o Selection.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \