aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/scintilla
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-10-29 20:05:37 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-10-29 20:05:37 +0000
commitbf96218fab53a3570b3f463d6f313b84e67b5df7 (patch)
treef6ab38ee4b7c4c6767d6902620211822043af5cb /x11-toolkits/scintilla
parent10e1ec693e906ab30b6ceebdf966496e798299cc (diff)
downloadports-bf96218fab53a3570b3f463d6f313b84e67b5df7.tar.gz
ports-bf96218fab53a3570b3f463d6f313b84e67b5df7.zip
x11-toolkits/scintilla: Update to 4.4.5
* Update Makefile (add PATCH_WRKSRC because I needed to patch some files outside of WRKSRC, add some GNOME Uses that poudriere complained about, remove the pseudo-versioning because it was never being done in the actual compilation anyways, add a way to get a debug build) * Update distinfo * Correct URL in pkg-descr * Remove patch-makefile (due to the PATCH_WRKSRC change) * Add patch-gtk_makefile (due to the PATCH_WRKSRC change) and patch-lexilla_src_makefile * Add patch-src_PositionCache.h, patch-src_Style.cxx and patch-src_Style.h, temporary patches for this version until 4.4.6 comes out to fix compilation with newer compilers * Update pkg-plist Use of ASAN is removed from the build as it was causing an ASAN error for me when trying to run SciTE within a VM due to libGL (which isn't compiled with ASAN, nor is the FreeBSD base system libraries), and the author of Scintilla and SciTE said that it was fine to remove (his thought being that normally Scintilla and SciTE aren't built with Clang, but since it is the default compiler for FreeBSD and I want the software to work, it is better to just not enable ASAN until it is enabled everywhere. The removal of the version number on the libraries was due to consensus on IRC in #bsdports that it wasn't necessary if the software was not originally doing so in the first place. Changelog: https://www.scintilla.org/ScintillaHistory.html PR: 250663 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer) MFH: 2020Q4
Notes
Notes: svn path=/head/; revision=553638
Diffstat (limited to 'x11-toolkits/scintilla')
-rw-r--r--x11-toolkits/scintilla/Makefile28
-rw-r--r--x11-toolkits/scintilla/distinfo6
-rw-r--r--x11-toolkits/scintilla/pkg-descr2
-rw-r--r--x11-toolkits/scintilla/pkg-plist6
4 files changed, 15 insertions, 27 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index b29cbadde151..600a6d28bfa3 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scintilla
-DISTVERSION= 4.3.2
+DISTVERSION= 4.4.5
CATEGORIES= x11-toolkits
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= scite${PORTVERSION:S/.//g}
@@ -17,18 +17,18 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= compiler:c++17-lang gmake gnome iconv pkgconfig tar:tgz
+PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
MAKEFILE= makefile
USE_LDCONFIG= yes
-USE_GNOME= gtk30
+USE_GNOME= cairo gdkpixbuf2 gtk30
MAKE_ENV= LDFLAGS="${LDFLAGS}"
CFLAGS+= -DPIC ${PICFLAG}
-MAJOR= 3
-AGE= 0
-REVISION= 0
-MAKE_ARGS= MAJOR="${MAJOR}" AGE="${AGE}" REVISION="${REVISION}" GTK3=1
-PLIST_SUB= MAJOR="${MAJOR}" AGE="${AGE}" REVISION="${REVISION}"
+MAKE_ARGS= GTK3=1
+.if defined(WITH_DEBUG)
+MAKE_ARGS+= DEBUG=1
+.endif
.include <bsd.port.pre.mk>
@@ -42,18 +42,10 @@ PICFLAG?= -fPIC
PICFLAG?= -fpic
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's| -Os||g' ${WRKSRC}/makefile
-
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/scintilla
- ${INSTALL_DATA} ${WRKSRC}/../include/*.h ${STAGEDIR}${PREFIX}/include/scintilla
-.for f in libscintilla.so libscintilla_lexers.so
- ${INSTALL_LIB} ${WRKSRC}/${f}.${MAJOR}.${AGE}.${REVISION} \
- ${STAGEDIR}${PREFIX}/lib
- (cd ${STAGEDIR}${PREFIX}/lib && \
- ${LN} -sf ${f}.${MAJOR}.${AGE}.${REVISION} ${f}.${MAJOR} && \
- ${LN} -sf ${f}.${MAJOR} ${f})
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/../include/*.h \
+ ${STAGEDIR}${PREFIX}/include/scintilla
+ ${INSTALL_LIB} ${WRKSRC}/../bin/*.so ${STAGEDIR}${PREFIX}/lib
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index a36785ef9c4f..53a72cda383c 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1584222036
-SHA256 (scite432.tgz) = fb7d9d2899b9559b31beca6a695d5b271cc7a6461b218e4a961b4fcd320a798f
-SIZE (scite432.tgz) = 2710026
+TIMESTAMP = 1601836808
+SHA256 (scite445.tgz) = 9d74bde5e4ee18d767b6add5a6b95d7ffcedbcfd017c3df59e16b0785e3521a1
+SIZE (scite445.tgz) = 2777899
diff --git a/x11-toolkits/scintilla/pkg-descr b/x11-toolkits/scintilla/pkg-descr
index 478e52b77c18..8eff55fb4d76 100644
--- a/x11-toolkits/scintilla/pkg-descr
+++ b/x11-toolkits/scintilla/pkg-descr
@@ -8,4 +8,4 @@ use of proportional fonts, bold and italics, multiple foreground and background
colours and multiple fonts. It comes with complete source code and may be used
in any free project or commercial product.
-WWW: http://www.scintilla.org/
+WWW: https://www.scintilla.org/
diff --git a/x11-toolkits/scintilla/pkg-plist b/x11-toolkits/scintilla/pkg-plist
index d1ebfc48b107..f234c6aaee8d 100644
--- a/x11-toolkits/scintilla/pkg-plist
+++ b/x11-toolkits/scintilla/pkg-plist
@@ -5,9 +5,5 @@ include/scintilla/Sci_Position.h
include/scintilla/SciLexer.h
include/scintilla/Scintilla.h
include/scintilla/ScintillaWidget.h
+lib/liblexilla.so
lib/libscintilla.so
-lib/libscintilla.so.%%MAJOR%%
-lib/libscintilla.so.%%MAJOR%%.%%AGE%%.%%REVISION%%
-lib/libscintilla_lexers.so
-lib/libscintilla_lexers.so.%%MAJOR%%
-lib/libscintilla_lexers.so.%%MAJOR%%.%%AGE%%.%%REVISION%%