aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/slingshot
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-04 12:32:52 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-04 12:32:52 +0000
commit2b6e0c42afe448def83a0cfd06dad38b01a1f4eb (patch)
tree18ea42eaa362adadb6a2e66e3719996125d4b053 /x11-toolkits/slingshot
parente9f4be875206de30e024434c14d4bd8c0a631e89 (diff)
downloadports-2b6e0c42afe448def83a0cfd06dad38b01a1f4eb.tar.gz
ports-2b6e0c42afe448def83a0cfd06dad38b01a1f4eb.zip
Notes
Diffstat (limited to 'x11-toolkits/slingshot')
-rw-r--r--x11-toolkits/slingshot/Makefile2
-rw-r--r--x11-toolkits/slingshot/files/patch-lex.yy.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/x11-toolkits/slingshot/Makefile b/x11-toolkits/slingshot/Makefile
index 247398956574..83d7ab8e8055 100644
--- a/x11-toolkits/slingshot/Makefile
+++ b/x11-toolkits/slingshot/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ftp://ftp.x.org/R5contrib/
DISTNAME= SlingShot${PORTVERSION}
EXTRACT_SUFX= .tar.Z
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gagnon__s@videotron.ca
COMMENT= Supplemental Libraries to extend Xview
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
diff --git a/x11-toolkits/slingshot/files/patch-lex.yy.c b/x11-toolkits/slingshot/files/patch-lex.yy.c
new file mode 100644
index 000000000000..f2d202bca317
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-lex.yy.c
@@ -0,0 +1,17 @@
+--- examples/tree/lex.yy.c.orig Tue Apr 15 11:56:25 2003
++++ examples/tree/lex.yy.c Tue Apr 15 11:57:27 2003
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <unistd.h>
+ # define U(x) x
+ # define NLSTATE yyprevious=YYNEWLINE
+ # define BEGIN yybgin = yysvec + 1 +
+@@ -66,7 +67,7 @@
+ int yymorfg;
+ extern char *yysptr, yysbuf[];
+ int yytchar;
+-FILE *yyin = {stdin}, *yyout = {stdout};
++FILE *yyin = STDIN_FILENO, *yyout = STDOUT_FILENO;
+ extern int yylineno;
+ struct yysvf {
+ struct yywork *yystoff;