aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/termit
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-19 17:37:48 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-19 17:37:48 +0000
commit4e0daa187d1a58846c941b18e2823c447424fd4c (patch)
treef8f48dd231987d5a4a30d4bdd722e6c98ef1c9a7 /x11-toolkits/termit
parentc3efd79a4363ad1fb2dedd5204e26f132cfc3f70 (diff)
downloadports-4e0daa187d1a58846c941b18e2823c447424fd4c.tar.gz
ports-4e0daa187d1a58846c941b18e2823c447424fd4c.zip
- Fix package installation removing modified config files
due wrong paths in @exec commands - Order USE_ flags properly
Notes
Notes: svn path=/head/; revision=309251
Diffstat (limited to 'x11-toolkits/termit')
-rw-r--r--x11-toolkits/termit/Makefile12
-rw-r--r--x11-toolkits/termit/pkg-plist8
2 files changed, 8 insertions, 12 deletions
diff --git a/x11-toolkits/termit/Makefile b/x11-toolkits/termit/Makefile
index 76a364d1a1df..c8db9827ab20 100644
--- a/x11-toolkits/termit/Makefile
+++ b/x11-toolkits/termit/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: termit
-# Date created: 2008/06/20
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= termit
PORTVERSION= 2.9.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits gnome
MASTER_SITES= http://cloud.github.com/downloads/nonstop/termit/
@@ -26,13 +22,13 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
xcb:${PORTSDIR}/x11/libxcb
USE_BZIP2= yes
-USE_GNOME= gdkpixbuf2 vte
-USE_LUA= yes
USE_CMAKE= yes
USE_PKGCONFIG= build
USE_ICONV= yes
+USE_LUA= yes
USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
xi xinerama xrandr xrender
+USE_GNOME= gdkpixbuf2 vte
MAKE_JOBS_SAFE= yes
CFLAGS+= -I${LOCALBASE}/include/vte-0.0
diff --git a/x11-toolkits/termit/pkg-plist b/x11-toolkits/termit/pkg-plist
index 8f73b8540b66..b53b2bbe221b 100644
--- a/x11-toolkits/termit/pkg-plist
+++ b/x11-toolkits/termit/pkg-plist
@@ -1,13 +1,13 @@
bin/termit
-@unexec if cmp -s %D/etc/xdg/termit/colormaps.lua.sample %D/etc/xdg/termit/colormaps.lua; then rm -f % %D/etc/xdg/termit/colormaps.lua; fi
+@unexec if cmp -s %D/etc/xdg/termit/colormaps.lua.sample %D/etc/xdg/termit/colormaps.lua; then rm -f %D/etc/xdg/termit/colormaps.lua; fi
etc/xdg/termit/colormaps.lua.sample
-@exec if [ ! -f %D/etc/colormaps.lua ] ; then cp -p %D/%F %B/colormaps.lua; fi
+@exec if [ ! -f %D/etc/xdg/termit/colormaps.lua ] ; then cp -p %D/%F %B/colormaps.lua; fi
@unexec if cmp -s %D/etc/xdg/termit/rc.lua.sample %D/etc/xdg/termit/rc.lua; then rm -f %D/etc/xdg/termit/rc.lua; fi
etc/xdg/termit/rc.lua.sample
-@exec if [ ! -f %D/etc/rc.lua ] ; then cp -p %D/%F %B/rc.lua; fi
+@exec if [ ! -f %D/etc/xdg/termit/rc.lua ] ; then cp -p %D/%F %B/rc.lua; fi
@unexec if cmp -s %D/etc/xdg/termit/utils.lua.sample %D/etc/xdg/termit/utils.lua; then rm -f %D/etc/xdg/termit/utils.lua; fi
etc/xdg/termit/utils.lua.sample
-@exec if [ ! -f %D/etc/utils.lua ] ; then cp -p %D/%F %B/utils.lua; fi
+@exec if [ ! -f %D/etc/xdg/termit/utils.lua ] ; then cp -p %D/%F %B/utils.lua; fi
share/applications/termit.desktop
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/lua_api.txt