aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tix/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-13 15:42:49 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-13 15:42:49 +0000
commita78c39b47ee3d1a97c91bbbdd241873574b762a7 (patch)
tree673dbd4d524811daaa302e2ed43baddf17a8b2a9 /x11-toolkits/tix/Makefile
parent91313616126bd2b143fe6649a55e1c87c47d757e (diff)
downloadports-a78c39b47ee3d1a97c91bbbdd241873574b762a7.tar.gz
ports-a78c39b47ee3d1a97c91bbbdd241873574b762a7.zip
Notes
Diffstat (limited to 'x11-toolkits/tix/Makefile')
-rw-r--r--x11-toolkits/tix/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/x11-toolkits/tix/Makefile b/x11-toolkits/tix/Makefile
index df8ac7e3cefe..1f7c95af6a61 100644
--- a/x11-toolkits/tix/Makefile
+++ b/x11-toolkits/tix/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tix
-# Date created: 22 December 1996
-# Whom: Thomas Gellekum <tg@freebsd.org>
-#
+# Created by: Thomas Gellekum <tg@freebsd.org>
# $FreeBSD$
-#
PORTNAME= tix
PORTVERSION= 8.4.3
@@ -23,7 +19,9 @@ CONFIGURE_ARGS= --enable-shared --enable-sam \
--with-tclconfig="${TCL_LIBDIR}" \
--with-tkconfig="${TK_LIBDIR}" \
--with-tclinclude="${TCL_INCLUDEDIR}" \
- --with-tkinclude="${TK_INCLUDEDIR}"
+ --with-tkinclude="${TK_INCLUDEDIR}" \
+ --prefix=${PREFIX} \
+ --exec-prefix=${PREFIX}
# this should probably be added to bsd.port.mk
CONFIGURE_ENV= PREFIX=${PREFIX}
MANN= TixIntro.n compound.n pixmap.n tix.n tixBalloon.n \
@@ -49,7 +47,7 @@ pre-extract:
pre-configure:
@(cd ${WRKSRC} && \
CC="${CC}" ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS}" \
- INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
+ INSTALL="${INSTALL} -c -o ${BINOWN} -g ${BINGRP}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})