aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tkdnd
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-11-01 06:39:12 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-11-01 06:39:12 +0000
commitb2e99e2884209b630635c07867322ddf861c1709 (patch)
tree849a6fbb19dc6a06a22c4c65501e6e51c7118653 /x11-toolkits/tkdnd
parent297e975bfc2aa4130436fee8a7cd9bfac7faccf4 (diff)
downloadports-b2e99e2884209b630635c07867322ddf861c1709.tar.gz
ports-b2e99e2884209b630635c07867322ddf861c1709.zip
Add port x11-toolkits/tkdnd:
tkdnd is an extension that adds native drag & drop capabilities to the tk toolkit. It can be used with any tk version equal or greater to 8.4 and currently only the UNIX (X-Windows) and Microsoft Windows operating systems are supported. Under unix the drag & drop protocol in use is the XDND protocol version 4 (also used by the QT toolkit, KDE & GNOME Desktops). WWW: http://www.iit.demokritos.gr/~petasis/Tcl/tkDND/tkDND.html
Notes
Notes: svn path=/head/; revision=175997
Diffstat (limited to 'x11-toolkits/tkdnd')
-rw-r--r--x11-toolkits/tkdnd/Makefile39
-rw-r--r--x11-toolkits/tkdnd/distinfo3
-rw-r--r--x11-toolkits/tkdnd/pkg-descr8
-rw-r--r--x11-toolkits/tkdnd/pkg-plist5
4 files changed, 55 insertions, 0 deletions
diff --git a/x11-toolkits/tkdnd/Makefile b/x11-toolkits/tkdnd/Makefile
new file mode 100644
index 000000000000..2d55e16d37af
--- /dev/null
+++ b/x11-toolkits/tkdnd/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: tkdnd
+# Date created: 14 October 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tkdnd
+PORTVERSION= 1.0
+DISTVERSION= 1.0.20040304
+CATEGORIES= x11-toolkits tk84
+MASTER_SITES= CSME
+# Distfile prepared from SourceForge CVS
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Native drag and drop capabilities
+
+LIB_DEPENDS= tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+
+USE_BZIP2= yes
+USE_TK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR} \
+ --with-tclinclude=${TCL_INCLUDEDIR} --with-tkinclude=${TK_INCLUDEDIR} --enable-shared
+CPPFLAGS= -I${TK_INCLUDEDIR}/generic -I${TCL_INCLUDEDIR}/generic
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
+TKPKG= ${PORTNAME}${PORTVERSION}
+PLIST_SUB= TKPKG=${TKPKG}
+USE_LDCONFIG= ${PREFIX}/lib/${TKPKG}
+MANN= ${PORTNAME}.n
+
+post-patch:
+ @${REINPLACE_CMD} -Ee '/^install:/s#install-doc##' -e 's#.*txt.*##' ${WRKSRC}/Makefile.in
+
+post-install:
+ @${LN} -sf ${USE_LDCONFIG}/lib${TKPKG}.so ${USE_LDCONFIG}/lib${TKPKG}.so.0
+ @${INSTALL_MAN} ${WRKSRC}/doc/tkDND.n ${MANNPREFIX}/man/mann/${MANN}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/tkdnd/distinfo b/x11-toolkits/tkdnd/distinfo
new file mode 100644
index 000000000000..0dc57af18510
--- /dev/null
+++ b/x11-toolkits/tkdnd/distinfo
@@ -0,0 +1,3 @@
+MD5 (tkdnd-1.0.20040304.tar.bz2) = e8791dd774c0d03d430529d77584eba9
+SHA256 (tkdnd-1.0.20040304.tar.bz2) = 3f4c6ffe89565456e2808000c441e669c7a3c315a5133382e0309140fe61dce8
+SIZE (tkdnd-1.0.20040304.tar.bz2) = 352734
diff --git a/x11-toolkits/tkdnd/pkg-descr b/x11-toolkits/tkdnd/pkg-descr
new file mode 100644
index 000000000000..e27cae3ea330
--- /dev/null
+++ b/x11-toolkits/tkdnd/pkg-descr
@@ -0,0 +1,8 @@
+tkdnd is an extension that adds native drag & drop capabilities to the
+tk toolkit. It can be used with any tk version equal or greater to 8.4
+and currently only the UNIX (X-Windows) and Microsoft Windows operating
+systems are supported. Under unix the drag & drop protocol in use is the
+XDND protocol version 4 (also used by the QT toolkit, KDE & GNOME
+Desktops).
+
+WWW: http://www.iit.demokritos.gr/~petasis/Tcl/tkDND/tkDND.html
diff --git a/x11-toolkits/tkdnd/pkg-plist b/x11-toolkits/tkdnd/pkg-plist
new file mode 100644
index 000000000000..196d94154fac
--- /dev/null
+++ b/x11-toolkits/tkdnd/pkg-plist
@@ -0,0 +1,5 @@
+lib/%%TKPKG%%/lib%%TKPKG%%.so
+lib/%%TKPKG%%/lib%%TKPKG%%.so.0
+lib/%%TKPKG%%/pkgIndex.tcl
+lib/%%TKPKG%%/tkdnd.tcl
+@dirrm lib/%%TKPKG%%