aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-06 01:49:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-06 01:49:09 +0000
commit25fde6ad9c7d83a5f267d81025dd7ac3af9543bd (patch)
treee7d813c4e0a07820ffef6e14248ab6087fc3d798 /x11-toolkits/vte/Makefile
parent638e9e1fdc0110d33d6783404bce64da68e0316a (diff)
downloadports-25fde6ad9c7d83a5f267d81025dd7ac3af9543bd.tar.gz
ports-25fde6ad9c7d83a5f267d81025dd7ac3af9543bd.zip
Notes
Diffstat (limited to 'x11-toolkits/vte/Makefile')
-rw-r--r--x11-toolkits/vte/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-toolkits/vte/Makefile b/x11-toolkits/vte/Makefile
new file mode 100644
index 000000000000..e694a696ee84
--- /dev/null
+++ b/x11-toolkits/vte/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: vte
+# Date created: 05 October 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vte
+PORTVERSION= 0.9.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.9
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_BISON= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>