aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-08 09:55:41 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-08 09:55:41 +0000
commit430957572e0547eb9db51dc3ae266f7da7b1e74f (patch)
treead519bdf5e9b7d1fb5321de8e707e5114b3a0170 /x11-toolkits/vte3
parent7db9db9528b455767056ac5c00b7954c2e84eecb (diff)
downloadports-430957572e0547eb9db51dc3ae266f7da7b1e74f.tar.gz
ports-430957572e0547eb9db51dc3ae266f7da7b1e74f.zip
Add vte3, the Gtk 3 version of the vte terminal widget.
Split off gnome-pty-helper from vte to allow both versions of vte to be installed at the same time. Update comment to make it clearer which gtk+ version it is for. Enable introspection bindings in vte. Obtained from: GNOME dev repo.
Notes
Notes: svn path=/head/; revision=335873
Diffstat (limited to 'x11-toolkits/vte3')
-rw-r--r--x11-toolkits/vte3/Makefile66
-rw-r--r--x11-toolkits/vte3/distinfo2
-rw-r--r--x11-toolkits/vte3/files/extra-patch-gnome-pty-helper_gnome-utmp.c40
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_Makefile.in13
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_config.h.in12
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_configure11
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-pty-helper.c10
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-utmp.c11
-rw-r--r--x11-toolkits/vte3/files/patch-src_vteseq.c10
-rw-r--r--x11-toolkits/vte3/pkg-descr4
-rw-r--r--x11-toolkits/vte3/pkg-plist188
11 files changed, 367 insertions, 0 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
new file mode 100644
index 000000000000..224cbabcc562
--- /dev/null
+++ b/x11-toolkits/vte3/Makefile
@@ -0,0 +1,66 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/x11-toolkits/vte3/Makefile 18941 2013-12-08 01:18:10Z kwm $
+
+PORTNAME?= vte
+PORTVERSION= 0.34.7
+PORTREVISION?= 0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= GNOME
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/gnome-pty-helper/vte/}/${PORTVERSION:R}
+DISTNAME= vte-${PORTVERSION}
+PKGNAMESUFFIX?= 3
+DIST_SUBDIR= gnome3
+
+MAINTAINER?= gnome@FreeBSD.org
+COMMENT?= Gtk 3 based terminal widget with accessibility and I18N support
+
+USE_XZ= yes
+
+.if !defined(REFERENCE_PORT)
+VTE3_SLAVE?= no
+
+.if ${VTE3_SLAVE}!="yes"
+RUN_DEPENDS+= ${LOCALBASE}/libexec/gnome-pty-helper:${PORTSDIR}/x11-toolkits/gnome-pty-helper
+.endif
+
+USES= bison gettext gmake pathfix pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GNOME?= gnomeprefix gtk30 ltverhack referencehack introspection:build
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS?=--disable-python \
+ --with-gtk=3.0 \
+ --enable-introspection \
+ --disable-static \
+ --disable-Bsymbolic \
+ --disable-gnome-pty-helper \
+ --disable-freetypetest
+
+.if !defined(MASTERDIR)
+OPTIONS_DEFINE= GLX
+GLX_DESC= Support for DRI/GLX rendering
+.endif
+
+PLIST_SUB= VERSION=2.90
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 900007
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-pty-helper_gnome-utmp.c
+.endif
+
+.if ${PORT_OPTIONS:MGLX} && !defined(MASTERDIR)
+CONFIGURE_ARGS+= --with-glX
+USE_GL= yes
+.endif
+
+.if ${VTE3_SLAVE}!=yes
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libvte2_90.so.9
+.endif
+
+.include <bsd.port.mk>
+
+.endif
diff --git a/x11-toolkits/vte3/distinfo b/x11-toolkits/vte3/distinfo
new file mode 100644
index 000000000000..4bf4600d53f1
--- /dev/null
+++ b/x11-toolkits/vte3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/vte-0.34.7.tar.xz) = 187e49cca574f548d04ceea701e95a1531ff9dd9cd1953ce6455824720dab932
+SIZE (gnome3/vte-0.34.7.tar.xz) = 984068
diff --git a/x11-toolkits/vte3/files/extra-patch-gnome-pty-helper_gnome-utmp.c b/x11-toolkits/vte3/files/extra-patch-gnome-pty-helper_gnome-utmp.c
new file mode 100644
index 000000000000..bc0877bf5f3a
--- /dev/null
+++ b/x11-toolkits/vte3/files/extra-patch-gnome-pty-helper_gnome-utmp.c
@@ -0,0 +1,40 @@
+--- gnome-pty-helper/gnome-utmp.c.orig Sat Oct 28 23:15:53 2006
++++ gnome-pty-helper/gnome-utmp.c Sat Oct 28 23:15:40 2006
+@@ -258,10 +258,18 @@ write_logout_record (char *login_name, v
+ #endif
+
+ if (utmp)
++#if defined(__FreeBSD__)
++ logout (put.ut_line);
++#else
+ update_utmp (&put);
++#endif
+
+ if (wtmp)
++#if defined(__FreeBSD__)
++ logwtmp (put.ut_line, "", "");
++#else
+ update_wtmp (WTMP_OUTPUT_FILENAME, &put);
++#endif
+
+ free (ut);
+ }
+@@ -347,10 +355,18 @@ write_login_record (char *login_name, ch
+ # endif
+ #endif
+ if (utmp)
++#if defined(__FreeBSD__)
++ login (ut);
++#else
+ update_utmp (ut);
++#endif
+
+ if (wtmp)
++#if defined(__FreeBSD__)
++ logwtmp (ut->ut_line, ut->ut_name, ut->ut_host);
++#else
+ update_wtmp (WTMP_OUTPUT_FILENAME, ut);
++#endif
+
+ if (lastlog)
+ update_lastlog(login_name, ut);
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_Makefile.in b/x11-toolkits/vte3/files/patch-gnome-pty-helper_Makefile.in
new file mode 100644
index 000000000000..93f9d08dab50
--- /dev/null
+++ b/x11-toolkits/vte3/files/patch-gnome-pty-helper_Makefile.in
@@ -0,0 +1,13 @@
+--- gnome-pty-helper/Makefile.in.orig 2009-05-06 01:20:54.000000000 -0400
++++ gnome-pty-helper/Makefile.in 2009-05-06 01:21:30.000000000 -0400
+@@ -590,8 +590,8 @@ uninstall-am: uninstall-libexecPROGRAMS
+
+
+ install-exec-hook:
+- chown root.utmp $(DESTDIR)$(libexecdir)/gnome-pty-helper || true
+- chmod g+s $(DESTDIR)$(libexecdir)/gnome-pty-helper || true
++ chown root:wheel $(DESTDIR)$(libexecdir)/gnome-pty-helper || true
++ chmod u+s $(DESTDIR)$(libexecdir)/gnome-pty-helper || true
+
+ -include $(top_srcdir)/git.mk
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_config.h.in b/x11-toolkits/vte3/files/patch-gnome-pty-helper_config.h.in
new file mode 100644
index 000000000000..d07c7bce3919
--- /dev/null
+++ b/x11-toolkits/vte3/files/patch-gnome-pty-helper_config.h.in
@@ -0,0 +1,12 @@
+--- gnome-pty-helper/config.h.in.orig 2012-03-24 17:31:26.000000000 -0400
++++ gnome-pty-helper/config.h.in 2012-03-24 17:31:43.000000000 -0400
+@@ -24,6 +24,9 @@
+ /* Define to 1 if you have the `getutmpx' function. */
+ #undef HAVE_GETUTMPX
+
++/* Define to 1 if you have the `getutxid' function. */
++#undef HAVE_GETUTXID
++
+ /* Define to 1 if you have the `grantpt' function. */
+ #undef HAVE_GRANTPT
+
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_configure b/x11-toolkits/vte3/files/patch-gnome-pty-helper_configure
new file mode 100644
index 000000000000..737b74e59ca5
--- /dev/null
+++ b/x11-toolkits/vte3/files/patch-gnome-pty-helper_configure
@@ -0,0 +1,11 @@
+--- gnome-pty-helper/configure.orig 2012-03-24 17:31:04.000000000 -0400
++++ gnome-pty-helper/configure 2012-03-24 17:31:21.000000000 -0400
+@@ -5699,7 +5699,7 @@ fi
+
+ fi
+
+-for ac_func in endutent fcntl forkpty getttyent getutent getutmpx grantpt flock login_tty openpty revoke sendmsg seteuid setreuid setutent strrchr updwtmp updwtmpx utmpname utmpxname
++for ac_func in endutent fcntl forkpty getttyent getutent getutmpx grantpt flock login_tty openpty revoke sendmsg seteuid setreuid setutent strrchr updwtmp updwtmpx utmpname utmpxname getutxid
+ do :
+ as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-pty-helper.c b/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-pty-helper.c
new file mode 100644
index 000000000000..ab80c5364b55
--- /dev/null
+++ b/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-pty-helper.c
@@ -0,0 +1,10 @@
+--- gnome-pty-helper/gnome-pty-helper.c
++++ gnome-pty-helper/gnome-pty-helper.c
+@@ -51,7 +51,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+-#include <utmp.h>
+ #include <grp.h>
+ #include "gnome-pty.h"
+ #include "gnome-login-support.h"
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-utmp.c b/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-utmp.c
new file mode 100644
index 000000000000..fa2750ccd5ba
--- /dev/null
+++ b/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-utmp.c
@@ -0,0 +1,11 @@
+--- gnome-pty-helper/gnome-utmp.c.orig 2012-03-24 17:30:46.000000000 -0400
++++ gnome-pty-helper/gnome-utmp.c 2012-03-24 17:30:25.000000000 -0400
+@@ -152,7 +152,7 @@ update_wtmp (char *file, UTMP *putmp)
+ #endif /* !HAVE_GETUTMPX */
+
+
+-#if defined(HAVE_GETUTMPX)
++#if defined(HAVE_GETUTMPX) || defined(HAVE_GETUTXID)
+ static void
+ update_utmp (UTMP *ut)
+ {
diff --git a/x11-toolkits/vte3/files/patch-src_vteseq.c b/x11-toolkits/vte3/files/patch-src_vteseq.c
new file mode 100644
index 000000000000..e5afb288b0d8
--- /dev/null
+++ b/x11-toolkits/vte3/files/patch-src_vteseq.c
@@ -0,0 +1,10 @@
+--- src/vteseq.c.orig Mon Jun 12 20:27:00 2006
++++ src/vteseq.c Mon Jun 12 20:27:19 2006
+@@ -20,6 +20,7 @@
+ #include "../config.h"
+
+ #ifdef HAVE_SYS_SYSLIMITS_H
++#include <sys/cdefs.h>
+ #include <sys/syslimits.h>
+ #endif
+
diff --git a/x11-toolkits/vte3/pkg-descr b/x11-toolkits/vte3/pkg-descr
new file mode 100644
index 000000000000..a363e23c7866
--- /dev/null
+++ b/x11-toolkits/vte3/pkg-descr
@@ -0,0 +1,4 @@
+Terminal widget with improved font, internationalisation and accessibility
+support for the GNOME 2 desktop. Designed to replace libzvt.
+
+WWW: http://www.gnome.org/
diff --git a/x11-toolkits/vte3/pkg-plist b/x11-toolkits/vte3/pkg-plist
new file mode 100644
index 000000000000..e90ead230384
--- /dev/null
+++ b/x11-toolkits/vte3/pkg-plist
@@ -0,0 +1,188 @@
+bin/vte2_90
+etc/profile.d/vte.sh
+include/vte-%%VERSION%%/vte/pty.h
+include/vte-%%VERSION%%/vte/reaper.h
+include/vte-%%VERSION%%/vte/vte.h
+include/vte-%%VERSION%%/vte/vteaccess.h
+include/vte-%%VERSION%%/vte/vtedeprecated.h
+include/vte-%%VERSION%%/vte/vtepty.h
+include/vte-%%VERSION%%/vte/vtetypebuiltins.h
+include/vte-%%VERSION%%/vte/vteversion.h
+lib/girepository-1.0/Vte-%%VERSION%%.typelib
+lib/libvte2_90.la
+lib/libvte2_90.so
+lib/libvte2_90.so.9
+libdata/pkgconfig/vte-%%VERSION%%.pc
+share/doc/vte-2.90/VteReaper.html
+share/doc/vte-2.90/VteTerminal.html
+share/doc/vte-2.90/VteTerminalAccessible.html
+share/doc/vte-2.90/annotation-glossary.html
+share/doc/vte-2.90/api-index-0-20.html
+share/doc/vte-2.90/api-index-0-24.html
+share/doc/vte-2.90/api-index-0-26.html
+share/doc/vte-2.90/api-index-0-28.html
+share/doc/vte-2.90/api-index-0-34.html
+share/doc/vte-2.90/api-index-deprecated.html
+share/doc/vte-2.90/api-index-full.html
+share/doc/vte-2.90/ch01.html
+share/doc/vte-2.90/ch02.html
+share/doc/vte-2.90/ch03.html
+share/doc/vte-2.90/deprecated-objects.html
+share/doc/vte-2.90/home.png
+share/doc/vte-2.90/index.html
+share/doc/vte-2.90/index.sgml
+share/doc/vte-2.90/internal-objects.html
+share/doc/vte-2.90/left.png
+share/doc/vte-2.90/licence.html
+share/doc/vte-2.90/object-hierarchy.html
+share/doc/vte-2.90/pt01.html
+share/doc/vte-2.90/right.png
+share/doc/vte-2.90/style.css
+share/doc/vte-2.90/up.png
+share/doc/vte-2.90/vte-Version-Information.html
+share/doc/vte-2.90/vte-Vte-PTY.html
+share/doc/vte-2.90/vte-2.90.devhelp2
+share/gir-1.0/Vte-%%VERSION%%.gir
+share/locale/am/LC_MESSAGES/vte-2.90.mo
+share/locale/ang/LC_MESSAGES/vte-2.90.mo
+share/locale/ar/LC_MESSAGES/vte-2.90.mo
+share/locale/as/LC_MESSAGES/vte-2.90.mo
+share/locale/ast/LC_MESSAGES/vte-2.90.mo
+share/locale/az/LC_MESSAGES/vte-2.90.mo
+share/locale/be/LC_MESSAGES/vte-2.90.mo
+share/locale/be@latin/LC_MESSAGES/vte-2.90.mo
+share/locale/bg/LC_MESSAGES/vte-2.90.mo
+share/locale/bn/LC_MESSAGES/vte-2.90.mo
+share/locale/bn_IN/LC_MESSAGES/vte-2.90.mo
+share/locale/bs/LC_MESSAGES/vte-2.90.mo
+share/locale/ca/LC_MESSAGES/vte-2.90.mo
+share/locale/ca@valencia/LC_MESSAGES/vte-2.90.mo
+share/locale/cs/LC_MESSAGES/vte-2.90.mo
+share/locale/cy/LC_MESSAGES/vte-2.90.mo
+share/locale/da/LC_MESSAGES/vte-2.90.mo
+share/locale/de/LC_MESSAGES/vte-2.90.mo
+share/locale/dz/LC_MESSAGES/vte-2.90.mo
+share/locale/el/LC_MESSAGES/vte-2.90.mo
+share/locale/en@shaw/LC_MESSAGES/vte-2.90.mo
+share/locale/en_CA/LC_MESSAGES/vte-2.90.mo
+share/locale/en_GB/LC_MESSAGES/vte-2.90.mo
+share/locale/eo/LC_MESSAGES/vte-2.90.mo
+share/locale/es/LC_MESSAGES/vte-2.90.mo
+share/locale/et/LC_MESSAGES/vte-2.90.mo
+share/locale/eu/LC_MESSAGES/vte-2.90.mo
+share/locale/fa/LC_MESSAGES/vte-2.90.mo
+share/locale/fi/LC_MESSAGES/vte-2.90.mo
+share/locale/fr/LC_MESSAGES/vte-2.90.mo
+share/locale/fur/LC_MESSAGES/vte-2.90.mo
+share/locale/ga/LC_MESSAGES/vte-2.90.mo
+share/locale/gl/LC_MESSAGES/vte-2.90.mo
+share/locale/gu/LC_MESSAGES/vte-2.90.mo
+share/locale/he/LC_MESSAGES/vte-2.90.mo
+share/locale/hi/LC_MESSAGES/vte-2.90.mo
+share/locale/hr/LC_MESSAGES/vte-2.90.mo
+share/locale/hu/LC_MESSAGES/vte-2.90.mo
+share/locale/id/LC_MESSAGES/vte-2.90.mo
+share/locale/is/LC_MESSAGES/vte-2.90.mo
+share/locale/it/LC_MESSAGES/vte-2.90.mo
+share/locale/ja/LC_MESSAGES/vte-2.90.mo
+share/locale/ka/LC_MESSAGES/vte-2.90.mo
+share/locale/kn/LC_MESSAGES/vte-2.90.mo
+share/locale/ko/LC_MESSAGES/vte-2.90.mo
+share/locale/ku/LC_MESSAGES/vte-2.90.mo
+share/locale/ky/LC_MESSAGES/vte-2.90.mo
+share/locale/li/LC_MESSAGES/vte-2.90.mo
+share/locale/lt/LC_MESSAGES/vte-2.90.mo
+share/locale/lv/LC_MESSAGES/vte-2.90.mo
+share/locale/mai/LC_MESSAGES/vte-2.90.mo
+share/locale/mi/LC_MESSAGES/vte-2.90.mo
+share/locale/mk/LC_MESSAGES/vte-2.90.mo
+share/locale/ml/LC_MESSAGES/vte-2.90.mo
+share/locale/mn/LC_MESSAGES/vte-2.90.mo
+share/locale/mr/LC_MESSAGES/vte-2.90.mo
+share/locale/ms/LC_MESSAGES/vte-2.90.mo
+share/locale/nb/LC_MESSAGES/vte-2.90.mo
+share/locale/ne/LC_MESSAGES/vte-2.90.mo
+share/locale/nds/LC_MESSAGES/vte-2.90.mo
+share/locale/nl/LC_MESSAGES/vte-2.90.mo
+share/locale/nn/LC_MESSAGES/vte-2.90.mo
+share/locale/oc/LC_MESSAGES/vte-2.90.mo
+share/locale/or/LC_MESSAGES/vte-2.90.mo
+share/locale/pa/LC_MESSAGES/vte-2.90.mo
+share/locale/pl/LC_MESSAGES/vte-2.90.mo
+share/locale/pt/LC_MESSAGES/vte-2.90.mo
+share/locale/pt_BR/LC_MESSAGES/vte-2.90.mo
+share/locale/ro/LC_MESSAGES/vte-2.90.mo
+share/locale/ru/LC_MESSAGES/vte-2.90.mo
+share/locale/rw/LC_MESSAGES/vte-2.90.mo
+share/locale/si/LC_MESSAGES/vte-2.90.mo
+share/locale/sk/LC_MESSAGES/vte-2.90.mo
+share/locale/sl/LC_MESSAGES/vte-2.90.mo
+share/locale/sq/LC_MESSAGES/vte-2.90.mo
+share/locale/sr/LC_MESSAGES/vte-2.90.mo
+share/locale/sr@latin/LC_MESSAGES/vte-2.90.mo
+share/locale/sv/LC_MESSAGES/vte-2.90.mo
+share/locale/ta/LC_MESSAGES/vte-2.90.mo
+share/locale/te/LC_MESSAGES/vte-2.90.mo
+share/locale/th/LC_MESSAGES/vte-2.90.mo
+share/locale/tr/LC_MESSAGES/vte-2.90.mo
+share/locale/ug/LC_MESSAGES/vte-2.90.mo
+share/locale/uk/LC_MESSAGES/vte-2.90.mo
+share/locale/uz@cyrillic/LC_MESSAGES/vte-2.90.mo
+share/locale/vi/LC_MESSAGES/vte-2.90.mo
+share/locale/wa/LC_MESSAGES/vte-2.90.mo
+share/locale/xh/LC_MESSAGES/vte-2.90.mo
+share/locale/zh_CN/LC_MESSAGES/vte-2.90.mo
+share/locale/zh_HK/LC_MESSAGES/vte-2.90.mo
+share/locale/zh_TW/LC_MESSAGES/vte-2.90.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
+@dirrmtry share/locale/uz@cyrillic
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mi/LC_MESSAGES
+@dirrmtry share/locale/mi
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/fur/LC_MESSAGES
+@dirrmtry share/locale/fur
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
+@dirrmtry share/locale/ang/LC_MESSAGES
+@dirrmtry share/locale/ang
+@dirrmtry share/doc/vte-2.90
+@dirrmtry etc/profile.d
+@dirrm include/vte-2.90/vte
+@dirrm include/vte-2.90