aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /x11-toolkits/vte3
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
Notes
Diffstat (limited to 'x11-toolkits/vte3')
-rw-r--r--x11-toolkits/vte3/Makefile25
-rw-r--r--x11-toolkits/vte3/distinfo4
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_Makefile.in13
-rw-r--r--x11-toolkits/vte3/pkg-plist53
4 files changed, 52 insertions, 43 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
index aedda06a25fa..1457507c724e 100644
--- a/x11-toolkits/vte3/Makefile
+++ b/x11-toolkits/vte3/Makefile
@@ -1,9 +1,8 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/x11-toolkits/vte3/Makefile 19957 2014-10-15 11:07:14Z gusi $
PORTNAME?= vte
-PORTVERSION= 0.38.3
+PORTVERSION= 0.40.2
PORTREVISION?= 0
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME/sources/${PORTNAME:S/gnome-pty-helper/vte/}/${PORTVERSION:R}
@@ -18,17 +17,22 @@ USES= tar:xz
.if !defined(REFERENCE_PORT)
VTE3_SLAVE?= no
+PORTSCOUT= limitw:1,even
.if ${VTE3_SLAVE} != yes
BUILD_DEPENDS+= vapigen:${PORTSDIR}/lang/vala \
bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
RUN_DEPENDS+= ${LOCALBASE}/libexec/gnome-pty-helper:${PORTSDIR}/x11-toolkits/gnome-pty-helper
+.else
+# we need gnutls for configure to pass for gnome-pty-helper ..
+BUILD_DEPENDS+= gnutls>=0:${PORTSDIR}/security/gnutls
.endif
USES+= bison gettext gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GNOME?= gnomeprefix gtk30 referencehack introspection:build
+USE_GNOME?= gtk30 intltool referencehack introspection:build
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS?=--disable-python \
@@ -48,18 +52,33 @@ PLIST_SUB= VERSION=2.91
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-pty-helper_gnome-utmp.c
.endif
+.if ${OSVERSION} < 1000000
+CFLAGS+= -lz
+.endif
+
post-patch:
.if ${VTE3_SLAVE} != yes
@${REINPLACE_CMD} -e 's|-Wno-unused-but-set-variable||g' \
${WRKSRC}/src/Makefile.in
.endif
+# zlib.pc only is available on 10.1-R and newer.
+.if ${OSVERSION} < 1000000
+ @${REINPLACE_CMD} -e 's|gio-unix-2.0 zlib|gio-unix-2.0|g' \
+ ${WRKSRC}/configure
+.endif
# borrowed osversion from bsd.ssp.mk
.if ${OSVERSION} < 1000036 && ${ARCH} == i386
@${REINPLACE_CMD} -e 's|-fstack-protector-strong||g; \
s|-fstack-protector||g' \
${WRKSRC}/configure
.endif
+ @${REINPLACE_CMD} -e 's|(AM_MAKEFLAGS) install-exec-hook|(AM_MAKEFLAGS)|g' \
+ ${WRKSRC}/gnome-pty-helper/Makefile.in
+ @${REINPLACE_CMD} -e 's|zlib"|"|g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
+.else
+PORTSCOUT= ignore:1
.endif
diff --git a/x11-toolkits/vte3/distinfo b/x11-toolkits/vte3/distinfo
index ce5c4ae5a2b7..f51564204901 100644
--- a/x11-toolkits/vte3/distinfo
+++ b/x11-toolkits/vte3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/vte-0.38.3.tar.xz) = 3f3ae063207ceea9ca2abd1cf9c9f8bd2b66ca82156609f31f3554288c0c2bf4
-SIZE (gnome3/vte-0.38.3.tar.xz) = 1005548
+SHA256 (gnome3/vte-0.40.2.tar.xz) = 9b68fbc16b27f2d79e6271f2b0708808594ac5acf979d0fccea118608199fd2d
+SIZE (gnome3/vte-0.40.2.tar.xz) = 923852
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_Makefile.in b/x11-toolkits/vte3/files/patch-gnome-pty-helper_Makefile.in
deleted file mode 100644
index 93f9d08dab50..000000000000
--- a/x11-toolkits/vte3/files/patch-gnome-pty-helper_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- gnome-pty-helper/Makefile.in.orig 2009-05-06 01:20:54.000000000 -0400
-+++ gnome-pty-helper/Makefile.in 2009-05-06 01:21:30.000000000 -0400
-@@ -590,8 +590,8 @@ uninstall-am: uninstall-libexecPROGRAMS
-
-
- install-exec-hook:
-- chown root.utmp $(DESTDIR)$(libexecdir)/gnome-pty-helper || true
-- chmod g+s $(DESTDIR)$(libexecdir)/gnome-pty-helper || true
-+ chown root:wheel $(DESTDIR)$(libexecdir)/gnome-pty-helper || true
-+ chmod u+s $(DESTDIR)$(libexecdir)/gnome-pty-helper || true
-
- -include $(top_srcdir)/git.mk
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/x11-toolkits/vte3/pkg-plist b/x11-toolkits/vte3/pkg-plist
index ec8757f38d8d..a06db59797c2 100644
--- a/x11-toolkits/vte3/pkg-plist
+++ b/x11-toolkits/vte3/pkg-plist
@@ -1,6 +1,7 @@
bin/vte-%%VERSION%%
etc/profile.d/vte.sh
include/vte-%%VERSION%%/vte/vte.h
+include/vte-%%VERSION%%/vte/vtedeprecated.h
include/vte-%%VERSION%%/vte/vteenums.h
include/vte-%%VERSION%%/vte/vteglobals.h
include/vte-%%VERSION%%/vte/vtemacros.h
@@ -11,32 +12,33 @@ include/vte-%%VERSION%%/vte/vteversion.h
lib/girepository-1.0/Vte-%%VERSION%%.typelib
lib/libvte-%%VERSION%%.so
lib/libvte-%%VERSION%%.so.0
-lib/libvte-%%VERSION%%.so.0.3800.3
+lib/libvte-%%VERSION%%.so.0.4000.2
libdata/pkgconfig/vte-%%VERSION%%.pc
-share/doc/vte-%%VERSION%%/VteTerminal.html
-share/doc/vte-%%VERSION%%/annotation-glossary.html
-share/doc/vte-%%VERSION%%/api-index-deprecated.html
-share/doc/vte-%%VERSION%%/api-index-full.html
-share/doc/vte-%%VERSION%%/ch01.html
-share/doc/vte-%%VERSION%%/ch02.html
-share/doc/vte-%%VERSION%%/ch03.html
-share/doc/vte-%%VERSION%%/home.png
-share/doc/vte-%%VERSION%%/index.html
-share/doc/vte-%%VERSION%%/index.sgml
-share/doc/vte-%%VERSION%%/left-insensitive.png
-share/doc/vte-%%VERSION%%/left.png
-share/doc/vte-%%VERSION%%/licence.html
-share/doc/vte-%%VERSION%%/object-hierarchy.html
-share/doc/vte-%%VERSION%%/pt01.html
-share/doc/vte-%%VERSION%%/right-insensitive.png
-share/doc/vte-%%VERSION%%/right.png
-share/doc/vte-%%VERSION%%/style.css
-share/doc/vte-%%VERSION%%/up-insensitive.png
-share/doc/vte-%%VERSION%%/up.png
-share/doc/vte-%%VERSION%%/vte-%%VERSION%%.devhelp2
-share/doc/vte-%%VERSION%%/vte-Version-Information.html
-share/doc/vte-%%VERSION%%/vte-Vte-PTY.html
share/gir-1.0/Vte-%%VERSION%%.gir
+share/gtk-doc/html/vte-%%VERSION%%/VteTerminal.html
+share/gtk-doc/html/vte-%%VERSION%%/annotation-glossary.html
+share/gtk-doc/html/vte-%%VERSION%%/api-index-0-40.html
+share/gtk-doc/html/vte-%%VERSION%%/api-index-deprecated.html
+share/gtk-doc/html/vte-%%VERSION%%/api-index-full.html
+share/gtk-doc/html/vte-%%VERSION%%/ch01.html
+share/gtk-doc/html/vte-%%VERSION%%/ch02.html
+share/gtk-doc/html/vte-%%VERSION%%/ch03.html
+share/gtk-doc/html/vte-%%VERSION%%/home.png
+share/gtk-doc/html/vte-%%VERSION%%/index.html
+share/gtk-doc/html/vte-%%VERSION%%/index.sgml
+share/gtk-doc/html/vte-%%VERSION%%/left-insensitive.png
+share/gtk-doc/html/vte-%%VERSION%%/left.png
+share/gtk-doc/html/vte-%%VERSION%%/licence.html
+share/gtk-doc/html/vte-%%VERSION%%/object-hierarchy.html
+share/gtk-doc/html/vte-%%VERSION%%/pt01.html
+share/gtk-doc/html/vte-%%VERSION%%/right-insensitive.png
+share/gtk-doc/html/vte-%%VERSION%%/right.png
+share/gtk-doc/html/vte-%%VERSION%%/style.css
+share/gtk-doc/html/vte-%%VERSION%%/up-insensitive.png
+share/gtk-doc/html/vte-%%VERSION%%/up.png
+share/gtk-doc/html/vte-%%VERSION%%/vte-%%VERSION%%.devhelp2
+share/gtk-doc/html/vte-%%VERSION%%/vte-Version-Information.html
+share/gtk-doc/html/vte-%%VERSION%%/vte-Vte-PTY.html
share/locale/am/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ang/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ar/LC_MESSAGES/vte-%%VERSION%%.mo
@@ -81,6 +83,7 @@ share/locale/is/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/it/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ja/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ka/LC_MESSAGES/vte-%%VERSION%%.mo
+share/locale/kk/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/kn/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ko/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ku/LC_MESSAGES/vte-%%VERSION%%.mo
@@ -96,8 +99,8 @@ share/locale/mn/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/mr/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ms/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/nb/LC_MESSAGES/vte-%%VERSION%%.mo
-share/locale/ne/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/nds/LC_MESSAGES/vte-%%VERSION%%.mo
+share/locale/ne/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/nn/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/oc/LC_MESSAGES/vte-%%VERSION%%.mo