aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/xbae/Makefile
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2000-12-29 16:15:13 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2000-12-29 16:15:13 +0000
commita52c0977b6f10c85e6d775cc5e0ee67a76843656 (patch)
treed4814f326f05525e56207189f20d72b3c5c3035c /x11-toolkits/xbae/Makefile
parent0340bdf3f573a64ed149a564595282abe578f0ac (diff)
downloadports-a52c0977b6f10c85e6d775cc5e0ee67a76843656.tar.gz
ports-a52c0977b6f10c85e6d775cc5e0ee67a76843656.zip
Notes
Diffstat (limited to 'x11-toolkits/xbae/Makefile')
-rw-r--r--x11-toolkits/xbae/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/x11-toolkits/xbae/Makefile b/x11-toolkits/xbae/Makefile
index f522091e9a07..0d8689d50b69 100644
--- a/x11-toolkits/xbae/Makefile
+++ b/x11-toolkits/xbae/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: Xbae
# Date created: 11 December 96
-# Whom: Lars Koeller <Lars_Koeller@odie.physik2.uni-rostock.de>
+# Whom: Lars Koeller <Lars.Koeller@Uni-Bielefeld.de>
# With some
# modifications from: Andreas Klemm <andreas@FreeBSD.ORG>
#
@@ -8,10 +8,10 @@
#
PORTNAME= xbae
-PORTVERSION= 4.7
+PORTVERSION= 4.8.4
CATEGORIES= x11-toolkits math
-MASTER_SITES= ftp://sunsite.doc.ic.ac.uk/packages/X11/contrib/widgets/ \
- ${MASTER_SITE_XCONTRIB}
+MASTER_SITES= ftp://ftp.lesstif.org/pub/hungry/lesstif/srcdist/ \
+ ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/lesstif/srcdist/
MASTER_SITE_SUBDIR= widgets/motif
DISTNAME= Xbae-${PORTVERSION}
@@ -19,17 +19,27 @@ MAINTAINER= Lars.Koeller@Uni-Bielefeld.de
USE_MOTIF= yes
USE_IMAKE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-MAN3= XbaeCaption.3 XbaeMatrix.3
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${X11BASE} --enable-xbae-24bit --enable-xbae-row-heights
+
+MAN3= XbaeCaption.3 XbaeInput.3 XbaeMatrix.3
.include <bsd.port.pre.mk>
+post-patch:
+ for na in $$(find ${WRKSRC}/examples -name Makefile.in); do \
+ ${CP} $$na $$na.orig; \
+ ${SED} "s%-lXm%${MOTIFLIB}%" $$na.orig > $$na; \
+ done
+
post-install:
.if ${PORTOBJFORMAT} == "aout"
- ${LN} -sf libXbae.so.6.2 ${PREFIX}/lib/libXbae.so
+ ${LN} -sf libXbae.so.8.4 ${PREFIX}/lib/libXbae.so
.endif
${RM} -rf ${PREFIX}/include/Xbae
- ${LN} -sf Xbae-4.7 ${PREFIX}/include/Xbae
+ ${LN} -sf Xbae-4.8 ${PREFIX}/include/Xbae
.include <bsd.port.post.mk>