aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-07-04 17:46:23 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-07-04 17:46:23 +0000
commit014d8ee951cded1c9499562bcdf4437f62f1facf (patch)
treeabe578b2b77602aeb13078e0ac2b98df6cbc4ac5 /x11-toolkits
parent632c5771dfd1b023ed38bba4316b66db21f7af42 (diff)
downloadports-014d8ee951cded1c9499562bcdf4437f62f1facf.tar.gz
ports-014d8ee951cded1c9499562bcdf4437f62f1facf.zip
- Backport patch to fix text cursor position:
https://bugs.kde.org/show_bug.cgi?id=296490 - Bump PORTREVISION. Obtained from: Qt Project
Notes
Notes: svn path=/head/; revision=300486
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt4-gui/Makefile1
-rw-r--r--x11-toolkits/qt4-gui/files/patch-git_ca89c4932
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index e82ff9329bc5..6db3fddef591 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gui
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES?= x11-toolkits
PKGNAMEPREFIX= qt4-
diff --git a/x11-toolkits/qt4-gui/files/patch-git_ca89c49 b/x11-toolkits/qt4-gui/files/patch-git_ca89c49
new file mode 100644
index 000000000000..1b8a35947694
--- /dev/null
+++ b/x11-toolkits/qt4-gui/files/patch-git_ca89c49
@@ -0,0 +1,32 @@
+From ca89c49fa2c5cbb3945897046f33eed9f7da846c Mon Sep 17 00:00:00 2001
+From: Jiang Jiang <jiang.jiang@nokia.com>
+Date: Tue, 3 Jul 2012 10:17:49 +0200
+Subject: [PATCH] Fix cursor truncate to include line position
+
+Since we could have moved the line position (QTextLine::setPosition),
+the truncating position should be adjusted with that.
+
+Change-Id: Ie1acd4a1b6a4adfbeeb9ce8ee2dfa19d992470e8
+Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@nokia.com>
+---
+ src/gui/text/qtextlayout.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/gui/text/qtextlayout.cpp b/src/gui/text/qtextlayout.cpp
+index 16f7150..52f2793 100644
+--- ./src/gui/text/qtextlayout.cpp
++++ ./src/gui/text/qtextlayout.cpp
+@@ -2616,8 +2616,8 @@ qreal QTextLine::cursorToX(int *cursorPos, Edge edge) const
+ x += eng->offsetInLigature(si, pos, end, glyph_pos);
+ }
+
+- if (eng->option.wrapMode() != QTextOption::NoWrap && x > line.width)
+- x = line.width;
++ if (eng->option.wrapMode() != QTextOption::NoWrap && x > line.x + line.width)
++ x = line.x + line.width;
+
+ *cursorPos = pos + si->position;
+ return x.toReal();
+--
+1.7.10
+