aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-01-28 03:12:09 +0000
committerSteve Wills <swills@FreeBSD.org>2019-01-28 03:12:09 +0000
commit1318ed9c4dade89bb9c755cf0c7fb11aead3e961 (patch)
tree3c5db914f3e515fb3701247700cad5fc2f5cca19 /x11-toolkits
parentec60ebb24c2c5913e7e3b4cd0280fb1f8714cfa5 (diff)
downloadports-1318ed9c4dade89bb9c755cf0c7fb11aead3e961.tar.gz
ports-1318ed9c4dade89bb9c755cf0c7fb11aead3e961.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/swt/Makefile51
-rw-r--r--x11-toolkits/swt/distinfo7
-rw-r--r--x11-toolkits/swt/files/build.xml67
-rw-r--r--x11-toolkits/swt/files/patch-OS.java32
-rw-r--r--x11-toolkits/swt/files/patch-build.sh48
-rw-r--r--x11-toolkits/swt/files/patch-build.xml113
-rw-r--r--x11-toolkits/swt/files/patch-make_freebsd.mak68
-rw-r--r--x11-toolkits/swt/files/patch-org_eclipse_swt_internal_C.java14
8 files changed, 151 insertions, 249 deletions
diff --git a/x11-toolkits/swt/Makefile b/x11-toolkits/swt/Makefile
index cf45e1b9da86..eda496c851c2 100644
--- a/x11-toolkits/swt/Makefile
+++ b/x11-toolkits/swt/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= swt
-DISTVERSION= 3.5.2
-PORTREVISION= 5
+DISTVERSION= 4.7.3a
CATEGORIES= x11-toolkits devel java
-#MASTER_SITES= ECLIPSE/R-${DISTVERSION}-201002111343
-MASTER_SITES= http://archive.eclipse.org/eclipse/downloads/drops/R-${DISTVERSION}-201002111343/
+MASTER_SITES= http://archive.eclipse.org/eclipse/downloads/drops4/R-${DISTVERSION}-201803300640/
DISTNAME= swt-${DISTVERSION}-${DIST_EXT}
MAINTAINER= ports@FreeBSD.org
@@ -14,17 +12,17 @@ COMMENT= Standard Widget Toolkit for Java
LICENSE= EPL
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= amd64 i386
-CONFLICTS= swt-3.1*
+USES= gl gnome pkgconfig zip:infozip
-SWT_VERSION= 3557
+SWT_VERSION= 4763
OUTPUT_JAR= swt.jar
-USE_GL= yes
-USES= pkgconfig zip:infozip
+USE_GL= glu gl
USE_GNOME= gtk20
USE_JAVA= yes
+USE_XORG= xtst
JAVA_VERSION= 1.6+
JAVA_OS= native
USE_ANT= yes
@@ -32,43 +30,27 @@ MAKE_ARGS+= -Doutput.jar=${OUTPUT_JAR}
MAKEFILE= make_freebsd.mak
USE_LDCONFIG= yes
PLIST_SUB= BUILD=${SWT_VERSION}
-PLIST_FILES= %%JAVAJARDIR%%/${OUTPUT_JAR} \
- lib/libswt-atk-gtk-%%BUILD%%.so \
- lib/libswt-awt-gtk-%%BUILD%%.so \
- lib/libswt-gtk-%%BUILD%%.so \
- lib/libswt-glx-gtk-%%BUILD%%.so \
- lib/libswt-pi-gtk-%%BUILD%%.so
+PLIST_FILES= ${JAVAJARDIR}/${OUTPUT_JAR} \
+ lib/libswt-atk-gtk-${SWT_VERSION}.so \
+ lib/libswt-awt-gtk-${SWT_VERSION}.so \
+ lib/libswt-gtk-${SWT_VERSION}.so \
+ lib/libswt-glx-gtk-${SWT_VERSION}.so \
+ lib/libswt-pi-gtk-${SWT_VERSION}.so
NO_WRKSUBDIR= yes
-OPTIONS_DEFINE= CAIRO GNOMEVFS BROWSER
-OPTIONS_DEFAULT= CAIRO GNOMEVFS
-GNOMEVFS_DESC= Gnome VFS Support
-BROWSER_DESC= Gecko Browser Support
+OPTIONS_DEFINE= CAIRO
+OPTIONS_DEFAULT= CAIRO
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCAIRO}
LIB_DEPENDS+= libcairo.so:graphics/cairo
-PLIST_FILES+= lib/libswt-cairo-gtk-%%BUILD%%.so
+PLIST_FILES+= lib/libswt-cairo-gtk-${SWT_VERSION}.so
MAKE_CAIRO= make_cairo
.endif
-.if ${PORT_OPTIONS:MGNOMEVFS}
-USE_GNOME+= gnomevfs2 libgnome libgnomeui
-PLIST_FILES+= lib/libswt-gnome-gtk-%%BUILD%%.so
-MAKE_GNOME= make_gnome
-.endif
-
-.if ${PORT_OPTIONS:MBROWSER}
-USES= gecko
-BROKEN= Does not build with newer libxul
-PLIST_FILES+= lib/libswt-xulrunner-gtk-%%BUILD%%.so
-MAKE_MOZILLA= make_xulrunner
-.endif
-
MAKE_ENV+= MAKE_CAIRO=${MAKE_CAIRO} \
- MAKE_GNOME=${MAKE_GNOME} \
MAKE_MOZILLA=${MAKE_MOZILLA} \
JAVA_HOME=${JAVA_HOME}
@@ -81,6 +63,7 @@ DIST_EXT= gtk-linux-x86
post-extract:
@(cd ${WRKSRC} && ${UNZIP_CMD} -qo "*.zip")
@${RM} ${WRKSRC}/*.o ${WRKSRC}/*.so ${WRKSRC}/*.jar
+ @${CP} ${FILESDIR}/build.xml ${WRKSRC}/build.xml
post-patch:
${SED} -e 's|freebsd|dragonfly|g' ${WRKSRC}/make_freebsd.mak \
diff --git a/x11-toolkits/swt/distinfo b/x11-toolkits/swt/distinfo
index 7423f0b0cc4c..1a4155c09a62 100644
--- a/x11-toolkits/swt/distinfo
+++ b/x11-toolkits/swt/distinfo
@@ -1,4 +1,3 @@
-SHA256 (swt-3.5.2-gtk-linux-x86.zip) = 00477e6fc3c913916cd980a1ec29629c5250afc52dc0fcee74b035af0360eef7
-SIZE (swt-3.5.2-gtk-linux-x86.zip) = 4881316
-SHA256 (swt-3.5.2-gtk-linux-x86_64.zip) = 91f9e2d4f6ca3926252d33895aafe82ba1b72bcdb77ec71dafa20d154f5d5bc7
-SIZE (swt-3.5.2-gtk-linux-x86_64.zip) = 5068674
+TIMESTAMP = 1530093075
+SHA256 (swt-4.7.3a-gtk-linux-x86_64.zip) = 856005feff25de55f7d7b304d2cbed9dd24938c7b6d07ffd7413b8361a4753e3
+SIZE (swt-4.7.3a-gtk-linux-x86_64.zip) = 6360885
diff --git a/x11-toolkits/swt/files/build.xml b/x11-toolkits/swt/files/build.xml
new file mode 100644
index 000000000000..b25b8819b9ec
--- /dev/null
+++ b/x11-toolkits/swt/files/build.xml
@@ -0,0 +1,67 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+ Copyright (c) 2009 IBM Corporation and others.
+ All rights reserved. This program and the accompanying materials
+ are made available under the terms of the Eclipse Public License v1.0
+ which accompanies this distribution, and is available at
+ http://www.eclipse.org/legal/epl-v10.html
+
+ Contributors:
+ IBM Corporation - initial API and implementation
+ -->
+<project name="org.eclipse.swt.gtk.freebsd.x86_64" default="build.jar" basedir=".">
+
+ <target name="init">
+ <property name="ws" value="gtk"/>
+ <property name="os" value="freebsd"/>
+ <property name="destination" value="${basedir}"/>
+ <property name="javac.verbose" value="false"/>
+ <property name="javac.debug" value="off"/>
+ <property name="input.srcdir" value="${basedir}/org"/>
+ <property name="output.jar" value="${basedir}/swt.jar"/>
+ <property name="output.classes" value="${basedir}/classes"/>
+ </target>
+
+ <target name="all" depends="build.jar"/>
+
+ <target name="build.classes" depends="init">
+ <mkdir dir="${output.classes}"/>
+ <!-- -source & -target taken from Eclipse 32M4 CVS build -->
+ <javac srcdir="${input.srcdir}" destdir="${output.classes}"
+ debug="${javac.debug}" verbose="${javac.verbose}"
+ source="1.8" target="1.8">
+ </javac>
+ </target>
+
+ <target name="build.jar" depends="build.nativeLibraries">
+ <jar destfile="${output.jar}" index="false">
+ <fileset dir="${output.classes}">
+ <exclude name="**/*.java"/>
+ <exclude name="**/*.o"/>
+ <exclude name="**/*.so"/>
+ <!-- exclude CVS archive -->
+ <exclude name="**/CVS/**"/>
+ </fileset>
+ <fileset dir="${basedir}">
+ <include name="**/version.txt"/>
+ <include name="**/*.properties"/>
+ </fileset>
+ </jar>
+ </target>
+
+ <target name="clean" depends="init">
+ <delete dir="${output.classes}"/>
+ <delete file="${output.jar}"/>
+ <exec executable="sh" failonerror="true">
+ <arg value="build.sh"/>
+ <arg value="clean"/>
+ </exec>
+ </target>
+
+ <target name="build.nativeLibraries" depends="build.classes">
+ <exec executable="sh" failonerror="true">
+ <arg value="build.sh"/>
+ </exec>
+ </target>
+
+</project>
diff --git a/x11-toolkits/swt/files/patch-OS.java b/x11-toolkits/swt/files/patch-OS.java
index 04dd3008d213..5196adf37e14 100644
--- a/x11-toolkits/swt/files/patch-OS.java
+++ b/x11-toolkits/swt/files/patch-OS.java
@@ -1,26 +1,26 @@
---- ./org/eclipse/swt/internal/gtk/OS.java.orig Thu Dec 15 15:19:38 2005
-+++ ./org/eclipse/swt/internal/gtk/OS.java Mon Jan 23 23:51:20 2006
-@@ -20,18 +20,20 @@
- }
-
+--- org/eclipse/swt/internal/gtk/OS.java.orig 2018-03-01 07:35:24.000000000 +0100
++++ org/eclipse/swt/internal/gtk/OS.java 2018-06-27 11:17:53.291216000 +0200
+@@ -20,19 +20,20 @@
+
+ public class OS extends C {
/** OS Constants */
-- public static final boolean IsAIX, IsSunOS, IsLinux, IsHPUX;
-+ public static final boolean IsAIX, IsSunOS, IsLinux, IsHPUX, IsFreeBSD;
+- public static final boolean IsAIX, IsSunOS, IsLinux, IsHPUX, IsWin32, BIG_ENDIAN;
++ public static final boolean IsAIX, IsSunOS, IsLinux, IsHPUX, IsWin32, BIG_ENDIAN, IsFreeBSD;
static {
-
+
/* Initialize the OS flags and locale constants */
-+ /* make bootstrap compatible with `uname -s` for FreeBSD */
String osName = System.getProperty ("os.name");
-- boolean isAIX = false, isSunOS = false, isLinux = false, isHPUX = false;
-+ boolean isAIX = false, isSunOS = false, isLinux = false, isHPUX = false, isFreeBSD = false;
+- boolean isAIX = false, isSunOS = false, isLinux = false, isHPUX = false, isWin32 = false;
++ boolean isAIX = false, isSunOS = false, isLinux = false, isHPUX = false, isWin32 = false, isFreeBSD = false;
if (osName.equals ("Linux")) isLinux = true;
-+ if (osName.equals ("FreeBSD")) isFreeBSD = true;
if (osName.equals ("AIX")) isAIX = true;
if (osName.equals ("Solaris")) isSunOS = true;
if (osName.equals ("SunOS")) isSunOS = true;
if (osName.equals ("HP-UX")) isHPUX = true;
-- IsAIX = isAIX; IsSunOS = isSunOS; IsLinux = isLinux; IsHPUX = isHPUX;
-+ IsAIX = isAIX; IsSunOS = isSunOS; IsLinux = isLinux; IsFreeBSD = isFreeBSD; IsHPUX = isHPUX;
- }
+ if (osName.startsWith("Windows")) isWin32 = true;
+- IsAIX = isAIX; IsSunOS = isSunOS; IsLinux = isLinux; IsHPUX = isHPUX; IsWin32 = isWin32;
++ if (osName.equals ("FreeBSD")) isFreeBSD = true;
++ IsAIX = isAIX; IsSunOS = isSunOS; IsLinux = isLinux; IsHPUX = isHPUX; IsWin32 = isWin32; IsFreeBSD = isFreeBSD;
- /** Constants */
+ byte[] buffer = new byte[4];
+ long /*int*/ ptr = OS.malloc(4);
diff --git a/x11-toolkits/swt/files/patch-build.sh b/x11-toolkits/swt/files/patch-build.sh
index 6fb1b85aa9ae..9b728e18d046 100644
--- a/x11-toolkits/swt/files/patch-build.sh
+++ b/x11-toolkits/swt/files/patch-build.sh
@@ -1,7 +1,7 @@
---- build.sh.orig 2010-02-12 17:49:56 UTC
-+++ build.sh
-@@ -41,9 +41,19 @@ case $OS in
- MAKE_TYPE=gmake
+--- build.sh.orig 2018-03-01 07:35:22.000000000 +0100
++++ build.sh 2018-06-27 11:24:43.371971000 +0200
+@@ -115,9 +115,19 @@
+ fi
fi
;;
+ "DragonFly")
@@ -18,44 +18,36 @@
+ MODEL=`uname -p`
+ fi
;;
- *)
- SWT_OS=`uname -s | tr -s '[:upper:]' '[:lower:]'`
-@@ -75,15 +85,16 @@ case $MODEL in
- esac
+ "Windows_NT")
+ SWT_OS=win32
+@@ -469,10 +479,10 @@
+
# For 64-bit CPUs, we have a switch
--if [ ${MODEL} = 'x86_64' -o ${MODEL} = 'ppc64' -o ${MODEL} = 'ia64' -o ${MODEL} = 's390x' ]; then
-+if [ ${MODEL} = 'x86_64' -o ${MODEL} = 'ppc64' -o ${MODEL} = 'ia64' -o ${MODEL} = 's390x' -o ${MODEL} = 'amd64' ]; then
+-if [ ${MODEL} = 'x86_64' -o ${MODEL} = 'ppc64' -o ${MODEL} = 'ia64' -o ${MODEL} = 'sparcv9' -o ${MODEL} = 's390x' -o ${MODEL} = 'ppc64le' -o ${MODEL} = 'aarch64' ]; then
++if [ ${MODEL} = 'x86_64' -o ${MODEL} = 'ppc64' -o ${MODEL} = 'ia64' -o ${MODEL} = 'sparcv9' -o ${MODEL} = 's390x' -o ${MODEL} = 'ppc64le' -o ${MODEL} = 'aarch64' -o ${MODEL} = 'amd64' ]; then
SWT_PTR_CFLAGS=-DJNI64
- export SWT_PTR_CFLAGS
if [ -d /lib64 ]; then
- XLIB64=-L/usr/X11R6/lib64
+ XLIB64=-L${LOCALBASE}/lib64
export XLIB64
fi
+ if [ ${MODEL} = 'ppc64' -o ${MODEL} = 'ppc64le' ]; then
+@@ -517,37 +527,24 @@
+ export SWT_LFLAGS SWT_PTR_CFLAGS
fi
-+if [ x${MAKE_GNOME} = "xmake_gnome" ]; then
- if [ x`pkg-config --exists gnome-vfs-module-2.0 libgnome-2.0 libgnomeui-2.0 && echo YES` = "xYES" ]; then
- echo "libgnomeui-2.0 found, compiling SWT program support using GNOME"
- MAKE_GNOME=make_gnome
-@@ -91,7 +102,9 @@ else
- echo "libgnome-2.0 and libgnomeui-2.0 not found:"
- echo " *** SWT Program support for GNOME will not be compiled."
- fi
-+fi
-
+-
+if [ x${MAKE_CAIRO} = "xmake_cairo" ]; then
if [ x`pkg-config --exists cairo && echo YES` = "xYES" ]; then
- echo "Cairo found, compiling SWT support for the cairo graphics library."
+ func_echo_plus "Cairo found, compiling SWT support for the cairo graphics library."
MAKE_CAIRO=make_cairo
-@@ -99,30 +112,17 @@ else
- echo "Cairo not found:"
- echo " *** Advanced graphics support using cairo will not be compiled."
+ else
+ func_echo_error "Cairo not found: Advanced graphics support using cairo will not be compiled."
fi
+fi
--if [ -z "${MOZILLA_INCLUDES}" -a -z "${MOZILLA_LIBS}" ]; then
+-if [ -z "${MOZILLA_INCLUDES}" -a -z "${MOZILLA_LIBS}" -a ${SWT_OS} != 'solaris' ]; then
- if [ x`pkg-config --exists mozilla-xpcom && echo YES` = "xYES" ]; then
- MOZILLA_INCLUDES=`pkg-config --cflags mozilla-xpcom`
- MOZILLA_LIBS=`pkg-config --libs mozilla-xpcom`
@@ -75,8 +67,8 @@
- export XULRUNNER_LIBS
- MAKE_MOZILLA=make_xulrunner
- else
-- echo "None of the following libraries were found: Mozilla/XPCOM, Firefox/XPCOM, or XULRunner/XPCOM"
-- echo " *** Mozilla embedding support will not be compiled."
+- func_echo_error "None of the following libraries were found: Mozilla/XPCOM, Firefox/XPCOM, or XULRunner/XPCOM:"
+- func_echo_error " >> Mozilla embedding support will not be compiled."
- fi
+if [ x${MAKE_MOZILLA} = "xmake_xulrunner" ]; then
+ echo "Using libxul for gecko support"
diff --git a/x11-toolkits/swt/files/patch-build.xml b/x11-toolkits/swt/files/patch-build.xml
deleted file mode 100644
index 9e32275530ef..000000000000
--- a/x11-toolkits/swt/files/patch-build.xml
+++ /dev/null
@@ -1,113 +0,0 @@
---- build.xml.orig 2005-12-05 15:14:46.000000000 -0500
-+++ build.xml 2007-10-11 13:38:48.000000000 -0400
-@@ -1,55 +1,57 @@
- <?xml version="1.0" encoding="UTF-8"?>
-+<project name="org.eclipse.swt.gtk.freebsd.x86_64" default="build.jar" basedir=".">
-
--<project default="build_gtk_lib" basedir="../../..">
-+ <target name="init">
-+ <property name="ws" value="gtk"/>
-+ <property name="os" value="freebsd"/>
-+ <property name="destination" value="${basedir}"/>
-+ <property name="javac.verbose" value="false"/>
-+ <property name="javac.debug" value="off"/>
-+ <property name="input.srcdir" value="${basedir}/org"/>
-+ <property name="output.jar" value="${basedir}/swt.jar"/>
-+ <property name="output.classes" value="${basedir}/classes"/>
-+ </target>
-+
-+ <target name="all" depends="build.jar"/>
-+
-+ <target name="build.classes" depends="init">
-+ <mkdir dir="${output.classes}"/>
-+ <!-- -source & -target taken from Eclipse 32M4 CVS build -->
-+ <javac srcdir="${input.srcdir}" destdir="${output.classes}"
-+ debug="${javac.debug}" verbose="${javac.verbose}"
-+ source="1.3" target="1.2">
-+ </javac>
-+ </target>
-+
-+ <target name="build.jar" depends="build.nativeLibraries">
-+ <jar destfile="${output.jar}" index="false">
-+ <fileset dir="${output.classes}">
-+ <exclude name="**/*.java"/>
-+ <exclude name="**/*.o"/>
-+ <exclude name="**/*.so"/>
-+ <!-- exclude CVS archive -->
-+ <exclude name="**/CVS/**"/>
-+ </fileset>
-+ <fileset dir="${basedir}">
-+ <include name="**/version.txt"/>
-+ <include name="**/*.properties"/>
-+ </fileset>
-+ </jar>
-+ </target>
-+
-+ <target name="clean" depends="init">
-+ <delete dir="${output.classes}"/>
-+ <delete file="${output.jar}"/>
-+ <exec executable="sh" failonerror="true">
-+ <arg value="build.sh"/>
-+ <arg value="clean"/>
-+ </exec>
-+ </target>
-+
-+ <target name="build.nativeLibraries" depends="build.classes">
-+ <exec executable="sh" failonerror="true">
-+ <arg value="build.sh"/>
-+ </exec>
-+ </target>
-
--<target name="init">
-- <eclipse.refreshLocal resource="org.eclipse.swt" depth="infinite" />
-- <eclipse.refreshLocal resource="org.eclipse.swt.tools" depth="infinite" />
-- <eclipse.incrementalBuild project="org.eclipse.swt" kind="incr" />
--</target>
--
--<!-- Build swt.so for GTK -->
--<target name="build_gtk_lib" depends="init">
-- <exec dir="./bin/library" executable="sh">
-- <arg line="${basedir}/bin/library/build.sh"/>
-- <arg line="install"/>
-- </exec>
-- <eclipse.refreshLocal resource="org.eclipse.swt.gtk.linux.x86" depth="infinite" />
--</target>
--
--<!-- Build swt.so for PowerPC 32 bit GTK (no Mozilla)-->
--<target name="build_ppc_gtk_lib" depends="init">
-- <exec dir="./bin/library" executable="sh">
-- <env key="MODEL" value="ppc"/>
-- <arg line="${basedir}/bin/library/build.sh"/>
-- <arg line="install"/>
-- </exec>
-- <eclipse.refreshLocal resource="org.eclipse.swt.gtk.linux.ppc" depth="infinite" />
--</target>
--
--<!-- Build swt.so for Solaris GTK (no Mozilla) -->
--<target name="build_solaris_gtk_lib" depends="init">
-- <exec dir="./bin/library" executable="sh">
-- <arg line="${basedir}/bin/library/build.sh"/>
-- <arg line="install"/>
-- </exec>
-- <eclipse.refreshLocal resource="org.eclipse.swt.gtk.solaris.sparc" depth="infinite" />
--</target>
--
--<!-- Build swt.so for GTK 64 -->
--<target name="build_gtk64_lib" depends="init">
-- <exec dir="./bin/library" executable="sh">
-- <arg line="${basedir}/bin/library/build.sh"/>
-- <arg line="install"/>
-- </exec>
-- <eclipse.refreshLocal resource="org.eclipse.swt.gtk.linux.x86_64" depth="infinite" />
--</target>
--
--<target name="clean">
-- <exec dir="./bin/library" executable="sh">
-- <arg line="${basedir}/bin/library/build.sh"/>
-- <arg line="clean"/>
-- </exec>
--</target>
--
--</project>
-\ No newline at end of file
-+</project>
diff --git a/x11-toolkits/swt/files/patch-make_freebsd.mak b/x11-toolkits/swt/files/patch-make_freebsd.mak
index 29a588481389..10ea1aad6339 100644
--- a/x11-toolkits/swt/files/patch-make_freebsd.mak
+++ b/x11-toolkits/swt/files/patch-make_freebsd.mak
@@ -1,12 +1,5 @@
---- make_freebsd.mak.orig 2009-06-11 16:10:54.000000000 -0500
-+++ make_freebsd.mak 2009-07-11 08:37:19.000000000 -0500
-@@ -1,5 +1,5 @@
- #*******************************************************************************
--# Copyright (c) 2000, 2007 IBM Corporation and others.
-+# Copyright (c) 2000, 2009 IBM Corporation and others.
- # All rights reserved. This program and the accompanying materials
- # are made available under the terms of the Eclipse Public License v1.0
- # which accompanies this distribution, and is available at
+--- make_freebsd.mak.orig 2018-03-01 07:35:22.000000000 +0100
++++ make_freebsd.mak 2018-06-27 11:33:21.105457000 +0200
@@ -9,7 +9,7 @@
# IBM Corporation - initial API and implementation
#*******************************************************************************
@@ -16,30 +9,29 @@
include make_common.mak
-@@ -46,7 +46,7 @@
+@@ -43,7 +43,7 @@
# Do not use pkg-config to get libs because it includes unnecessary dependencies (i.e. pangoxft-1.0)
- GTKCFLAGS = `pkg-config --cflags gtk+-2.0`
+ GTKCFLAGS = `pkg-config --cflags gtk+-2.0 gtk+-unix-print-$(GTK_VERSION)`
-GTKLIBS = `pkg-config --libs-only-L gtk+-2.0 gthread-2.0` -lgtk-x11-2.0 -lgthread-2.0 -L/usr/X11R6/lib $(XLIB64) -lXtst
+GTKLIBS = `pkg-config --libs-only-L gtk+-2.0 gthread-2.0` -lgtk-x11-2.0 -lgthread-2.0 -L$(LOCALBASE)/lib $(XLIB64) -lXtst
- CDE_LIBS = -L$(CDE_HOME)/lib -R$(CDE_HOME)/lib -lXt -lX11 -lDtSvc
-
-@@ -58,8 +58,8 @@
- GNOMECFLAGS = `pkg-config --cflags gnome-vfs-module-2.0 libgnome-2.0 libgnomeui-2.0`
- GNOMELIBS = `pkg-config --libs-only-L gnome-vfs-module-2.0 libgnome-2.0 libgnomeui-2.0` -lgnomevfs-2 -lgnome-2 -lgnomeui-2
+ AWT_LFLAGS = -shared
+ AWT_LIBS = -L$(AWT_LIB_PATH) -ljawt
+@@ -51,7 +51,8 @@
+ ATKCFLAGS = `pkg-config --cflags atk gtk+-2.0 gtk+-unix-print-$(GTK_VERSION)`
+ ATKLIBS = `pkg-config --libs-only-L atk gtk+-2.0` -latk-1.0 -lgtk-x11-2.0
--GLXCFLAGS =
--GLXLIBS = -shared -fPIC -L/usr/X11R6/lib -lGL -lGLU -lm
+-GLXLIBS = -L/usr/X11R6/lib -lGL -lGLU -lm
+GLXCFLAGS = -I$(LOCALBASE)/include
-+GLXLIBS = -shared -fPIC -L$(LOCALBASE)/lib -lGL -lGLU -lm
++GLXLIBS = -L$(LOCALBASE)/lib -lGL -lGLU -lm
# Uncomment for Native Stats tool
#NATIVE_STATS = -DNATIVE_STATS
-@@ -78,7 +78,17 @@
+@@ -70,14 +71,24 @@
-I$(JAVA_HOME)/include/freebsd \
${SWT_PTR_CFLAGS}
- MOZILLALIBS = -shared -Wl,--version-script=mozilla_exports -Bsymbolic
+ MOZILLALFLAGS = -shared -Wl,--version-script=mozilla_exports -Bsymbolic
-
+MOZILLAEXCLUDES = -DNO__1XPCOMGlueShutdown \
+ -DNO__1XPCOMGlueStartup \
@@ -53,18 +45,17 @@
+XULRUNNEREXCLUDES = -DNO__1NS_1InitXPCOM2
+
SWT_OBJECTS = swt.o c.o c_stats.o callback.o
- CDE_OBJECTS = swt.o cde.o cde_structs.o cde_stats.o
AWT_OBJECTS = swt_awt.o
-@@ -87,7 +97,7 @@
+ SWTPI_OBJECTS = swt.o os.o os_structs.o os_custom.o os_stats.o
+ CAIRO_OBJECTS = swt.o cairo.o cairo_structs.o cairo_stats.o
ATK_OBJECTS = swt.o atk.o atk_structs.o atk_custom.o atk_stats.o
- GNOME_OBJECTS = swt.o gnome.o gnome_structs.o gnome_stats.o
MOZILLA_OBJECTS = swt.o xpcom.o xpcom_custom.o xpcom_structs.o xpcom_stats.o
-XULRUNNER_OBJECTS = swt.o xpcomxul.o xpcomxul_custom.o xpcomxul_structs.o xpcomxul_stats.o xpcomxulglue.o xpcomxulglue_stats.o
+XULRUNNER_OBJECTS = swt.o xpcomxul.o xpcomxul_custom.o xpcomxul_structs.o xpcomxul_stats.o
XPCOMINIT_OBJECTS = swt.o xpcominit.o xpcominit_structs.o xpcominit_stats.o
GLX_OBJECTS = swt.o glx.o glx_structs.o glx_stats.o
-@@ -95,19 +105,20 @@
+@@ -85,17 +96,18 @@
-DSWT_VERSION=$(SWT_VERSION) \
$(NATIVE_STATS) \
-DFREEBSD -DGTK \
@@ -73,26 +64,23 @@
-I$(JAVA_HOME)/include/freebsd \
-fPIC \
${SWT_PTR_CFLAGS}
- LIBS = -shared -fPIC
+ LFLAGS = -shared -fPIC
-ifndef NO_STRIP
-- AWT_LIBS := $(AWT_LIBS) -s
-- MOZILLALIBS := $(MOZILLALIBS) -s
-- LIBS := $(LIBS) -s
+- AWT_LFLAGS := $(AWT_LFLAGS) -s
+- MOZILLALFLAGS := $(MOZILLALFLAGS) -s
+- LFLAGS := $(LFLAGS) -s
-endif
+.ifndef NO_STRIP
-+AWT_LIBS := $(AWT_LIBS) -s
-+MOZILLALIBS := $(MOZILLALIBS) -s
-+LIBS := $(LIBS) -s
++AWT_LFLAGS := $(AWT_LFLAGS) -s
++MOZILLALFLAGS := $(MOZILLALFLAGS) -s
++LFLAGS := $(LFLAGS) -s
+.endif
--all: make_swt make_atk make_gnome make_glx
-+all: make_swt make_atk make_glx
+ all: make_swt make_atk make_glx
- #
- # SWT libs
-@@ -209,16 +220,16 @@
- $(CXX) -o $(MOZILLA_LIB) $(MOZILLA_OBJECTS) $(MOZILLALIBS) ${MOZILLA_LIBS}
+@@ -173,16 +185,16 @@
+ $(CXX) -o $(MOZILLA_LIB) $(MOZILLA_OBJECTS) $(MOZILLALFLAGS) ${MOZILLA_LIBS}
xpcom.o: xpcom.cpp
- $(CXX) $(MOZILLACFLAGS) ${MOZILLA_INCLUDES} -c xpcom.cpp
@@ -112,8 +100,8 @@
#
# XULRunner lib
-@@ -229,22 +240,16 @@
- $(CXX) -o $(XULRUNNER_LIB) $(XULRUNNER_OBJECTS) $(MOZILLALIBS) ${XULRUNNER_LIBS}
+@@ -193,22 +205,16 @@
+ $(CXX) -o $(XULRUNNER_LIB) $(XULRUNNER_OBJECTS) $(MOZILLALFLAGS) ${XULRUNNER_LIBS}
xpcomxul.o: xpcom.cpp
- $(CXX) -o xpcomxul.o $(MOZILLACFLAGS) ${XULRUNNER_INCLUDES} -c xpcom.cpp
diff --git a/x11-toolkits/swt/files/patch-org_eclipse_swt_internal_C.java b/x11-toolkits/swt/files/patch-org_eclipse_swt_internal_C.java
deleted file mode 100644
index cfa060d3fb72..000000000000
--- a/x11-toolkits/swt/files/patch-org_eclipse_swt_internal_C.java
+++ /dev/null
@@ -1,14 +0,0 @@
---- org/eclipse/swt/internal/C.java.orig 2009-07-11 08:21:27.000000000 -0500
-+++ org/eclipse/swt/internal/C.java 2009-07-11 08:22:21.000000000 -0500
-@@ -13,9 +13,9 @@
- public class C extends Platform {
-
- static {
-- if ("Linux".equals (System.getProperty ("os.name")) && "motif".equals (Platform.PLATFORM)) { //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
-+ if ("FreeBSD".equals (System.getProperty ("os.name")) && "motif".equals (Platform.PLATFORM)) { //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
- try {
-- Library.loadLibrary ("libXm.so.2", false); //$NON-NLS-1$
-+ Library.loadLibrary ("libXm.so.3", false); //$NON-NLS-1$
- } catch (Throwable ex) {}
- }
- Library.loadLibrary ("swt"); //$NON-NLS-1$