aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-08 19:47:35 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-08 19:47:35 +0000
commitb23dbd361dddceb2253049f04abf6aea78e2592a (patch)
treec690a1e99d2fafebc2d8a38443e7453d48944e13 /x11-toolkits
parentf41538257e1c8e5a6c09f6970588cb6ec0f1a595 (diff)
downloadports-b23dbd361dddceb2253049f04abf6aea78e2592a.tar.gz
ports-b23dbd361dddceb2253049f04abf6aea78e2592a.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/scintilla/Makefile15
-rw-r--r--x11-toolkits/scintilla/distinfo4
-rw-r--r--x11-toolkits/scintilla/files/patch-makefile43
3 files changed, 27 insertions, 35 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 68aa7b86e5ba..c4b0c259bc38 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scintilla
-PORTVERSION= 3.4.1
+PORTVERSION= 3.4.4
CATEGORIES= x11-toolkits
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= scite${PORTVERSION:S/.//g}
@@ -12,7 +12,7 @@ COMMENT= Full-featured free source code editing component for GTK+
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
-USES= compiler gmake iconv pkgconfig tar:tgz
+USES= gmake iconv pkgconfig tar:tgz
MAKEFILE= makefile
USE_LDCONFIG= yes
USE_GNOME= gtk20
@@ -27,17 +27,6 @@ PICFLAG?= -fPIC
PICFLAG?= -fpic
.endif
-.if ! ${COMPILER_TYPE:Mclang}
-CPPSTDRE= -e 's|--std=c++0x||'
-.else
-CPPSTDRE=
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|[(]CC[)]|(CXX)|g ; s|[(]CCOMP[)]|(CC)|g' \
- ${CPPSTDRE} \
- ${WRKSRC}/makefile
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/scintilla
${INSTALL_DATA} ${WRKSRC}/../include/*.h ${STAGEDIR}${PREFIX}/include/scintilla
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 1c0edc2a254a..7ab540d3f6b8 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scite341.tgz) = ab2940ba6ad3f1c7c33aea233dd5b44efc75319062fe0b3625db04c747bf3341
-SIZE (scite341.tgz) = 2237159
+SHA256 (scite344.tgz) = 89602ea4c245928caac07bc5192d57f98b968e578efaf0748e3dd832a724c499
+SIZE (scite344.tgz) = 2245870
diff --git a/x11-toolkits/scintilla/files/patch-makefile b/x11-toolkits/scintilla/files/patch-makefile
index cd5b51477d0c..f07d7225376e 100644
--- a/x11-toolkits/scintilla/files/patch-makefile
+++ b/x11-toolkits/scintilla/files/patch-makefile
@@ -1,22 +1,21 @@
---- makefile.orig 2013-08-31 05:20:24.000000000 +0200
-+++ makefile 2013-09-11 13:10:02.007909736 +0200
-@@ -7,14 +7,7 @@
+--- ./makefile.orig 2014-07-25 06:59:40.000000000 -0400
++++ ./makefile 2014-08-07 08:31:47.000000000 -0400
+@@ -7,14 +7,6 @@
# Also works with ming32-make on Windows.
.SUFFIXES: .cxx .c .o .h .a
-ifdef CLANG
+-CXX = clang++
-CC = clang
--CCOMP = clang
--else
--CC = g++
--CCOMP = gcc
+-# Can choose aspect to sanitize: address and undefined can simply change SANITIZE but for
+-# thread also need to create Position Independent Executable -> search online documentation
+-SANITIZE = address
+-#SANITIZE = undefined
-endif
--AR = ar
-+AR = $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared
RANLIB = touch
ifdef GTK3
-@@ -36,7 +29,8 @@
+@@ -36,7 +28,8 @@
COMPLIB=..\bin\scintilla.a
else
DEL = rm -f
@@ -26,18 +25,22 @@
endif
vpath %.h ../src ../include ../lexlib
-@@ -68,16 +62,17 @@
- CXXTFLAGS:=--std=c++0x $(CTFLAGS)
+@@ -64,8 +57,7 @@
+ CTFLAGS=-DNDEBUG -Os $(CXXBASEFLAGS) $(THREADFLAGS)
+ endif
+
+-CFLAGS:=$(CTFLAGS)
+-CXXTFLAGS:=--std=c++0x $(CTFLAGS)
++CXXTFLAGS:=$(CTFLAGS)
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
-+CONFIGLIBS:=$(shell pkg-config --libs $(GTKVERSION))
MARSHALLER=scintilla-marshal.o
-
+@@ -73,11 +65,11 @@
.cxx.o:
- $(CC) $(CONFIGFLAGS) $(CXXTFLAGS) $(CXXFLAGS) -c $<
+ $(CXX) $(CONFIGFLAGS) $(CXXTFLAGS) $(CXXFLAGS) -c $<
.c.o:
-- $(CCOMP) $(CONFIGFLAGS) $(CFLAGS) -w -c $<
-+ $(CCOMP) $(CONFIGFLAGS) $(CFLAGS) $(CXXFLAGS) -w -c $<
+- $(CC) $(CONFIGFLAGS) $(CFLAGS) -w -c $<
++ $(CC) $(CONFIGFLAGS) $(CTFLAGS) $(CFLAGS) -w -c $<
LEXOBJS:=$(addsuffix .o,$(basename $(notdir $(wildcard ../lexers/Lex*.cxx))))
@@ -46,7 +49,7 @@
clean:
$(DEL) *.o $(COMPLIB) *.plist
-@@ -93,9 +88,11 @@
+@@ -93,9 +85,11 @@
ScintillaBase.o ContractionState.o Editor.o ExternalLexer.o PropSetSimple.o PlatGTK.o \
KeyMap.o LineMarker.o PositionCache.o ScintillaGTK.o CellBuffer.o CharacterCategory.o ViewStyle.o \
RESearch.o RunStyles.o Selection.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \
@@ -54,10 +57,10 @@
- $(AR) rc $@ $^
- $(RANLIB) $@
+ $(MARSHALLER)
-+ $(AR) -o $@ $^ -Wl,--as-needed $(CONFIGLIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared -o $@ $^ -Wl,--as-needed $(CONFIGLIBS)
+
+$(LEXRLIB): $(LEXOBJS)
-+ $(AR) -o $@ $^ -Wl,--as-needed $(CONFIGLIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared -o $@ $^ -Wl,--as-needed $(CONFIGLIBS)
# Automatically generate header dependencies with "make deps"
include deps.mak