aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep-stable
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2013-07-07 23:01:43 +0000
committerGreg Lewis <glewis@FreeBSD.org>2013-07-07 23:01:43 +0000
commit3a4dd6220c2e7a9b4bb873ab774e668db5c42049 (patch)
tree0cc2267690a92c0b691441afaee08da5c64f19ee /x11-wm/afterstep-stable
parentdb285450219e4827352597fed26f80fbf0b250f8 (diff)
downloadports-3a4dd6220c2e7a9b4bb873ab774e668db5c42049.tar.gz
ports-3a4dd6220c2e7a9b4bb873ab774e668db5c42049.zip
. Update to 2.2.12.
. Pet portlint some: . Switch to new style header. . Use MASTER_SITE_AFTERSTEP. . s/file/f/ in .for loops.
Notes
Notes: svn path=/head/; revision=322465
Diffstat (limited to 'x11-wm/afterstep-stable')
-rw-r--r--x11-wm/afterstep-stable/Makefile62
-rw-r--r--x11-wm/afterstep-stable/distinfo4
-rw-r--r--x11-wm/afterstep-stable/files/patch-configure18
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterImage-export.c11
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterImage-import.c19
-rw-r--r--x11-wm/afterstep-stable/pkg-plist92
6 files changed, 82 insertions, 124 deletions
diff --git a/x11-wm/afterstep-stable/Makefile b/x11-wm/afterstep-stable/Makefile
index 5513b338dc2b..625a4e55ddf8 100644
--- a/x11-wm/afterstep-stable/Makefile
+++ b/x11-wm/afterstep-stable/Makefile
@@ -1,47 +1,43 @@
-# New ports collection makefile for: afterstep-stable
-# Date created: 1 May 1998
-# Whom: Brett Taylor <brett@peloton.physics.montana.edu>
-#
+# Created by: Brett Taylor <brett@peloton.physics.montana.edu>
# $FreeBSD$
-#
PORTNAME= afterstep
-PORTVERSION= 2.2.11
-PORTREVISION= 1
+PORTVERSION= 2.2.12
CATEGORIES= x11-wm afterstep
-MASTER_SITES= ftp://ftp.afterstep.org/stable/ \
- SF/${PORTNAME}/AfterStep/${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
+MASTER_SITE_SUBDIR= stable
DISTNAME= AfterStep-${PORTVERSION}
MAINTAINER= glewis@FreeBSD.org
COMMENT= A stable version of the AfterStep window manager
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
- execinfo.1:${PORTSDIR}/devel/libexecinfo \
- freetype.9:${PORTSDIR}/print/freetype2 \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
+ execinfo:${PORTSDIR}/devel/libexecinfo \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype:${PORTSDIR}/print/freetype2 \
+ gif:${PORTSDIR}/graphics/giflib \
+ jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
- rplay.1:${PORTSDIR}/audio/rplay \
- rsvg-2.2:${PORTSDIR}/graphics/librsvg2 \
- tiff.4:${PORTSDIR}/graphics/tiff \
- gif.5:${PORTSDIR}/graphics/giflib
+ tiff:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= xli:${PORTSDIR}/graphics/xli
USE_BZIP2= yes
-USE_GNOME= glib20 gtk20 pango
-USES= iconv
-USE_XORG+= ice sm x11 xcursor xext xfixes xi xinerama xrandr xrender
+USE_GMAKE= yes
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 librsvg2 pango
+USE_XORG+= ice sm x11 xcomposite xcursor xdamage xext xfixes xi xinerama \
+ xrandr xrender
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS+=--disable-ascp \
--enable-i18n \
--disable-send-postcard-to-developer \
--with-helpcommand="xterm -e man" \
+ --x-includes="${LOCALBASE}/include" \
--with-jpeg-includes="${LOCALBASE}/include" \
- --with-jpeg-libs="${LOCALBASE}/lib" \
--with-png-includes="${LOCALBASE}/include" \
- --with-png-libs="${LOCALBASE}/lib" \
- --with-ungif
+ --with-gif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-devel-${PORTVERSION}
MAN1= ASDatabase.1x ASDatabaseEntry.1x AfterStep.1x Align.1x \
Animate.1x AnimateTypes.1x Arrange.1x AutoExec.1x \
@@ -74,25 +70,25 @@ post-extract:
${WRKSRC}/afterstep/desktop/icons/xml/monitor-bsd.xpm
post-patch:
-.for file in afterstep/database
+.for f in afterstep/database
@${REINPLACE_CMD} -e 's,linux-penguin,monitor-bsd,' \
- ${WRKSRC}/${file}
+ ${WRKSRC}/${f}
.endfor
-.for file in libAfterBase/Makefile.in libAfterImage/Makefile.in
+.for f in libAfterBase/Makefile.in libAfterImage/Makefile.in
@${REINPLACE_CMD} -e 's,^install\.,noinstall.,g ; \
- s,^install:,install:#,g' ${WRKSRC}/${file}
+ s,^install:,install:#,g' ${WRKSRC}/${f}
.endfor
-.for file in libAfterBase/configure libAfterImage/configure
+.for f in libAfterBase/configure libAfterImage/configure
@${REINPLACE_CMD} -e 's,="-O3",="$$CFLAGS",g' \
- ${WRKSRC}/${file}
+ ${WRKSRC}/${f}
.endfor
-.for file in libAfterStep/afterstep-config.in
+.for f in libAfterStep/afterstep-config.in
@${REINPLACE_CMD} -e 's,ft_version,libafterstep_version,g' \
- ${WRKSRC}/${file}
+ ${WRKSRC}/${f}
.endfor
-.for file in configure libAfterBase/configure libAfterConf/Makefile.in libAfterImage/configure
+.for f in configure libAfterBase/configure libAfterConf/Makefile.in libAfterImage/configure
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
- ${WRKSRC}/${file}
+ ${WRKSRC}/${f}
.endfor
.include <bsd.port.post.mk>
diff --git a/x11-wm/afterstep-stable/distinfo b/x11-wm/afterstep-stable/distinfo
index a4999fb725ef..af523479aeef 100644
--- a/x11-wm/afterstep-stable/distinfo
+++ b/x11-wm/afterstep-stable/distinfo
@@ -1,2 +1,2 @@
-SHA256 (AfterStep-2.2.11.tar.bz2) = ca7e872fc4d8320899667087d934e0672a3f38264a5207ea314d3c20242903aa
-SIZE (AfterStep-2.2.11.tar.bz2) = 6126237
+SHA256 (AfterStep-2.2.12.tar.bz2) = ff15da51d4122b8e0286567052951e11a746e7d878dade9ce37f9217439ffbc8
+SIZE (AfterStep-2.2.12.tar.bz2) = 6132233
diff --git a/x11-wm/afterstep-stable/files/patch-configure b/x11-wm/afterstep-stable/files/patch-configure
index 3ae52c9596a0..066581d04b12 100644
--- a/x11-wm/afterstep-stable/files/patch-configure
+++ b/x11-wm/afterstep-stable/files/patch-configure
@@ -2,15 +2,6 @@ $FreeBSD$
--- configure Sat Jun 24 21:55:24 2006
+++ configure.orig Sat Jun 24 21:54:41 2006
-@@ -1811,7 +1811,7 @@
- # Check whether --enable-reuse-font or --disable-reuse-font was given.
- if test "${enable_reuse_font+set}" = set; then
- enableval="$enable_reuse_font"
-- if test x$enableval == "xyes"; then
-+ if test x$enableval = "xyes"; then
- cat >>confdefs.h <<\_ACEOF
- #define MODULE_REUSE_LOADED_FONT 1
- _ACEOF
@@ -7955,7 +7955,7 @@
fi
@@ -38,3 +29,12 @@ $FreeBSD$
AFTERIMAGE_STATIC_LIB="../../libAfterImage/libAfterImage.a"
AFTERSTEP_STATIC_LIB="../../libAfterStep/libAfterStep.a"
AFTERCONF_STATIC_LIB="../../libAfterConf/libAfterConf.a"
+@@ -7660,7 +7660,7 @@
+
+ fi
+
+- export CFLAGS=$gio_saved_cflags
++ export CFLAGS="$gio_saved_cflags"
+
+ present_libs="$LDFLAGS $LIBS $x_libs $AFTERIMAGE_LIBS";
+ for l in `echo "$GIOLIB_LIBS"`; do
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterImage-export.c b/x11-wm/afterstep-stable/files/patch-libAfterImage-export.c
deleted file mode 100644
index 2c5e7660c5bb..000000000000
--- a/x11-wm/afterstep-stable/files/patch-libAfterImage-export.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libAfterImage/export.c.orig 2010-09-23 22:52:15.000000000 +0200
-+++ libAfterImage/export.c 2012-05-06 07:25:17.000000000 +0200
-@@ -496,7 +496,7 @@
- png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
- if ( png_ptr != NULL )
- if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
-- if( setjmp(png_ptr->jmpbuf) )
-+ if( setjmp(png_jmpbuf(png_ptr)) )
- {
- png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
- info_ptr = NULL ;
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterImage-import.c b/x11-wm/afterstep-stable/files/patch-libAfterImage-import.c
deleted file mode 100644
index bef85880f392..000000000000
--- a/x11-wm/afterstep-stable/files/patch-libAfterImage-import.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- libAfterImage/import.c.orig 2010-09-23 22:57:57.000000000 +0200
-+++ libAfterImage/import.c 2012-05-06 09:30:26.000000000 +0200
-@@ -40,6 +40,7 @@
- # else
- # include <png.h>
- # endif
-+# include <pngpriv.h>
- #else
- # include <setjmp.h>
- # ifdef HAVE_JPEG
-@@ -1251,7 +1252,7 @@
- * the normal method of doing things with libpng). REQUIRED unless you
- * set up your own error handlers in the png_create_read_struct() earlier.
- */
-- if ( !setjmp (png_ptr->jmpbuf))
-+ if ( !setjmp (png_jmpbuf(png_ptr)))
- {
- ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
-
diff --git a/x11-wm/afterstep-stable/pkg-plist b/x11-wm/afterstep-stable/pkg-plist
index 608c8cdc4e7e..a9e32cd74aa8 100644
--- a/x11-wm/afterstep-stable/pkg-plist
+++ b/x11-wm/afterstep-stable/pkg-plist
@@ -1,4 +1,5 @@
bin/ASFileBrowser
+bin/ASMount
bin/ASRun
bin/ASWallpaper
bin/Animate
@@ -90,6 +91,7 @@ lib/libAfterStep.a
%%DATADIR%%/applications/terminals.desktop
%%DATADIR%%/applications/text_editors.desktop
%%DATADIR%%/applications/xtools.desktop
+%%DATADIR%%/asmount
%%DATADIR%%/autoexec
%%DATADIR%%/backgrounds/.Cell
%%DATADIR%%/backgrounds/.CloudsOfDoubt
@@ -388,6 +390,9 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/buttons/default-switchwindow-dark-pressed
%%DATADIR%%/desktop/buttons/default-switchwindow-light
%%DATADIR%%/desktop/buttons/default-switchwindow-light-pressed
+%%DATADIR%%/desktop/buttons/eject-red
+%%DATADIR%%/desktop/buttons/eject-red-pressed
+%%DATADIR%%/desktop/buttons/eject-white
%%DATADIR%%/desktop/buttons/fuf-iconify-pressed.xpm
%%DATADIR%%/desktop/buttons/fuf-iconify.xpm
%%DATADIR%%/desktop/buttons/fuf-kill-pressed.xpm
@@ -414,6 +419,8 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/buttons/glass-switchwindow-pressed
%%DATADIR%%/desktop/buttons/menu_smooth
%%DATADIR%%/desktop/buttons/minmax_smooth
+%%DATADIR%%/desktop/buttons/mount-green-pressed
+%%DATADIR%%/desktop/buttons/mount-white
%%DATADIR%%/desktop/buttons/qnx-close
%%DATADIR%%/desktop/buttons/qnx-close-pressed
%%DATADIR%%/desktop/buttons/qnx-iconify
@@ -436,6 +443,8 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/buttons/unity-menu
%%DATADIR%%/desktop/buttons/unity-shade
%%DATADIR%%/desktop/buttons/unity-switchwindow
+%%DATADIR%%/desktop/buttons/unmount-red-pressed
+%%DATADIR%%/desktop/buttons/unmount-white
%%DATADIR%%/desktop/cursors/cursor.xbm
%%DATADIR%%/desktop/cursors/cursor.xbm.mask
%%DATADIR%%/desktop/cursors/iconify.xbm
@@ -464,6 +473,9 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/fonts/DefaultSansBold.ttf
%%DATADIR%%/desktop/fonts/DefaultSansBoldOblique.ttf
%%DATADIR%%/desktop/fonts/DefaultSansOblique.ttf
+%%DATADIR%%/desktop/icons/128x128/Logout
+%%DATADIR%%/desktop/icons/128x128/MusicalNote
+%%DATADIR%%/desktop/icons/128x128/SpeechBubble
%%DATADIR%%/desktop/icons/3_dots.xpm
%%DATADIR%%/desktop/icons/3dpaint.xpm
%%DATADIR%%/desktop/icons/ASBBlockBlue.xpm
@@ -633,6 +645,7 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/icons/dots/bar_medium
%%DATADIR%%/desktop/icons/dots/circle_medium
%%DATADIR%%/desktop/icons/dots/close_smooth_white
+%%DATADIR%%/desktop/icons/dots/eject
%%DATADIR%%/desktop/icons/dots/lined_arrow
%%DATADIR%%/desktop/icons/dots/maxmin_unity
%%DATADIR%%/desktop/icons/dots/menu_medium
@@ -648,6 +661,7 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/icons/dots/shade_unity
%%DATADIR%%/desktop/icons/dots/square_medium
%%DATADIR%%/desktop/icons/dots/square_small
+%%DATADIR%%/desktop/icons/dots/synchronize
%%DATADIR%%/desktop/icons/dots/triangle_medium
%%DATADIR%%/desktop/icons/dots/triangle_squared_medium
%%DATADIR%%/desktop/icons/dots/triangle_squared_small
@@ -749,6 +763,7 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/icons/logos/Xmms
%%DATADIR%%/desktop/icons/logos/aterm
%%DATADIR%%/desktop/icons/logos/aterm2
+%%DATADIR%%/desktop/icons/logos/aterm3
%%DATADIR%%/desktop/icons/logos/gimp
%%DATADIR%%/desktop/icons/logos/konqueror
%%DATADIR%%/desktop/icons/logos/linux-penguin
@@ -777,6 +792,7 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/icons/mini/Info
%%DATADIR%%/desktop/icons/mini/KDESearchTool
%%DATADIR%%/desktop/icons/mini/KDEWallpapers
+%%DATADIR%%/desktop/icons/mini/Logout
%%DATADIR%%/desktop/icons/mini/Menu
%%DATADIR%%/desktop/icons/mini/Mona
%%DATADIR%%/desktop/icons/mini/MoonInMonitor
@@ -784,8 +800,10 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/icons/mini/Puzzle
%%DATADIR%%/desktop/icons/mini/Recycler
%%DATADIR%%/desktop/icons/mini/RemoteControl
+%%DATADIR%%/desktop/icons/mini/Shutdown
%%DATADIR%%/desktop/icons/mini/Stopsign
%%DATADIR%%/desktop/icons/mini/Windows
+%%DATADIR%%/desktop/icons/mini/ZZZ
%%DATADIR%%/desktop/icons/mini/applications
%%DATADIR%%/desktop/icons/mini/feel
%%DATADIR%%/desktop/icons/mini/look
@@ -892,7 +910,6 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/icons/normal/House3
%%DATADIR%%/desktop/icons/normal/IRC
%%DATADIR%%/desktop/icons/normal/IRCTransparent
-%%DATADIR%%/desktop/icons/normal/IRC_Transp
%%DATADIR%%/desktop/icons/normal/Info
%%DATADIR%%/desktop/icons/normal/InkJetPrinter
%%DATADIR%%/desktop/icons/normal/JFK
@@ -911,6 +928,7 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/icons/normal/Lightswitch
%%DATADIR%%/desktop/icons/normal/LockClosed
%%DATADIR%%/desktop/icons/normal/LockOpen
+%%DATADIR%%/desktop/icons/normal/Logout
%%DATADIR%%/desktop/icons/normal/MCInMonitor
%%DATADIR%%/desktop/icons/normal/MCInMonitorShadow
%%DATADIR%%/desktop/icons/normal/MagnifyingGlass
@@ -1233,6 +1251,7 @@ lib/libAfterStep.a
%%DATADIR%%/doc/html/winlist_sticky.html
%%DATADIR%%/doc/html/winlist_unfocused.html
%%DATADIR%%/feels/feel.DEFAULT
+%%DATADIR%%/feels/feel.Debian
%%DATADIR%%/feels/feel.ICCCM
%%DATADIR%%/gtkrc-2.0_template
%%DATADIR%%/gtkrc_template
@@ -1294,31 +1313,13 @@ lib/libAfterStep.a
%%DATADIR%%/start/1_Desktop/Menu_Options/5_recentitems
%%DATADIR%%/start/1_Desktop/Pictures/.include
%%DATADIR%%/start/1_Desktop/Pictures/AfterStep_Images/.include
-%%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/.include
-%%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/GNOME_Branded/.include
-%%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/GNOME_Nature/.include
-%%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/GNOME_Tiles/.include
-%%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/GNOME_Translucent/.include
-%%DATADIR%%/start/1_Desktop/Pictures/KDE_Wallpapers/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Nautilus_Patterns/.include
%%DATADIR%%/start/1_Desktop/Pictures/Other/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/For-E/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_01/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_02/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_03/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_04/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_05/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_06/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_07/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_08/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_09/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_10/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_11/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_12/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_13/.include
-%%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_14/.include
%%DATADIR%%/start/1_Desktop/Pictures/User_Backgrounds/.include
+%%DATADIR%%/start/1_Desktop/Pictures/Web/Digital_Blasphemy
+%%DATADIR%%/start/1_Desktop/Pictures/Web/Mountains
+%%DATADIR%%/start/1_Desktop/Pictures/Web/Vladstudio_com
+%%DATADIR%%/start/1_Desktop/Pictures/Web/Walk_In_Clouds
+%%DATADIR%%/start/1_Desktop/Pictures/Web/Water
%%DATADIR%%/start/1_Desktop/Theme/.include
%%DATADIR%%/start/1_Desktop/X_Tools/.include
%%DATADIR%%/start/1_Desktop/X_Tools/Mouse/.include
@@ -1339,6 +1340,10 @@ lib/libAfterStep.a
%%DATADIR%%/start/3_Screen_savers/With_password/.include
%%DATADIR%%/start/3_Screen_savers/Without_password/.include
%%DATADIR%%/start/3_System_Settings/.include
+%%DATADIR%%/start/3_System_Settings/Gnome_Hardware_Settings/.include
+%%DATADIR%%/start/3_System_Settings/Gnome_Settings_Panel/.include
+%%DATADIR%%/start/3_System_Settings/Gnome_Settings_Panel/Other/.include
+%%DATADIR%%/start/3_System_Settings/XFCE_Settings/.include
%%DATADIR%%/start/3_run
%%DATADIR%%/start/4_Windows/.include
%%DATADIR%%/start/4_Windows/0_Arrange/.include
@@ -1355,24 +1360,32 @@ lib/libAfterStep.a
%%DATADIR%%/start/4_Windows/5_destroy
%%DATADIR%%/start/4_Windows/6_winprop
%%DATADIR%%/start/4_Windows/7_fullscreen
+%%DATADIR%%/start/4_xterminal
%%DATADIR%%/start/4_zzznop
%%DATADIR%%/start/5_Quit/.include
%%DATADIR%%/start/5_Quit/0_close
+%%DATADIR%%/start/5_Quit/0_nop
+%%DATADIR%%/start/5_Quit/1_shutdown
+%%DATADIR%%/start/5_Quit/2_hibernate
+%%DATADIR%%/start/5_Quit/2_suspend
+%%DATADIR%%/start/5_Quit/3_nop
%%DATADIR%%/start/5_Quit/3_restartsession
+%%DATADIR%%/start/5_Quit/4_quit
%%DATADIR%%/start/7_About_AfterStep/.include
%%DATADIR%%/themes/DEFAULT.tar.gz
%%DATADIR%%/themes/Default
%%DATADIR%%/wharf
%%DATADIR%%/winlist
%%DATADIR%%/wintabs
-%%GNOME%%share/gnome/wm-properties/AfterStep.desktop
-share/xsessions/AfterStep.desktop
-@dirrmtry share/xsessions
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%/start/7_About_AfterStep
@dirrm %%DATADIR%%/start/5_Quit
@dirrm %%DATADIR%%/start/4_Windows/0_Arrange
@dirrm %%DATADIR%%/start/4_Windows
+@dirrm %%DATADIR%%/start/3_System_Settings/XFCE_Settings
+@dirrm %%DATADIR%%/start/3_System_Settings/Gnome_Settings_Panel/Other
+@dirrm %%DATADIR%%/start/3_System_Settings/Gnome_Settings_Panel
+@dirrm %%DATADIR%%/start/3_System_Settings/Gnome_Hardware_Settings
@dirrm %%DATADIR%%/start/3_System_Settings
@dirrm %%DATADIR%%/start/3_Screen_savers/Without_password
@dirrm %%DATADIR%%/start/3_Screen_savers/With_password
@@ -1381,31 +1394,9 @@ share/xsessions/AfterStep.desktop
@dirrm %%DATADIR%%/start/1_Desktop/X_Tools/Mouse
@dirrm %%DATADIR%%/start/1_Desktop/X_Tools
@dirrm %%DATADIR%%/start/1_Desktop/Theme
+@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Web
@dirrm %%DATADIR%%/start/1_Desktop/Pictures/User_Backgrounds
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_14
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_13
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_12
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_11
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_10
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_09
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_08
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_07
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_06
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_05
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_04
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_03
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_02
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/Volume_01
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images/For-E
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Propaganda_Images
@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Other
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/Nautilus_Patterns
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/KDE_Wallpapers
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/GNOME_Translucent
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/GNOME_Tiles
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/GNOME_Nature
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images/GNOME_Branded
-@dirrm %%DATADIR%%/start/1_Desktop/Pictures/GNOME_Images
@dirrm %%DATADIR%%/start/1_Desktop/Pictures/AfterStep_Images
@dirrm %%DATADIR%%/start/1_Desktop/Pictures
@dirrm %%DATADIR%%/start/1_Desktop/Menu_Options
@@ -1445,6 +1436,7 @@ share/xsessions/AfterStep.desktop
@dirrm %%DATADIR%%/desktop/icons/logos
@dirrm %%DATADIR%%/desktop/icons/large
@dirrm %%DATADIR%%/desktop/icons/dots
+@dirrm %%DATADIR%%/desktop/icons/128x128
@dirrm %%DATADIR%%/desktop/icons
@dirrm %%DATADIR%%/desktop/fonts
@dirrm %%DATADIR%%/desktop/cursors