aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-12 17:34:18 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-12 17:34:18 +0000
commit6c1c5b05f5a4727886d4be7b74ffa44de2ff2ea2 (patch)
tree930037d6329a0e3536128d8efa081946d69e227f /x11-wm/afterstep
parent73b65aa5279b1171ece7e966135c56303750dfc3 (diff)
downloadports-6c1c5b05f5a4727886d4be7b74ffa44de2ff2ea2.tar.gz
ports-6c1c5b05f5a4727886d4be7b74ffa44de2ff2ea2.zip
Fix build with clang
Notes
Notes: svn path=/head/; revision=320708
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index a109c0dadbbb..09c4ce7254a8 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -22,6 +22,7 @@ MANCOMPRESSED= yes
MAN1= afterstep.1 Animate.1 Audio.1 Auto.1 Banner.1 Pager.1 Wharf.1
CONFLICTS?= afterstep-2*
PORTSCOUT= limit:^1\.[0-9.]*$$
+CFLAGS+= -Wno-return-type
SRCDIRS= afterstep \
modules/Animate modules/Audio modules/Auto \
@@ -33,6 +34,9 @@ post-patch:
-e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/configure.h \
${WRKSRC}/sample.steprc
+ ${REINPLACE_CMD} \
+ -e 's/__inline__//g' \
+ ${WRKSRC}/configure.h
@ for i in ${SRCDIRS}; do \
cd ${WRKSRC}/$$i; \
${MV} Imakefile Imakefile.orig; \