aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /x11-wm/afterstep
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index e3bd29abbcb5..500973349b09 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= asclock:${PORTSDIR}/x11-clocks/asclock
NO_LATEST_LINK= yes
USE_XORG= xpm xext x11
-USE_IMAKE= yes
+USES= imake
INSTALL_TARGET= install install.man
MANCOMPRESSED= yes
MAN1= afterstep.1 Animate.1 Audio.1 Auto.1 Banner.1 Pager.1 Wharf.1
@@ -42,7 +42,7 @@ post-patch:
done
pre-build:
- @ cd ${WRKSRC}; ${SH} MakeMakefiles
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} MakeMakefiles
post-install:
@ ${MKDIR} ${PREFIX}/lib/X11/afterstep/backgrounds/