aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/bbkeys
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-06-23 08:19:35 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-06-23 08:19:35 +0000
commita75d049e143e329326cc0ea92bee3b794dd4b55b (patch)
tree08e9f5ae0e9c49f80b020587db24a9d84b2b19fc /x11-wm/bbkeys
parent4d8593594d6baf61148b0fe3a5b8307d10776dd0 (diff)
downloadports-a75d049e143e329326cc0ea92bee3b794dd4b55b.tar.gz
ports-a75d049e143e329326cc0ea92bee3b794dd4b55b.zip
- Fix segfault on 6.x.
PR: ports/82563 Submitted by: maintainer Obtained from: bbkeys CVS
Notes
Notes: svn path=/head/; revision=137907
Diffstat (limited to 'x11-wm/bbkeys')
-rw-r--r--x11-wm/bbkeys/Makefile2
-rw-r--r--x11-wm/bbkeys/files/patch-src_KeyClient.cpp14
2 files changed, 15 insertions, 1 deletions
diff --git a/x11-wm/bbkeys/Makefile b/x11-wm/bbkeys/Makefile
index ff6bfa5623d2..d3503109f304 100644
--- a/x11-wm/bbkeys/Makefile
+++ b/x11-wm/bbkeys/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bbkeys
PORTVERSION= 0.9.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/x11-wm/bbkeys/files/patch-src_KeyClient.cpp b/x11-wm/bbkeys/files/patch-src_KeyClient.cpp
new file mode 100644
index 000000000000..89200e5f00ca
--- /dev/null
+++ b/x11-wm/bbkeys/files/patch-src_KeyClient.cpp
@@ -0,0 +1,14 @@
+--- src/KeyClient.cpp.orig Thu Jun 9 09:07:14 2005
++++ src/KeyClient.cpp Thu Jun 9 09:10:24 2005
+@@ -102,6 +102,11 @@
+ _netclient = new Netclient(this->display());
+ _active = _clients.end();
+
++ // Initialize uninitialized pointers to NULL
++ _keybindings = NULL;
++ config_check_timer = NULL;
++
++
+ initialize();
+ }
+