aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/bbpager/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-04 04:31:05 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-04 04:31:05 +0000
commit3d0fc197d0ff25f3c69b721b24cd23509148eb2e (patch)
tree01aaee77b46d03f1a91967da3eed9f1f5493ad1b /x11-wm/bbpager/Makefile
parentfd69b67ceda54b3c15fbb7924a781a0d42d14203 (diff)
downloadports-3d0fc197d0ff25f3c69b721b24cd23509148eb2e.tar.gz
ports-3d0fc197d0ff25f3c69b721b24cd23509148eb2e.zip
Notes
Diffstat (limited to 'x11-wm/bbpager/Makefile')
-rw-r--r--x11-wm/bbpager/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/x11-wm/bbpager/Makefile b/x11-wm/bbpager/Makefile
index e7334ee59eb1..2ab8ec35c901 100644
--- a/x11-wm/bbpager/Makefile
+++ b/x11-wm/bbpager/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= bbpager
-DISTVERSION= 0.4.3
-PORTREVISION= 1
+DISTVERSION= 0.4.7
CATEGORIES= x11-wm
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= bbtools
MAINTAINER= A.J.Caines@halplant.com
@@ -17,29 +16,23 @@ COMMENT= A pager for the Blackbox window manager
BUILD_DEPENDS= blackbox:${PORTSDIR}/x11-wm/blackbox
-USE_X_PREFIX= yes
USE_GNOME= gnomehack pkgconfig
-USE_GCC= 3.3+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="`pkg-config --cflags xft`" \
LDFLAGS="`pkg-config --libs xft`"
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-PORTDOCS= README.bbpager
-PLIST_FILES= bin/bbpager %%DATADIR%%/bbpager.rc
-PLIST_DIRS= %%DATADIR%%
+DOCS= AUTHORS BUGS COPYING ChangeLog INSTALL NEWS \
+ README TODO
+EXAMPLES= bbpager.rc README.bbpager
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/bbpager ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/data/bbpager.rc ${DATADIR}/
-
-post-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/bbpager ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/data/${file} ${DOCSDIR}/
-.endfor
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/data/,} ${EXAMPLESDIR}/
.endif
.include <bsd.port.mk>