aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/blackbox
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-19 11:28:11 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-19 11:28:11 +0000
commit433cdeafb5b808b8db121d49b0bc3d36531906ab (patch)
treee497915cd429e06d47a71079c870b339644fd62e /x11-wm/blackbox
parent897319326dd2b8fd09235f00744a99a121cde7fd (diff)
downloadports-433cdeafb5b808b8db121d49b0bc3d36531906ab.tar.gz
ports-433cdeafb5b808b8db121d49b0bc3d36531906ab.zip
- Fix build on -current
PR: 58235 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=91668
Diffstat (limited to 'x11-wm/blackbox')
-rw-r--r--x11-wm/blackbox/Makefile1
-rw-r--r--x11-wm/blackbox/files/patch-src::Window.cc10
2 files changed, 11 insertions, 0 deletions
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index c592ae897c78..a62ccf5a846d 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -23,6 +23,7 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
pre-patch:
+ ${REINPLACE_CMD} -e 's#-pedantic##' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's#nls src util#nls src#' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -E 's/^SUBDIRS/#SUBDIRS/' ${WRKSRC}/doc/Makefile.in
${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' ${WRKSRC}/doc/Makefile.in
diff --git a/x11-wm/blackbox/files/patch-src::Window.cc b/x11-wm/blackbox/files/patch-src::Window.cc
new file mode 100644
index 000000000000..ec6c3afd4e04
--- /dev/null
+++ b/x11-wm/blackbox/files/patch-src::Window.cc
@@ -0,0 +1,10 @@
+--- src/Window.cc.orig Wed Aug 13 12:40:02 2003
++++ src/Window.cc Wed Aug 13 12:41:03 2003
+@@ -44,6 +44,8 @@
+ #endif // HAVE_STDLIB_H
+ }
++#include <cassert>
++
+ #include "i18n.hh"
+ #include "blackbox.hh"
+ #include "GCCache.hh"