aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/cage
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-04-26 17:36:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-04-26 17:36:19 +0000
commit0a19420a6e738bee66d7fdcb4f5a14bda878f128 (patch)
treeb9d31589852e67e87d361cfa6b90440ac6dad875 /x11-wm/cage
parent823c5067aaf5c64311d476ca0e7d32c9327d24da (diff)
downloadports-0a19420a6e738bee66d7fdcb4f5a14bda878f128.tar.gz
ports-0a19420a6e738bee66d7fdcb4f5a14bda878f128.zip
Notes
Diffstat (limited to 'x11-wm/cage')
-rw-r--r--x11-wm/cage/Makefile39
-rw-r--r--x11-wm/cage/distinfo7
-rw-r--r--x11-wm/cage/pkg-descr8
3 files changed, 54 insertions, 0 deletions
diff --git a/x11-wm/cage/Makefile b/x11-wm/cage/Makefile
new file mode 100644
index 000000000000..31242f739398
--- /dev/null
+++ b/x11-wm/cage/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= cage
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1
+CATEGORIES= x11-wm
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= c69d394bedc6.patch:-p1
+PATCHFILES+= 00fe8d7ce3d5.patch:-p1
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Wayland kiosk
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ wayland-protocols>=1.14:graphics/wayland-protocols \
+ wlroots>=0.5.0:x11-toolkits/wlroots
+LIB_DEPENDS= libwayland-server.so:graphics/wayland \
+ libwlroots.so:x11-toolkits/wlroots \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 meson pkgconfig
+USE_GITHUB= yes
+USE_XORG= pixman
+GH_ACCOUNT= Hjdskes
+PLIST_FILES= "${MAYBE_SUID}bin/${PORTNAME}"
+
+OPTIONS_DEFINE= SUID X11
+OPTIONS_DEFAULT=SUID X11
+
+SUID_DESC= setuid bit on "${PORTNAME}" binary (required for DRM session)
+SUID_VARS= MAYBE_SUID="@(,,4755) "
+
+X11_MESON_TRUE= xwayland
+
+.include <bsd.port.mk>
diff --git a/x11-wm/cage/distinfo b/x11-wm/cage/distinfo
new file mode 100644
index 000000000000..57ed35ff305b
--- /dev/null
+++ b/x11-wm/cage/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1552316236
+SHA256 (Hjdskes-cage-v0.1_GH0.tar.gz) = 03e2b4d97744aead935f4a289e5cfda4888dd06c6586982f4a25c8f435ef4166
+SIZE (Hjdskes-cage-v0.1_GH0.tar.gz) = 19838
+SHA256 (c69d394bedc6.patch) = 0c6101fa17248e170c202b43d682af1f25c9584e324ea01da43c6775ede5c9b4
+SIZE (c69d394bedc6.patch) = 654
+SHA256 (00fe8d7ce3d5.patch) = 194aef0c60c0a4e9a2a8d6c7b33341caaccb64f183488d009b1a61f8fc06db00
+SIZE (00fe8d7ce3d5.patch) = 1258
diff --git a/x11-wm/cage/pkg-descr b/x11-wm/cage/pkg-descr
new file mode 100644
index 000000000000..29687323d074
--- /dev/null
+++ b/x11-wm/cage/pkg-descr
@@ -0,0 +1,8 @@
+Cage is a kiosk compositor for Wayland. A kiosk is a window manager
+(in the X11 world) or compositor (in the Wayland world) that is
+designed for a user experience wherein user interaction and activities
+outside the scope of the running application are prevented. That is, a
+kiosk compositor displays a single maximized application at a time and
+prevents the user from interacting with anything but this application.
+
+WWW: https://hjdskes.nl/projects/cage