aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/cage
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-01-26 00:06:03 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-01-26 00:06:03 +0000
commite1ffc8d0789bfb73658d653a47eb5179d0e86bf2 (patch)
tree7716c73456ee95c84b6afe8c652127540e6304e6 /x11-wm/cage
parentb61e67ce31b9781b683c09c0768e5a7486307539 (diff)
downloadports-e1ffc8d0789bfb73658d653a47eb5179d0e86bf2.tar.gz
ports-e1ffc8d0789bfb73658d653a47eb5179d0e86bf2.zip
x11-wm/cage: follow up for r522232
Notes
Notes: svn path=/head/; revision=524144
Diffstat (limited to 'x11-wm/cage')
-rw-r--r--x11-wm/cage/Makefile2
-rw-r--r--x11-wm/cage/files/patch-wlroots-0.910
2 files changed, 10 insertions, 2 deletions
diff --git a/x11-wm/cage/Makefile b/x11-wm/cage/Makefile
index 6b2fd834412c..589763c24398 100644
--- a/x11-wm/cage/Makefile
+++ b/x11-wm/cage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cage
DISTVERSIONPREFIX= v
DISTVERSION= 0.1.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-wm
MAINTAINER= jbeich@FreeBSD.org
diff --git a/x11-wm/cage/files/patch-wlroots-0.9 b/x11-wm/cage/files/patch-wlroots-0.9
index 83475d0d0128..b3cfa3668571 100644
--- a/x11-wm/cage/files/patch-wlroots-0.9
+++ b/x11-wm/cage/files/patch-wlroots-0.9
@@ -21,7 +21,15 @@ https://github.com/Hjdskes/cage/commit/51e6c760da51
with a proper wl_display. */
--- output.c.orig 2019-06-03 17:55:52 UTC
+++ output.c
-@@ -386,6 +386,9 @@ handle_new_output(struct wl_listener *listener, void *
+@@ -207,6 +207,7 @@ handle_output_damage_frame(struct wl_listener *listene
+ }
+
+ if (!needs_frame) {
++ wlr_output_rollback(output->wlr_output);
+ wlr_log(WLR_DEBUG, "Output doesn't need frame and isn't damaged");
+ goto buffer_damage_finish;
+ }
+@@ -386,6 +387,9 @@ handle_new_output(struct wl_listener *listener, void *
/* Place the cursor in the center of the screen. */
wlr_cursor_warp(server->seat->cursor, NULL, wlr_output->width / 2, wlr_output->height / 2);
wlr_output_damage_add_whole(server->output->damage);