aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compiz
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-12 05:27:57 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-12 05:27:57 +0000
commitbcc0bfc29764a88cb4bbccb22c1cb6c42c5eb570 (patch)
tree5b40f0f99a1e8c91786a5f7eb356d043f722e7d4 /x11-wm/compiz
parentf006cc33630b950a03dcb79c09fac93c536ec112 (diff)
downloadports-bcc0bfc29764a88cb4bbccb22c1cb6c42c5eb570.tar.gz
ports-bcc0bfc29764a88cb4bbccb22c1cb6c42c5eb570.zip
- Fix compiz-manager script to work with Nvidia graphics card.
- Add run_depends needed by compiz-manager script. - Portlint. - Bump portrevision. PR: ports/151137 Submitted by: Ivan Klymenko <fidaj@ukr.net> Approved by: gabor (mentor)
Notes
Notes: svn path=/head/; revision=277576
Diffstat (limited to 'x11-wm/compiz')
-rw-r--r--x11-wm/compiz/Makefile7
-rw-r--r--x11-wm/compiz/files/compiz-manager.in4
-rw-r--r--x11-wm/compiz/pkg-message1
3 files changed, 6 insertions, 6 deletions
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index 9a80d72f859b..6bcd369edb33 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -7,7 +7,7 @@
PORTNAME= compiz
PORTVERSION= 0.8.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
@@ -17,6 +17,8 @@ COMMENT= Compiz Composite/Window Manager
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
gtop-2.0.7:${PORTSDIR}/devel/libgtop \
startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= glxinfo:${PORTSDIR}/graphics/mesa-demos \
+ nvidia-settings:${PORTSDIR}/x11/nvidia-settings
XORG_CAT= app
GNU_CONFIGURE= yes
@@ -65,8 +67,7 @@ GCONF_SCHEMAS= gwd.schemas \
compiz-zoom.schemas
CONFIGURE_ARGS= --disable-kde4
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
OPTIONS= RSVG "Enable librsvg2 support" on \
GTK "Enable gtk2 support" on \
diff --git a/x11-wm/compiz/files/compiz-manager.in b/x11-wm/compiz/files/compiz-manager.in
index adfd309d3830..c5a521d14b5a 100644
--- a/x11-wm/compiz/files/compiz-manager.in
+++ b/x11-wm/compiz/files/compiz-manager.in
@@ -36,7 +36,7 @@ XFWM="%%LOCALBASE%%/bin/xfwm"
COMPIZ_NAME="compiz" # Final name for compiz (compiz.real)
# For Xgl LD_PRELOAD
-LIBGL_NVIDIA="/usr/lib/nvidia/libGL.so.1.2.xlibmesa"
+LIBGL_NVIDIA="%%LOCALBASE%%/lib/libGL.so"
LIBGL_FGLRX="/usr/lib/fglrx/libGL.so.1.2.xlibmesa"
# Minimum amount of memory (in kilo bytes) that nVidia cards need
@@ -206,7 +206,7 @@ check_xgl()
# Check if the nVidia card has enough video ram to make sense
check_nvidia_memory()
{
- MEM=$(${NVIDIA_SETTINGS} -q VideoRam | egrep Attribute\ \'VideoRam\'\ .*: | cut -d: -f3 | sed 's/[^0-9]//g')
+ MEM=$(${NVIDIA_SETTINGS} -q VideoRam | grep "Attribute 'VideoRam'"| cut -d: -f3 | sed 's/[^0-9]//g')
if [ $MEM -lt $NVIDIA_MEMORY ]; then
verbose "Less than ${NVIDIA_MEMORY}kb of memory and nVidia";
return 1;
diff --git a/x11-wm/compiz/pkg-message b/x11-wm/compiz/pkg-message
index fb8bce93719d..b7f68ab5fd79 100644
--- a/x11-wm/compiz/pkg-message
+++ b/x11-wm/compiz/pkg-message
@@ -7,4 +7,3 @@ value of:
desktop->gnome->session->required_components->windowmanager = compiz-manager
This will enable compiz as your default window manager.
-