aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e-module-alarm
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2014-11-25 03:07:22 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2014-11-25 03:07:22 +0000
commit273c6e6d76de909e0b97d381d45340af8e91a37e (patch)
treea3ede366da71e5f2c9d8a5565a987a08de3b99d0 /x11-wm/e-module-alarm
parente688f6929aa312916047cec14f32a26ac695505a (diff)
downloadports-273c6e6d76de909e0b97d381d45340af8e91a37e.tar.gz
ports-273c6e6d76de909e0b97d381d45340af8e91a37e.zip
Notes
Diffstat (limited to 'x11-wm/e-module-alarm')
-rw-r--r--x11-wm/e-module-alarm/Makefile37
-rw-r--r--x11-wm/e-module-alarm/distinfo2
-rw-r--r--x11-wm/e-module-alarm/pkg-descr3
-rw-r--r--x11-wm/e-module-alarm/pkg-plist37
4 files changed, 79 insertions, 0 deletions
diff --git a/x11-wm/e-module-alarm/Makefile b/x11-wm/e-module-alarm/Makefile
new file mode 100644
index 000000000000..bba12d4e5217
--- /dev/null
+++ b/x11-wm/e-module-alarm/Makefile
@@ -0,0 +1,37 @@
+# Created by: Grzegorz Blach <gblach@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= e-module-alarm
+PORTVERSION= 20140911
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= LOCAL/gblach/enlightenment/
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Module to set Alarms in Enlightenment
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= enlightenment
+GNU_CONFIGURE= yes
+USES= gmake libtool pkgconfig tar:xz
+INSTALL_TARGET= install-strip
+
+.include "../enlightenment/Makefile.plist"
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e-module-alarm/distinfo b/x11-wm/e-module-alarm/distinfo
new file mode 100644
index 000000000000..455ab0fd760c
--- /dev/null
+++ b/x11-wm/e-module-alarm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (enlightenment/e-module-alarm-20140911.tar.xz) = d0284c998b473a04eeddbb1b0fa8624959bee8f0e3618d97237311d16655314c
+SIZE (enlightenment/e-module-alarm-20140911.tar.xz) = 365188
diff --git a/x11-wm/e-module-alarm/pkg-descr b/x11-wm/e-module-alarm/pkg-descr
new file mode 100644
index 000000000000..ac264c0c4558
--- /dev/null
+++ b/x11-wm/e-module-alarm/pkg-descr
@@ -0,0 +1,3 @@
+A module to set Alarms in Enlightenment 17.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e-module-alarm/pkg-plist b/x11-wm/e-module-alarm/pkg-plist
new file mode 100644
index 000000000000..8d39127d11fc
--- /dev/null
+++ b/x11-wm/e-module-alarm/pkg-plist
@@ -0,0 +1,37 @@
+lib/enlightenment/modules/alarm/module.desktop
+lib/enlightenment/modules/alarm/e-module-alarm.edj
+lib/enlightenment/modules/alarm/%%ENLIGHTENMENT_ARCH%%/module.a
+lib/enlightenment/modules/alarm/%%ENLIGHTENMENT_ARCH%%/module.so
+lib/enlightenment/modules/alarm/alarm.edj
+%%NLS%%lib/enlightenment/modules/alarm/locale/ca/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/it/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/eo/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/sk/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/tr/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/vi/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/de/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/ja/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/uk/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/el/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/fi/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/sv/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/pt/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/ko/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/ru/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/zh_CN/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/cs/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/ar/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/he/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/lt/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/fr/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/nl/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/nb/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/hr/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/et/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/pt_BR/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/pl/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/es/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/hu/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/sl/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/gl/LC_MESSAGES/alarm.mo
+%%NLS%%lib/enlightenment/modules/alarm/locale/sr/LC_MESSAGES/alarm.mo