aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e16
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-18 11:51:29 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-18 11:51:29 +0000
commitd3b3c58808d9677a541b4c0e687ae0a6e9bee1c7 (patch)
treecf6133a22dd2da66e16e439f27ef699e83ce5ba2 /x11-wm/e16
parentfeaa5651be660112f863e48fbfc27cf48c16a006 (diff)
downloadports-d3b3c58808d9677a541b4c0e687ae0a6e9bee1c7.tar.gz
ports-d3b3c58808d9677a541b4c0e687ae0a6e9bee1c7.zip
- Update to 1.0.11.001
Changes: * Enable using libsndfile for sound file loading. * Focus update tweaks. * Add EventsBlock(). * Add script to place pagers (James Bowlin). * Introduce new animation engine (Daniel Manjarres). * Fix various issues reported by clang. Minor cleanups. * Fix test for XI2 availability. * Use __func__ for function names in debug stuff. * Window slide code cosmetics. * Wrap some calls to XGrab/UngrabKeyboard() + cosmetics. * Wrap XAllowEvents(). * Fix major memory leak when using XI2 events. * Cleanup around XI2 event selection. * When using XI2, handle all keyboard and pointer events via XI2. * When using XI2, handle enter/leave events via XI2. * When using XI2, handle focus change events via XI2. * Restore old pointer warping behavior on maximization. * Non-time-limited animations should not run until next ?!? * CM: Set destination clip when rendering compositing buffer to screen. * Remove long time disabled raindrops and imagespinner fx code. * No need to adjust fx on area change. * Add AnimatorDel(). * Add AnimatorGetData(). * Refactor fx. * AnimatorsDelCatAll() is now unused. * Resurrect slide shape. * Enable setting shape on multiple windows. * Remove code for shaded, semi-solid, and translucent move/resize modes. * PixImg stuff is no longer used. * Disable pseudo-transparency by default. * Add AC_CONFIG_MACRO_DIR. * Avoid warnings about uninitialised struct members. * Enable not using a container window. * Unbreak animated move/resize after recent changes. * Get frame rate from randr. * Remove obsolete ecore_x compatibility. * Add/use ecore_x_window_prop_del(). * Cosmetic change around TimersRunNextIn(). * Switch default sound support to pulseaudio/libsndfile. * Run composite rendering to screen separately from animators/idlers/ timers.
Notes
Notes: svn path=/head/; revision=312500
Diffstat (limited to 'x11-wm/e16')
-rw-r--r--x11-wm/e16/Makefile22
-rw-r--r--x11-wm/e16/distinfo4
-rw-r--r--x11-wm/e16/pkg-plist3
3 files changed, 16 insertions, 13 deletions
diff --git a/x11-wm/e16/Makefile b/x11-wm/e16/Makefile
index 84473ee90a31..86337dba0b60 100644
--- a/x11-wm/e16/Makefile
+++ b/x11-wm/e16/Makefile
@@ -2,32 +2,38 @@
# $FreeBSD$
PORTNAME= e16
-PORTVERSION= 1.0.11
+PORTVERSION= 1.0.11.001
CATEGORIES= x11-wm enlightenment
-MASTER_SITES= SF/enlightenment/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= SF/enlightenment/${PORTNAME}/Snapshots/
MAINTAINER= gahr@FreeBSD.org
COMMENT= A very artistic X window manager
-OPTIONS_DEFINE= ESOUND
-OPTIONS_DEFAULT=ESOUND
+OPTIONS_DEFINE= SOUND
+SOUND_DESC= Sound support via pulseaudio/libsndfile
USE_XORG= compositeproto damageproto xextproto x11 xbitmaps xcomposite xdamage \
xext xfixes xft xinerama xrandr xrender xxf86vm
USE_ICONV= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
USE_EFL= imlib2
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-esdtest --disable-dependency-tracking \
+CONFIGURE_ARGS= --disable-dependency-tracking \
--disable-rpath --enable-mans SHELL=/bin/sh
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MESOUND}
-USE_GNOME= esound
+.if ${PORT_OPTIONS:MSOUND}
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio \
+ sndfile:${PORTSDIR}/audio/libsndfile
+CONFIGURE_ARGS+=--enable-sound \
+ --enable-sound-pulse \
+ --with-sndldr=sndfile
.else
-CONFIGURE_ARGS+=--disable-sound
+CONFIGURE_ARGS+=--disable-sound \
+ --with-sndldr=none
.endif
.if ${PORT_OPTIONS:MNLS}
diff --git a/x11-wm/e16/distinfo b/x11-wm/e16/distinfo
index c048a0e710d6..157f3c539ba2 100644
--- a/x11-wm/e16/distinfo
+++ b/x11-wm/e16/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e16-1.0.11.tar.gz) = c7bc9fed4a83d2791df2acd6aa9e710cc162f2b54312c834f41940fb60a1f13e
-SIZE (e16-1.0.11.tar.gz) = 2281672
+SHA256 (e16-1.0.11.001.tar.gz) = 1b3dbd10ca78a85740b049c2b2b61f1cedca99aa5dc9ffb088cbcbe29f6c5351
+SIZE (e16-1.0.11.001.tar.gz) = 2296210
diff --git a/x11-wm/e16/pkg-plist b/x11-wm/e16/pkg-plist
index db76f2dd0118..32f3c3c09960 100644
--- a/x11-wm/e16/pkg-plist
+++ b/x11-wm/e16/pkg-plist
@@ -381,7 +381,6 @@ share/xsessions/e16-gnome3-session.desktop
%%NLS%%share/locale/bg/LC_MESSAGES/e16.mo
%%NLS%%share/locale/bs/LC_MESSAGES/e16.mo
%%NLS%%share/locale/cs/LC_MESSAGES/e16.mo
-%%NLS%%share/locale/csb/LC_MESSAGES/e16.mo
%%NLS%%share/locale/da/LC_MESSAGES/e16.mo
%%NLS%%share/locale/de/LC_MESSAGES/e16.mo
%%NLS%%share/locale/en_US/LC_MESSAGES/e16.mo
@@ -472,8 +471,6 @@ share/xsessions/e16-gnome3-session.desktop
@dirrmtry %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/xsessions
-@dirrmtry share/locale/csb/LC_MESSAGES
-@dirrmtry share/locale/csb
@dirrmtry share/locale/en_US/LC_MESSAGES
@dirrmtry share/locale/en_US
@dirrmtry share/locale/fo/LC_MESSAGES