aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/echinus
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-09-03 11:23:26 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-09-03 11:23:26 +0000
commit18733e8b6db40b2fc3f11e15dbce677e78c18e7a (patch)
tree3c1d9efd0874ed83fcff41db85060b43de3df8b5 /x11-wm/echinus
parent5c82fa580d4b81539bbd23f4cfea10da2ecef5dd (diff)
downloadports-18733e8b6db40b2fc3f11e15dbce677e78c18e7a.tar.gz
ports-18733e8b6db40b2fc3f11e15dbce677e78c18e7a.zip
- Update to 0.4.7
- Fix build with clang, While I'am here PR: ports/159961 Submitted by: Herbert J. Skuhra <h.skuhra@gmail.com> Approved by: Henrik Friedrichsen <hrkfdn@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=281084
Diffstat (limited to 'x11-wm/echinus')
-rw-r--r--x11-wm/echinus/Makefile2
-rw-r--r--x11-wm/echinus/distinfo4
-rw-r--r--x11-wm/echinus/files/patch-config.mk29
-rw-r--r--x11-wm/echinus/files/patch-ewmh.c11
4 files changed, 32 insertions, 14 deletions
diff --git a/x11-wm/echinus/Makefile b/x11-wm/echinus/Makefile
index f1341776f633..1609290824d2 100644
--- a/x11-wm/echinus/Makefile
+++ b/x11-wm/echinus/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= echinus
-PORTVERSION= 0.4.3.2
+PORTVERSION= 0.4.7
CATEGORIES= x11-wm
MASTER_SITES= http://plhk.ru/static/echinus/
diff --git a/x11-wm/echinus/distinfo b/x11-wm/echinus/distinfo
index d92bf9f2d16b..d9215cc12cdf 100644
--- a/x11-wm/echinus/distinfo
+++ b/x11-wm/echinus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (echinus-0.4.3.2.tar.gz) = bf41fef15b1d68c91af8f3ad636156e146dd9837638acc174048f58fe9761f3e
-SIZE (echinus-0.4.3.2.tar.gz) = 30453
+SHA256 (echinus-0.4.7.tar.gz) = 174da785d6f60bf50734f106a137654c2c98c3f2aaccc47649f37777491f74c9
+SIZE (echinus-0.4.7.tar.gz) = 32576
diff --git a/x11-wm/echinus/files/patch-config.mk b/x11-wm/echinus/files/patch-config.mk
index 67de18a6720f..657a82c67ffc 100644
--- a/x11-wm/echinus/files/patch-config.mk
+++ b/x11-wm/echinus/files/patch-config.mk
@@ -1,17 +1,24 @@
-diff -Naur ./config.mk ../echinus-0.3.8/config.mk
---- ./config.mk 2009-11-07 22:00:00.000000000 +0100
-+++ ../echinus-0.3.8/config.mk 2009-11-07 22:01:52.000000000 +0100
-@@ -6,10 +6,10 @@
- # paths
- PREFIX = /usr/local
- MANPREFIX = ${PREFIX}/share/man
--CONF = /share/examples/echinus
-+CONF = ${PREFIX}/etc/echinus/
+--- ./config.mk.orig 2011-08-19 18:19:22.000000000 +0200
++++ ./config.mk 2011-09-03 13:08:44.000000000 +0200
+@@ -7,12 +7,12 @@
+ PREFIX?= /usr/local
+ BINPREFIX?= ${PREFIX}/bin
+ MANPREFIX?= ${PREFIX}/share/man
+-CONFPREFIX?= ${PREFIX}/share/examples
++CONFPREFIX?= ${PREFIX}/etc/echinus/
+ DOCPREFIX?= ${PREFIX}/share/doc
+ CONF?= ${CONFPREFIX}
--X11INC = /usr/X11R6/include
--X11LIB = /usr/X11R6/lib
+-X11INC?= /usr/X11R6/include
+-X11LIB?= /usr/X11R6/lib
+X11INC = /usr/local/include
+X11LIB = /usr/local/lib
# includes and libs
INCS = -I. -I/usr/include -I${X11INC} `pkg-config --cflags xft`
+@@ -44,4 +44,4 @@
+ #CFLAGS += -xtarget=ultra
+
+ # compiler and linker
+-#CC = cc
++CC?= cc
diff --git a/x11-wm/echinus/files/patch-ewmh.c b/x11-wm/echinus/files/patch-ewmh.c
new file mode 100644
index 000000000000..940c08ac5c75
--- /dev/null
+++ b/x11-wm/echinus/files/patch-ewmh.c
@@ -0,0 +1,11 @@
+--- ./ewmh.c.orig 2011-09-03 13:09:18.000000000 +0200
++++ ./ewmh.c 2011-09-03 13:09:46.000000000 +0200
+@@ -218,7 +218,7 @@
+ CARD32 data[2];
+
+ data[1] = None;
+- if ((state == atom[WindowStateFs])) {
++ if ((state = atom[WindowStateFs])) {
+ focus(c);
+ if (set && !c->ismax) {
+ c->wasfloating = c->isfloating;