aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/echinus
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-09-02 01:07:18 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-09-02 01:07:18 +0000
commit9d04503ce06596388f64410203fa13d514b5d44a (patch)
treec0ab62917c6ed5957e0ac8018e242c49afb18e98 /x11-wm/echinus
parent3564c262125a179de8cf80a1b772c3a77fd556c5 (diff)
downloadports-9d04503ce06596388f64410203fa13d514b5d44a.tar.gz
ports-9d04503ce06596388f64410203fa13d514b5d44a.zip
echinus is a dynamic window manager for X11 supporting managing windows in floating, tiled and maximized layouts based on dwm.
All the configuration is made via config file in Xresources format. Echinus supports a small subset of EWMH to be compatible with external panels and pagers. The goal of development is a small, fast window manager without features not strictly related to window management (menus, panels, etc.) WWW: http://rootshell.be/~polachok/code/ PR: ports/126238 Submitted by: Henrik Friedrichsen <hrkfrd@googlemail.com>
Notes
Notes: svn path=/head/; revision=219625
Diffstat (limited to 'x11-wm/echinus')
-rw-r--r--x11-wm/echinus/Makefile43
-rw-r--r--x11-wm/echinus/distinfo3
-rw-r--r--x11-wm/echinus/files/patch-Makefile11
-rw-r--r--x11-wm/echinus/files/patch-config.mk29
-rw-r--r--x11-wm/echinus/files/pkg-message.in9
-rw-r--r--x11-wm/echinus/pkg-descr9
6 files changed, 104 insertions, 0 deletions
diff --git a/x11-wm/echinus/Makefile b/x11-wm/echinus/Makefile
new file mode 100644
index 000000000000..8761d536b3db
--- /dev/null
+++ b/x11-wm/echinus/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: echinus
+# Date created: 04 August 2008
+# Whom: hrkfrd@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= echinus
+PORTVERSION= 0.3.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://rootshell.be/~polachok/code/
+
+MAINTAINER= hrkfrd@googlemail.com
+COMMENT= A dynamic window manager for X11 based on dwm
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+
+USE_XORG= x11 xft xrender
+USE_GNOME= pkgconfig
+
+MAN1= echinus.1
+MANCOMPRESSED= no
+
+FILES= echinusrc close.xbm iconify.xbm max.xbm
+
+PLIST_FILES= bin/echinus \
+ etc/echinus/close.xbm \
+ etc/echinus/iconify.xbm \
+ etc/echinus/max.xbm \
+ etc/echinus/echinusrc
+
+PLIST_DIRS= etc/echinus
+SUB_FILES= pkg-message
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${MKDIR} ${ETCDIR}
+ @${INSTALL_DATA} ${FILES:S,^,${WRKSRC}/,} ${ETCDIR}/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-wm/echinus/distinfo b/x11-wm/echinus/distinfo
new file mode 100644
index 000000000000..b8efdbab793c
--- /dev/null
+++ b/x11-wm/echinus/distinfo
@@ -0,0 +1,3 @@
+MD5 (echinus-0.3.1.tar.gz) = 515057b47796534db55826640e6d7d8c
+SHA256 (echinus-0.3.1.tar.gz) = f609a53cb81c28d7197fede748ab459b8f96a4d24479c9e28a0c5041b1af2fa3
+SIZE (echinus-0.3.1.tar.gz) = 26905
diff --git a/x11-wm/echinus/files/patch-Makefile b/x11-wm/echinus/files/patch-Makefile
new file mode 100644
index 000000000000..ec724a10a5a1
--- /dev/null
+++ b/x11-wm/echinus/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.old 2008-08-19 16:57:30.000000000 -0300
++++ Makefile 2008-08-31 17:46:50.000000000 -0300
+@@ -8,7 +8,7 @@
+ FILES = draw.c parse.c ewmh.c config.h
+ SRC = echinus.c
+ OBJ = ${SRC:.c=.o}
+-CONF = /share/examples/echinus
++CONF = /usr/local/etc/echinus/
+
+ all: options echinus ${HEADERS}
+
diff --git a/x11-wm/echinus/files/patch-config.mk b/x11-wm/echinus/files/patch-config.mk
new file mode 100644
index 000000000000..ab551ef19131
--- /dev/null
+++ b/x11-wm/echinus/files/patch-config.mk
@@ -0,0 +1,29 @@
+--- _config.mk 2008-08-04 14:08:03.000000000 +0200
++++ config.mk 2008-08-04 14:07:48.000000000 +0200
+@@ -7,16 +7,16 @@
+ PREFIX = ${HOME}
+ MANPREFIX = ${PREFIX}/share/man
+
+-X11INC = /usr/X11R6/include
+-X11LIB = /usr/X11R6/lib
++X11INC = /usr/local/include
++X11LIB = /usr/local/lib
+
+ # includes and libs
+ INCS = -I. -I/usr/include -I${X11INC} `pkg-config --cflags xft`
+ LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 `pkg-config --libs xft`
+
+ # flags
+-CFLAGS = -Os ${INCS} -DVERSION=\"${VERSION}\"
+-LDFLAGS = -s ${LIBS}
++CFLAGS += -Os ${INCS} -DVERSION=\"${VERSION}\"
++LDFLAGS += -s ${LIBS}
+ #CFLAGS = -g3 -ggdb3 -std=c99 -pedantic -Wall -O0 ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = -g3 -ggdb3 ${LIBS}
+
+@@ -26,4 +26,4 @@
+ #CFLAGS += -xtarget=ultra
+
+ # compiler and linker
+-CC = cc
++CC? = cc
diff --git a/x11-wm/echinus/files/pkg-message.in b/x11-wm/echinus/files/pkg-message.in
new file mode 100644
index 000000000000..632063986f4c
--- /dev/null
+++ b/x11-wm/echinus/files/pkg-message.in
@@ -0,0 +1,9 @@
+==============================================================================
+
+Echnis has been installed.
+
+A standard config file with its pixmaps has been installed to:
+ PREFIX/etc/echinus/
+Copy this folder to ~/.echinus/ and modify the echinusrc as you wish.
+
+==============================================================================
diff --git a/x11-wm/echinus/pkg-descr b/x11-wm/echinus/pkg-descr
new file mode 100644
index 000000000000..04b5066dbf0f
--- /dev/null
+++ b/x11-wm/echinus/pkg-descr
@@ -0,0 +1,9 @@
+echinus wm is a window manager for X11 supporting managing windows in
+floating, tiled and maximized layouts.
+All the configuration is made via config file in Xresources format.
+So you don't need to recompile echinus every time you change something.
+Echinus supports a small subset of EWMH to be compatible
+with external panels and pagers.
+It draws a border around windows and also an optional titlebar.
+
+WWW: http://rootshell.be/~polachok/code/