aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/emerald/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-09-18 17:50:54 +0000
committerSteve Wills <swills@FreeBSD.org>2018-09-18 17:50:54 +0000
commit26747a563a04af79a4fdd3d4c25f767c0500def8 (patch)
treef2100dcca000805f300cc500849b4ace30da6724 /x11-wm/emerald/Makefile
parent59dcc20566eb4359da4ee2c41118f03209304be5 (diff)
downloadports-26747a563a04af79a4fdd3d4c25f767c0500def8.tar.gz
ports-26747a563a04af79a4fdd3d4c25f767c0500def8.zip
Notes
Diffstat (limited to 'x11-wm/emerald/Makefile')
-rw-r--r--x11-wm/emerald/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/x11-wm/emerald/Makefile b/x11-wm/emerald/Makefile
index 9ba138f70529..bd7b5853251b 100644
--- a/x11-wm/emerald/Makefile
+++ b/x11-wm/emerald/Makefile
@@ -2,29 +2,40 @@
PORTNAME= emerald
PORTVERSION= 0.8.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= Emerald Window Decorator
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:x11-wm/compiz
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
RUN_DEPENDS:= ${BUILD_DEPENDS}
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-USE_GL= gl
-USES= desktop-file-utils gettext gmake libtool pathfix \
+USES= desktop-file-utils gmake libtool pathfix \
pkgconfig shared-mime-info tar:bzip2
-USE_GNOME= gtk20 intltool libwnck pango
-USE_XORG= xrender
+USE_GL= gl
+USE_GNOME= cairo gtk20 intltool libwnck pango
+USE_XORG= x11 xrender
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= NLS
+OPTIONS_DEFAULT= NLS
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime gettext-tools
+
# XXX - might want to change that
post-patch:
@${REINPLACE_CMD} 's|icons/gnome|icons/hicolor|' ${WRKSRC}/misc/Makefile.in