aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/emerald
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
commitd4f0d0048a8755106a4b0445221a19761e746984 (patch)
treec87184c5bfeaf942c827c5f706186ce9786a2588 /x11-wm/emerald
parente82affd309fc2d8e5ea19b2e003f1296920bd825 (diff)
downloadports-d4f0d0048a8755106a4b0445221a19761e746984.tar.gz
ports-d4f0d0048a8755106a4b0445221a19761e746984.zip
Notes
Diffstat (limited to 'x11-wm/emerald')
-rw-r--r--x11-wm/emerald/Makefile44
-rw-r--r--x11-wm/emerald/distinfo3
-rw-r--r--x11-wm/emerald/files/patch-themer_main.c106
-rw-r--r--x11-wm/emerald/pkg-descr8
-rw-r--r--x11-wm/emerald/pkg-plist106
5 files changed, 267 insertions, 0 deletions
diff --git a/x11-wm/emerald/Makefile b/x11-wm/emerald/Makefile
new file mode 100644
index 000000000000..0aa06b018402
--- /dev/null
+++ b/x11-wm/emerald/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: emerald
+# Date created: Oct 29 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emerald
+PORTVERSION= 0.2.1
+PORTREVISION= 1
+CATEGORIES= x11-wm
+MASTER_SITES= http://releases.beryl-project.org/${PORTVERSION}/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= flz/beryl/
+
+MAINTAINER= rnoland@2hip.net
+COMMENT= Emerald Window Decorator
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/beryl.pc:${PORTSDIR}/x11-wm/beryl-core
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+USE_GL= gl
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 libwnck pango gnomehack
+USE_XORG= xrender
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+
+MAN1= emerald.1 \
+ emerald-theme-manager.1
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --mandir="${PREFIX}/man"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
+
+# XXX - might want to change that
+post-patch:
+ @${REINPLACE_CMD} 's|icons/gnome|icons/hicolor|' ${WRKSRC}/misc/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11-wm/emerald/distinfo b/x11-wm/emerald/distinfo
new file mode 100644
index 000000000000..873bbb8f0a47
--- /dev/null
+++ b/x11-wm/emerald/distinfo
@@ -0,0 +1,3 @@
+MD5 (emerald-0.2.1.tar.bz2) = dde0e2b5cbe405961a350e6d47d2445f
+SHA256 (emerald-0.2.1.tar.bz2) = 43e4fb81fa1bcada42058c9aa8a27c6e09ed7b3cbf0ed1b65578ccb958b64cba
+SIZE (emerald-0.2.1.tar.bz2) = 502243
diff --git a/x11-wm/emerald/files/patch-themer_main.c b/x11-wm/emerald/files/patch-themer_main.c
new file mode 100644
index 000000000000..3a434eb47adc
--- /dev/null
+++ b/x11-wm/emerald/files/patch-themer_main.c
@@ -0,0 +1,106 @@
+--- themer/main.c.orig Sun Oct 29 18:57:14 2006
++++ themer/main.c Sun Oct 29 23:09:37 2006
+@@ -7,6 +7,103 @@
+ #include <emerald.h>
+ #include <engine.h>
+
++/* states: S_N: normal, S_I: comparing integral part, S_F: comparing
++ fractional parts, S_Z: idem but with leading Zeroes only */
++#define S_N 0x0
++#define S_I 0x4
++#define S_F 0x8
++#define S_Z 0xC
++
++/* result_type: CMP: return diff; LEN: compare using len_diff/diff */
++#define CMP 2
++#define LEN 3
++
++
++/* ISDIGIT differs from isdigit, as follows:
++ - Its arg may be any int or unsigned int; it need not be an unsigned char.
++ - It's guaranteed to evaluate its argument exactly once.
++ - It's typically faster.
++ Posix 1003.2-1992 section 2.5.2.1 page 50 lines 1556-1558 says that
++ only '0' through '9' are digits. Prefer ISDIGIT to isdigit unless
++ it's important to use the locale's definition of `digit' even when the
++ host does not conform to Posix. */
++#define ISDIGIT(c) ((unsigned) (c) - '0' <= 9)
++
++/* Compare S1 and S2 as strings holding indices/version numbers,
++ returning less than, equal to or greater than zero if S1 is less than,
++ equal to or greater than S2 (for more info, see the texinfo doc).
++*/
++
++int
++strverscmp (const char *s1, const char *s2)
++{
++ const unsigned char *p1 = (const unsigned char *) s1;
++ const unsigned char *p2 = (const unsigned char *) s2;
++ unsigned char c1, c2;
++ int state;
++ int diff;
++
++ /* Symbol(s) 0 [1-9] others (padding)
++ Transition (10) 0 (01) d (00) x (11) - */
++ static const unsigned int next_state[] =
++ {
++ /* state x d 0 - */
++ /* S_N */ S_N, S_I, S_Z, S_N,
++ /* S_I */ S_N, S_I, S_I, S_I,
++ /* S_F */ S_N, S_F, S_F, S_F,
++ /* S_Z */ S_N, S_F, S_Z, S_Z
++ };
++
++ static const int result_type[] =
++ {
++ /* state x/x x/d x/0 x/- d/x d/d d/0 d/-
++ 0/x 0/d 0/0 0/- -/x -/d -/0 -/- */
++
++ /* S_N */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
++ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
++ /* S_I */ CMP, -1, -1, CMP, 1, LEN, LEN, CMP,
++ 1, LEN, LEN, CMP, CMP, CMP, CMP, CMP,
++ /* S_F */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
++ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
++ /* S_Z */ CMP, 1, 1, CMP, -1, CMP, CMP, CMP,
++ -1, CMP, CMP, CMP
++ };
++
++ if (p1 == p2)
++ return 0;
++
++ c1 = *p1++;
++ c2 = *p2++;
++ /* Hint: '0' is a digit too. */
++ state = S_N | ((c1 == '0') + (ISDIGIT (c1) != 0));
++
++ while ((diff = c1 - c2) == 0 && c1 != '\0')
++ {
++ state = next_state[state];
++ c1 = *p1++;
++ c2 = *p2++;
++ state |= (c1 == '0') + (ISDIGIT (c1) != 0);
++ }
++
++ state = result_type[state << 2 | ((c2 == '0') + (ISDIGIT (c2) != 0))];
++
++ switch (state)
++ {
++ case CMP:
++ return diff;
++
++ case LEN:
++ while (ISDIGIT (*p1++))
++ if (!ISDIGIT (*p2++))
++ return 1;
++
++ return ISDIGIT (*p2) ? -1 : diff;
++
++ default:
++ return state;
++ }
++}
++
+ #define LAST_COMPAT_VER "0.1.0"
+
+ typedef struct _FetcherInfo
diff --git a/x11-wm/emerald/pkg-descr b/x11-wm/emerald/pkg-descr
new file mode 100644
index 000000000000..c9d35bf6ae83
--- /dev/null
+++ b/x11-wm/emerald/pkg-descr
@@ -0,0 +1,8 @@
+Emerald is a window decorator for beryl. It comes with a
+themes editor called emerald-theme-manager and the decorator.
+You need beryl to use emerald.
+
+WWW: http://www.beryl-project.org/
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/x11-wm/emerald/pkg-plist b/x11-wm/emerald/pkg-plist
new file mode 100644
index 000000000000..37cc50ec208a
--- /dev/null
+++ b/x11-wm/emerald/pkg-plist
@@ -0,0 +1,106 @@
+bin/emerald
+bin/emerald-theme-manager
+include/emerald/emerald.h
+include/emerald/engine.h
+include/emerald/libengine.h
+include/emerald/titlebar.h
+lib/libemeraldengine.a
+lib/libemeraldengine.la
+lib/libemeraldengine.so
+lib/libemeraldengine.so.0
+lib/emerald/engines/liblegacy.so
+lib/emerald/engines/liblegacy.la
+lib/emerald/engines/liblegacy.a
+lib/emerald/engines/libvrunner.so
+lib/emerald/engines/libvrunner.la
+lib/emerald/engines/libvrunner.a
+lib/emerald/engines/libtruglass.so
+lib/emerald/engines/libtruglass.la
+lib/emerald/engines/libtruglass.a
+lib/emerald/engines/liboxygen.so
+lib/emerald/engines/liboxygen.la
+lib/emerald/engines/liboxygen.a
+lib/emerald/engines/libpixmap.so
+lib/emerald/engines/libpixmap.la
+lib/emerald/engines/libpixmap.a
+lib/emerald/engines/libzootreeves.so
+lib/emerald/engines/libzootreeves.la
+lib/emerald/engines/libzootreeves.a
+libdata/pkgconfig/emeraldengine.pc
+share/applications/emerald-theme-manager.desktop
+share/icons/hicolor/48x48/mimetypes/application-x-emerald-theme.png
+share/mime/packages/emerald.xml
+share/mime-info/emerald.mime
+%%DATADIR%%/settings.ini
+%%DATADIR%%/theme/buttons.above.png
+%%DATADIR%%/theme/buttons.close.png
+%%DATADIR%%/theme/buttons.glow.png
+%%DATADIR%%/theme/buttons.help.png
+%%DATADIR%%/theme/buttons.inactive_glow.png
+%%DATADIR%%/theme/buttons.max.png
+%%DATADIR%%/theme/buttons.menu.png
+%%DATADIR%%/theme/buttons.min.png
+%%DATADIR%%/theme/buttons.restore.png
+%%DATADIR%%/theme/buttons.shade.png
+%%DATADIR%%/theme/buttons.sticky.png
+%%DATADIR%%/theme/buttons.unabove.png
+%%DATADIR%%/theme/buttons.unshade.png
+%%DATADIR%%/theme/buttons.unsticky.png
+%%DATADIR%%/theme/theme.screenshot.png
+%%DATADIR%%/theme/theme.ini
+share/locale/ca/LC_MESSAGES/emerald.mo
+share/locale/cs/LC_MESSAGES/emerald.mo
+share/locale/de_DE/LC_MESSAGES/emerald.mo
+share/locale/en_GB/LC_MESSAGES/emerald.mo
+share/locale/es_AR/LC_MESSAGES/emerald.mo
+share/locale/es_ES/LC_MESSAGES/emerald.mo
+share/locale/fr_FR/LC_MESSAGES/emerald.mo
+share/locale/gu_IN/LC_MESSAGES/emerald.mo
+share/locale/hu_HU/LC_MESSAGES/emerald.mo
+share/locale/it/LC_MESSAGES/emerald.mo
+share/locale/ja/LC_MESSAGES/emerald.mo
+share/locale/ko_KR/LC_MESSAGES/emerald.mo
+share/locale/nb_NO/LC_MESSAGES/emerald.mo
+share/locale/nl/LC_MESSAGES/emerald.mo
+share/locale/pt_BR/LC_MESSAGES/emerald.mo
+share/locale/pt_PT/LC_MESSAGES/emerald.mo
+share/locale/sv_FI/LC_MESSAGES/emerald.mo
+share/locale/sv_SE/LC_MESSAGES/emerald.mo
+share/locale/tr_TR/LC_MESSAGES/emerald.mo
+share/locale/zh_CN/LC_MESSAGES/emerald.mo
+share/locale/zh_HK/LC_MESSAGES/emerald.mo
+share/locale/zh_TW/LC_MESSAGES/emerald.mo
+share/pixmaps/emerald-theme-manager-icon.png
+@dirrmtry share/mime-info
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/tr_TR/LC_MESSAGES
+@dirrmtry share/locale/tr_TR
+@dirrmtry share/locale/sv_SE/LC_MESSAGES
+@dirrmtry share/locale/sv_SE
+@dirrmtry share/locale/sv_FI/LC_MESSAGES
+@dirrmtry share/locale/sv_FI
+@dirrmtry share/locale/nb_NO/LC_MESSAGES
+@dirrmtry share/locale/nb_NO
+@dirrmtry share/locale/ko_KR/LC_MESSAGES
+@dirrmtry share/locale/ko_KR
+@dirrmtry share/locale/ja_JP/LC_MESSAGES
+@dirrmtry share/locale/ja_JP
+@dirrmtry share/locale/it_IT/LC_MESSAGES
+@dirrmtry share/locale/it_IT
+@dirrmtry share/locale/hu_HU/LC_MESSAGES
+@dirrmtry share/locale/hu_HU
+@dirrmtry share/locale/gu_IN/LC_MESSAGES
+@dirrmtry share/locale/gu_IN
+@dirrmtry share/locale/es_AR/LC_MESSAGES
+@dirrmtry share/locale/es_AR
+@dirrmtry share/locale/de_DE/LC_MESSAGES
+@dirrmtry share/locale/de_DE
+@dirrmtry share/locale/ca_ES/LC_MESSAGES
+@dirrmtry share/locale/ca_ES
+@dirrmtry %%DATADIR%%/theme
+@dirrmtry %%DATADIR%%
+@dirrmtry share/applications
+@dirrmtry lib/emerald/engines
+@dirrmtry lib/emerald
+@dirrmtry include/emerald