aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/epplets/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-06-03 12:03:39 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-06-03 12:03:39 +0000
commitd48c67b1417bae2355a988e7093a6e1468512932 (patch)
tree7b391713d3435cf53ca4198401c8f26c4bf1ee48 /x11-wm/epplets/Makefile
parenta173d1a98b0cd89b459bb59f0bbfe867d8beb5a1 (diff)
downloadports-d48c67b1417bae2355a988e7093a6e1468512932.tar.gz
ports-d48c67b1417bae2355a988e7093a6e1468512932.zip
Notes
Diffstat (limited to 'x11-wm/epplets/Makefile')
-rw-r--r--x11-wm/epplets/Makefile37
1 files changed, 8 insertions, 29 deletions
diff --git a/x11-wm/epplets/Makefile b/x11-wm/epplets/Makefile
index c4b1e49ab96b..f21d2ba76daa 100644
--- a/x11-wm/epplets/Makefile
+++ b/x11-wm/epplets/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= epplets
-PORTVERSION= 0.7
-PORTREVISION= 5
+PORTVERSION= 0.9
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= enlightenment
@@ -16,8 +15,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A collection of Enlightenment dock applications
BUILD_DEPENDS= e16:${PORTSDIR}/x11-wm/enlightenment
-LIB_DEPENDS= cdaudio.1:${PORTSDIR}/audio/libcdaudio \
- epplet.1:${PORTSDIR}/x11-wm/libepplet
+LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2 \
+ cdaudio.1:${PORTSDIR}/audio/libcdaudio
RUN_DEPENDS= import:${PORTSDIR}/graphics/ImageMagick \
e16:${PORTSDIR}/x11-wm/enlightenment
@@ -25,31 +24,11 @@ USE_X_PREFIX= yes
USE_GNOME= esound lthack
USE_GL= yes
USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-CONFIGURE_ENV= EROOT="${X11BASE}/share/enlightenment" \
- EBIN="${X11BASE}/bin" \
- CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}"
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-fsstd
-MAKE_ARGS= SUBDIRS="epplets debian"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "i386"
-APM_PROGS= E-Power.epplet
-PLIST_SUB+= APM_PROGS=""
-.else
-APM_PROGS= # none
-PLIST_SUB+= APM_PROGS="@comment "
-.endif
-
-post-extract:
- @${RM} -f ${WRKSRC}/api/epplet.h*
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's| ../api/epplet.h||g ; \
- s|@APM_PROGS@|${APM_PROGS}|g'
- @${REINPLACE_CMD} -e 's| api/epplet.h||g' ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>