aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/epplets
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-10-10 13:14:27 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-10-10 13:14:27 +0000
commit39b9a7d50a99011cb297b2dafe67aad5273b90ee (patch)
tree6edfcc03ac63368f24e5d6a971b9602b5ac58a3d /x11-wm/epplets
parent3fe25b5e4e0b59fad4656aecaec9ee9815704ab7 (diff)
downloadports-39b9a7d50a99011cb297b2dafe67aad5273b90ee.tar.gz
ports-39b9a7d50a99011cb297b2dafe67aad5273b90ee.zip
- Update to 0.14
Notes
Notes: svn path=/head/; revision=305659
Diffstat (limited to 'x11-wm/epplets')
-rw-r--r--x11-wm/epplets/Makefile9
-rw-r--r--x11-wm/epplets/distinfo4
-rw-r--r--x11-wm/epplets/files/patch-epplets_E-Power.c86
-rw-r--r--x11-wm/epplets/files/patch-epplets_Makefile48
-rw-r--r--x11-wm/epplets/files/patch-epplets_net.c18
-rw-r--r--x11-wm/epplets/pkg-plist1
6 files changed, 81 insertions, 85 deletions
diff --git a/x11-wm/epplets/Makefile b/x11-wm/epplets/Makefile
index bf33c00b1f4c..2757ab518110 100644
--- a/x11-wm/epplets/Makefile
+++ b/x11-wm/epplets/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: epplets
-# Date created: 18 October 1999
-# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
-#
+# Created by: Yukihiro Nakai <nakai@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= epplets
-PORTVERSION= 0.13
-PORTREVISION= 3
+PORTVERSION= 0.14
CATEGORIES= x11-wm
MASTER_SITES= SF/enlightenment/${PORTNAME}/${PORTVERSION}
diff --git a/x11-wm/epplets/distinfo b/x11-wm/epplets/distinfo
index a575392625f2..bdc05fe193f7 100644
--- a/x11-wm/epplets/distinfo
+++ b/x11-wm/epplets/distinfo
@@ -1,2 +1,2 @@
-SHA256 (epplets-0.13.tar.gz) = 605dfec7ce380eefa42dbd36bcec9b41e7754d4cc5d4f7365761743df5640021
-SIZE (epplets-0.13.tar.gz) = 953034
+SHA256 (epplets-0.14.tar.gz) = e3d1520344532f602a0a7807cda363d6435655aed302967a8580f102e3468132
+SIZE (epplets-0.14.tar.gz) = 971885
diff --git a/x11-wm/epplets/files/patch-epplets_E-Power.c b/x11-wm/epplets/files/patch-epplets_E-Power.c
index 62b4e1ef20d1..6662378ddcab 100644
--- a/x11-wm/epplets/files/patch-epplets_E-Power.c
+++ b/x11-wm/epplets/files/patch-epplets_E-Power.c
@@ -1,5 +1,5 @@
---- epplets/E-Power.c.orig 2006-04-16 00:32:43.000000000 +0200
-+++ epplets/E-Power.c 2008-03-10 17:12:55.000000000 +0100
+--- epplets/E-Power.c.orig 2011-11-26 11:38:40.000000000 +0100
++++ epplets/E-Power.c 2012-10-10 15:01:17.000000000 +0200
@@ -1,9 +1,22 @@
+/*-
+ * Copyright 2008, Pietro Cerutti <gahr@FreeBSD.org> (FreeBSD adaptation)
@@ -23,7 +23,7 @@
/* Modified by Attila ZIMLER <hijaszu@hlfslinux.hu>, 2003/11/16
Added ACPI power management support.
*/
-@@ -11,6 +24,19 @@
+@@ -11,6 +24,20 @@
/* Length of explain strings in /proc/acpi/battery/BAT0 data files */
#define DATA_EXPLAIN_STR_LEN 25
@@ -31,6 +31,7 @@
+#define MODE_NONE 0x0
+#define MODE_APM 0x1
+#define MODE_ACPI 0x2
++#define MODE_SYS 0x3
+static unsigned mode = MODE_NONE;
+
+#ifdef __FreeBSD__
@@ -43,59 +44,68 @@
int prev_bat_val = 110;
int bat_val = 0;
int time_val = 0;
-@@ -31,17 +57,39 @@
+@@ -33,14 +60,37 @@
static void
cb_timer(void *data)
{
-- struct stat st;
-
+#ifdef linux
-+ struct stat st;
+ struct stat st;
+
if ((stat("/proc/apm", &st) > -1) && S_ISREG(st.st_mode))
- cb_timer_apm(data);
-+ mode = MODE_APM;
- else if ((stat("/proc/acpi", &st) > -1) && S_ISDIR(st.st_mode))
-+ mode = MODE_ACPI;
-+#elif defined(__FreeBSD__)
++ mode = MODE_APM;
+ else if ((stat("/proc/acpi/battery", &st) > -1) && S_ISDIR(st.st_mode))
+- cb_timer_acpi(data);
++ mode = MODE_ACPI;
+ else if ((stat("/sys/class/power_supply", &st) > -1) && S_ISDIR(st.st_mode))
+- cb_timer_sys(data);
++ mode = MODE_SYS;
++ else
++ mode = MODE_NONE;
++#elif defined (__FreeBSD__)
+ /*
-+ * Try ACPI first, if does not work, revert to APM
++ * Try ACPI first, if it doesn't work, revert to APM
+ */
-+ if(acpi_fd != -1 || ((acpi_fd = open(ACPI_DEV, O_RDONLY)) != -1))
-+ mode = MODE_ACPI;
-+ else if(apm_fd != -1 || ((apm_fd = open(APM_DEV, O_RDONLY)) != -1))
-+ mode = MODE_APM;
++ if (acpi_fd != 1 || ((acpi_fd = open(ACPI_DEV, O_RDONLY)) != -1))
++ mode = MODE_ACPI;
++ else if (apm_fd != 1 || (apm_fd = open(APM_DEV, O_RDONLY)) != -1)
++ mode = MODE_APM;
++ else
++ mode = MODE_NONE;
+#else
+ mode = MODE_NONE;
+#endif
+
-+
-+ if(mode & MODE_APM)
-+ cb_timer_apm(data);
-+ else if(mode & MODE_ACPI)
- cb_timer_acpi(data);
++ if (mode & MODE_APM)
++ cb_timer_apm(data);
++ else if (mode & MODE_ACPI)
++ cb_timer_acpi(data);
++ else if (mode & MODE_SYS)
++ tb_timer_sys(data);
}
static void
- cb_timer_acpi(void *data)
- {
-+ char current_status[256];
-+ int bat_val = 0;
-+
-+#ifdef linux
- /* We don't have any data from the remaining percentage, and time directly,
- * so we have to calculate and measure them.
- * (Measure the time and calculate the percentage.)
-@@ -57,9 +105,6 @@
+@@ -61,9 +111,8 @@
int bat_level = 0;
int bat_drain = 1;
- int bat_val = 0;
-
-- char current_status[256];
+ char current_status[256];
++
char *line = 0;
size_t lsize = 0;
int discharging = 0;
-@@ -203,27 +248,74 @@
+@@ -77,6 +126,8 @@
+
+ int hours, minutes;
+
++#ifdef linux
++
+ /* Read some information on first run. */
+ dirp = opendir("/proc/acpi/battery");
+ if (dirp)
+@@ -207,27 +258,74 @@
else
snprintf(current_status, sizeof(current_status), "Full");
@@ -176,7 +186,7 @@
int apm_flags, ac_stat, bat_stat, bat_flags;
int i, hours, minutes, up, up2;
char *s_ptr;
-@@ -296,14 +388,57 @@
+@@ -300,14 +398,57 @@
else
s_ptr += sprintf(s_ptr, "%i:%02i", hours, minutes);
}
@@ -187,7 +197,7 @@
+ int c;
+ if(ioctl(apm_fd, APMIO_GETINFO, &apm) == -1)
+ return;
-
++
+ /*
+ * Get percent
+ */
@@ -221,7 +231,7 @@
+ snprintf(&s[c], sizeof(s) - c, "%d:%2d",
+ apm.ai_batt_time / 3600, apm.ai_batt_time / 60 % 60);
+#endif
-+
+
+ /* Display current status */
+ Epplet_change_label(label, s);
sprintf(s, "E-Power-Bat-%i.png", ((bat_val + 5) / 10) * 10);
@@ -237,7 +247,7 @@
data = NULL;
}
-@@ -351,7 +486,14 @@
+@@ -530,7 +671,14 @@
static void
cb_suspend(void *data)
{
@@ -252,7 +262,7 @@
return;
data = NULL;
}
-@@ -359,7 +501,14 @@
+@@ -538,7 +686,14 @@
static void
cb_sleep(void *data)
{
diff --git a/x11-wm/epplets/files/patch-epplets_Makefile b/x11-wm/epplets/files/patch-epplets_Makefile
index 9c652dbf2e90..309f0a7fcbec 100644
--- a/x11-wm/epplets/files/patch-epplets_Makefile
+++ b/x11-wm/epplets/files/patch-epplets_Makefile
@@ -1,33 +1,27 @@
---- epplets/Makefile.in.orig 2012-06-11 09:51:10.000000000 +0200
-+++ epplets/Makefile.in 2012-06-11 09:51:31.000000000 +0200
-@@ -554,11 +554,11 @@
- E_Biff_epplet_LDFLAGS = -rpath $(libdir)
- E_MemWatch_epplet_SOURCES = E-MemWatch.c
- E_MemWatch_epplet_DEPENDENCIES = $(top_builddir)/api/libepplet.la
--E_MemWatch_epplet_LDFLAGS = -rpath $(libdir)
-+E_MemWatch_epplet_LDFLAGS = -rpath $(libdir) -lkvm
- E_MemWatch_epplet_LDADD = $(LDADD) $(GTLIBS)
- E_Disk_epplet_SOURCES = E-Disk.c
- E_Disk_epplet_DEPENDENCIES = $(top_builddir)/api/libepplet.la
--E_Disk_epplet_LDFLAGS = -rpath $(libdir)
-+E_Disk_epplet_LDFLAGS = -rpath $(libdir) -ldevstat
- E_Sys_epplet_SOURCES = E-Sys.c
- E_Sys_epplet_DEPENDENCIES = $(top_builddir)/api/libepplet.la
- E_Sys_epplet_LDFLAGS = -rpath $(libdir)
---- epplets/Makefile.am.orig 2012-06-11 09:51:16.000000000 +0200
-+++ epplets/Makefile.am 2012-06-11 09:51:44.000000000 +0200
-@@ -122,12 +122,12 @@
+--- epplets/Makefile.am.orig 2012-10-10 14:52:30.000000000 +0200
++++ epplets/Makefile.am 2012-10-10 14:53:32.000000000 +0200
+@@ -79,9 +79,10 @@
+ E_Biff_epplet_LDADD = $(LDADD) -lX11
E_MemWatch_epplet_SOURCES = E-MemWatch.c
- E_MemWatch_epplet_DEPENDENCIES = $(top_builddir)/api/libepplet.la
--E_MemWatch_epplet_LDFLAGS = -rpath $(libdir)
-+E_MemWatch_epplet_LDFLAGS = -rpath $(libdir) -lkvm
- E_MemWatch_epplet_LDADD = $(LDADD) $(GTLIBS)
+-E_MemWatch_epplet_LDADD = $(LDADD) $(GTLIBS)
++E_MemWatch_epplet_LDADD = $(LDADD) $(GTLIBS) -lkvm
E_Disk_epplet_SOURCES = E-Disk.c
- E_Disk_epplet_DEPENDENCIES = $(top_builddir)/api/libepplet.la
--E_Disk_epplet_LDFLAGS = -rpath $(libdir)
-+E_Disk_epplet_LDFLAGS = -rpath $(libdir) -ldevstat
++E_Disk_epplet_LDADD = $(LDADD) -ldevstat
E_Sys_epplet_SOURCES = E-Sys.c
- E_Sys_epplet_DEPENDENCIES = $(top_builddir)/api/libepplet.la
+ E_Sys_epplet_LDADD = $(LDADD) $(GTLIBS)
+--- epplets/Makefile.in.orig 2012-10-10 15:02:11.000000000 +0200
++++ epplets/Makefile.in 2012-10-10 15:03:03.000000000 +0200
+@@ -479,8 +479,9 @@
+ E_Biff_epplet_SOURCES = E-Biff.c mbox.c
+ E_Biff_epplet_LDADD = $(LDADD) -lX11
+ E_MemWatch_epplet_SOURCES = E-MemWatch.c
+-E_MemWatch_epplet_LDADD = $(LDADD) $(GTLIBS)
++E_MemWatch_epplet_LDADD = $(LDADD) $(GTLIBS) -lkvm
+ E_Disk_epplet_SOURCES = E-Disk.c
++E_Disk_epplet_LDADD = $(LDADD) -ldevstat
+ E_Sys_epplet_SOURCES = E-Sys.c
+ E_Sys_epplet_LDADD = $(LDADD) $(GTLIBS)
+ E_Slides_epplet_SOURCES = E-Slides.c
diff --git a/x11-wm/epplets/files/patch-epplets_net.c b/x11-wm/epplets/files/patch-epplets_net.c
index 7ffb4a32a89c..f964e7714ab3 100644
--- a/x11-wm/epplets/files/patch-epplets_net.c
+++ b/x11-wm/epplets/files/patch-epplets_net.c
@@ -1,5 +1,5 @@
---- epplets/net.c.orig 2006-04-16 00:32:43.000000000 +0200
-+++ epplets/net.c 2008-03-10 21:26:47.000000000 +0100
+--- epplets/net.c.orig 2012-09-30 11:38:35.000000000 +0200
++++ epplets/net.c 2012-10-10 14:56:21.000000000 +0200
@@ -1,5 +1,6 @@
/*
* Copyright (C) 1999-2000, Michael Jennings
@@ -9,7 +9,7 @@
* of this software and associated documentation files (the "Software"), to
@@ -38,6 +39,14 @@
#ifdef linux
- # include <linux/version.h>
+ #include <linux/version.h>
#endif
+#ifdef __FreeBSD__
+# include <sys/types.h>
@@ -71,7 +71,7 @@
#elif defined(__sun__)
return ((char **)NULL);
#else
-@@ -107,8 +158,11 @@
+@@ -107,6 +158,10 @@
FILE *fp;
char buff[256], *colon =
NULL, dev[64], in_str[64], out_str[64];
@@ -80,11 +80,9 @@
+ int mib[6], ifno_mib[5], row, nof_ifaces;
+ size_t len;
#endif
--
- if (device == NULL)
- {
- return (EFAULT);
-@@ -173,6 +227,43 @@
+
+ if (!device)
+@@ -173,6 +228,43 @@
}
fclose(fp);
return ((match) ? (0) : (ENODEV));
@@ -127,4 +125,4 @@
+
#else
/* Unsupported platform. */
- if (in_bytes != NULL)
+ if (in_bytes)
diff --git a/x11-wm/epplets/pkg-plist b/x11-wm/epplets/pkg-plist
index 22f1d9ce0903..6d20f32390e8 100644
--- a/x11-wm/epplets/pkg-plist
+++ b/x11-wm/epplets/pkg-plist
@@ -204,7 +204,6 @@ share/e16/epplet_data/Emix/Emix.AUTHORS
share/e16/epplet_data/Emix/Emix.COPYING
share/e16/epplet_data/Emix/Emix.README
share/e16/epplet_data/Emix/Emix.TODO
-@dirrmtry share/e16/epplet_icons
@dirrm share/e16/epplet_data/Emix/ABOUT
@dirrm share/e16/epplet_data/Emix
@dirrm share/e16/epplet_data/E-Wireless/ABOUT