aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fbcmd
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-20 03:32:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-20 03:32:46 +0000
commit7ae0f8f5402f68583bbb17b5797510aeb343f8f8 (patch)
treed8024a4bbe4b5da4ed1ac51864bece37ebf99c5b /x11-wm/fbcmd
parent6a6ceaff1027c9b5a795bb476afe01c15cbacf9e (diff)
downloadports-7ae0f8f5402f68583bbb17b5797510aeb343f8f8.tar.gz
ports-7ae0f8f5402f68583bbb17b5797510aeb343f8f8.zip
Notes
Diffstat (limited to 'x11-wm/fbcmd')
-rw-r--r--x11-wm/fbcmd/Makefile32
-rw-r--r--x11-wm/fbcmd/distinfo2
-rw-r--r--x11-wm/fbcmd/pkg-descr4
3 files changed, 38 insertions, 0 deletions
diff --git a/x11-wm/fbcmd/Makefile b/x11-wm/fbcmd/Makefile
new file mode 100644
index 000000000000..dacc96805f9d
--- /dev/null
+++ b/x11-wm/fbcmd/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: fbcmd
+# Date created: 2004-09-24
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fbcmd
+PORTVERSION= 0.5
+CATEGORIES= x11-wm
+MASTER_SITES= http://darkshed.dyndns.org/~mathias/files/c_cpp/fbcmd/
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= A commandline utility for controlling fluxbox
+
+RUN_DEPENDS= fluxbox:${PORTSDIR}/x11-wm/fluxbox-devel
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+ALL_TARGET= first
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+PLIST_FILES= bin/fbcmd
+
+post-extract:
+ @${REINPLACE_CMD} -e "s|/usr/X11R6|${X11BASE}|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fbcmd ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11-wm/fbcmd/distinfo b/x11-wm/fbcmd/distinfo
new file mode 100644
index 000000000000..edb3cb2749a7
--- /dev/null
+++ b/x11-wm/fbcmd/distinfo
@@ -0,0 +1,2 @@
+MD5 (fbcmd-0.5.tar.bz2) = e2678ab8364b9ea59a7fb2710871d574
+SIZE (fbcmd-0.5.tar.bz2) = 7570
diff --git a/x11-wm/fbcmd/pkg-descr b/x11-wm/fbcmd/pkg-descr
new file mode 100644
index 000000000000..fd749f9c76d3
--- /dev/null
+++ b/x11-wm/fbcmd/pkg-descr
@@ -0,0 +1,4 @@
+fbcmd provides some functions to the 'core' of fluxbox
+from the commandline.
+
+WWW: http://darkshed.dyndns.org/~mathias/files/c_cpp/fbcmd/