aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fluxbox
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2010-07-25 08:12:41 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2010-07-25 08:12:41 +0000
commit722600ffda162dcca22ed24cdd3dbdadcf03b88a (patch)
tree0eeebbe85b8699d44dca60f3571f6d23098aee67 /x11-wm/fluxbox
parent77882f7bcbf8dc8017dc2fe8fbb41abac53157cb (diff)
downloadports-722600ffda162dcca22ed24cdd3dbdadcf03b88a.tar.gz
ports-722600ffda162dcca22ed24cdd3dbdadcf03b88a.zip
- Add OPTIONS
PR: ports/148578 Submitted by: David DEMELIER <demelier.david AT gmail.com>
Notes
Notes: svn path=/head/; revision=258217
Diffstat (limited to 'x11-wm/fluxbox')
-rw-r--r--x11-wm/fluxbox/Makefile52
1 files changed, 14 insertions, 38 deletions
diff --git a/x11-wm/fluxbox/Makefile b/x11-wm/fluxbox/Makefile
index 26a8e9f3a143..f381964a1324 100644
--- a/x11-wm/fluxbox/Makefile
+++ b/x11-wm/fluxbox/Makefile
@@ -30,6 +30,20 @@ MAN1= fbrun.1 fbsetbg.1 fbsetroot.1 fluxbox.1 fluxstyle.1 \
MAN5= fluxbox-keys.5
DOCSVERSION= 20060629
+OPTIONS= DOCHTML "Install html documentation" off \
+ DOCPDF "Install pdf documentation" off \
+ DEBUG "Enable debugging support" off \
+ GNOME "Enable GNOME support" off \
+ IMLIB2 "Enable imlib2 support" off \
+ XINERAMA "Enable xinerama support" off \
+ XRENDER "Enable xrender support" on \
+ NLS "Native language support" on \
+ SLIT "Enable slit feature" on \
+ REMEMBER "Enable remember feature" on \
+ TOOLBAR "Enable toolbar feature" on
+
+.include <bsd.port.options.mk>
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -113,44 +127,6 @@ CONFIGURE_ARGS+= --enable-gnome
CONFIGURE_ARGS+= --disable-gnome
.endif
-pre-everything::
- @${ECHO_CMD} ""
- @${ECHO_CMD} "Definable build options"
- @${ECHO_CMD} "-----------------------"
-.if !defined(WITH_DEBUG)
- @${ECHO_CMD} "WITH_DEBUG=yes Build with debugging symbols"
-.endif
-.if !defined(WITH_DOCHTML)
- @${ECHO_CMD} "WITH_DOCHTML=yes Install the HTML documentation"
-.endif
-.if !defined(WITH_DOCPDF)
- @${ECHO_CMD} "WITH_DOCPDF=yes Install the PDF documentation"
-.endif
-.if !defined(WITH_GNOME)
- @${ECHO_CMD} "WITH_GNOME=yes Enable GNOME support"
-.endif
-.if !defined(WITH_IMLIB2)
- @${ECHO_CMD} "WITH_IMLIB2=yes Enable Imlib2 (pixmap themes) support"
-.endif
-.if !defined(WITH_XINERAMA)
- @${ECHO_CMD} "WITH_XINERAMA=yes Enable Xinerama support"
-.endif
-.if !defined(WITHOUT_NLS)
- @${ECHO_CMD} "WITHOUT_NLS=yes Disable NLS support"
-.endif
-.if !defined(WITHOUT_REMEMBER)
- @${ECHO_CMD} "WITHOUT_REMEMBER=yes Disable remembering attributes support"
-.endif
-.if !defined(WITHOUT_SLIT)
- @${ECHO_CMD} "WITHOUT_SLIT=yes Disable slit"
-.endif
-.if !defined(WITHOUT_TOOLBAR)
- @${ECHO_CMD} "WITHOUT_TOOLBAR=yes Disable toolbar"
-.endif
-.if !defined(WITHOUT_XRENDER)
- @${ECHO_CMD} "WITHOUT_XRENDER=yes Disable Xrender (transparent) support"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/util/fluxbox-generate_menu.in