aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fvwm2
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-03-29 17:34:48 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-03-29 17:34:48 +0000
commit4d762c2da0f9ebd29c56f6d862f2c554ea412011 (patch)
tree87b41155c1632d36116dd2a52689324d0f408fc4 /x11-wm/fvwm2
parent2a58169b19854c36ac6d019a7c3954879ded21d5 (diff)
downloadports-4d762c2da0f9ebd29c56f6d862f2c554ea412011.tar.gz
ports-4d762c2da0f9ebd29c56f6d862f2c554ea412011.zip
- Bump port revision after the latest libiconv commit because
locale_charset() is used when the ICONV option is enabled. [1] - Remove X_CFLAGS from CONFIGURE_ENV. Not needed. - Remove --mandir=${MANPREFIX}/man from CONFIGURE_ARGS. Redundant. - Patch configure directly instead of configure.ac+autoconf. - Prevent rebuilding manpages with --disable-mandoc. - USES=tar:bzip2. - Missing dependencies: USES=perl5, USE_XORG=xcursor xinerama xrender sm. - Restore default options from before OPTIONSng conversion. - Use OPTIONS_SUB=yes. - Staging. - Specify --without-iconv-library when empty(ICONV_LIB) to force libc iconv. - New LIB_DEPENDS syntax. - Remove remnants of OPTIONSng conversion: WITHOUT_GTK and WITHOUT_GNOME. - Use --disable-gtk instead of --disable-gtktest. Reported by: kib [1]
Notes
Notes: svn path=/head/; revision=349573
Diffstat (limited to 'x11-wm/fvwm2')
-rw-r--r--x11-wm/fvwm2/Makefile96
-rw-r--r--x11-wm/fvwm2/files/patch-bin::Makefile.in12
-rw-r--r--x11-wm/fvwm2/files/patch-configure10
-rw-r--r--x11-wm/fvwm2/files/patch-configure.ac11
-rw-r--r--x11-wm/fvwm2/files/patch-libs-Ficonv.c11
-rw-r--r--x11-wm/fvwm2/pkg-plist48
6 files changed, 102 insertions, 86 deletions
diff --git a/x11-wm/fvwm2/Makefile b/x11-wm/fvwm2/Makefile
index e3b42a002a8f..9737743d2fbd 100644
--- a/x11-wm/fvwm2/Makefile
+++ b/x11-wm/fvwm2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fvwm
PORTVERSION= 2.6.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= ftp://ftp.fvwm.org/pub/fvwm/version-2/ \
http://www.fvwm.org/generated/icon_download/
@@ -20,23 +20,22 @@ CONFLICTS?= fvwm-1.* fvwm-2.[457].*
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= X_CFLAGS=-I${LOCALBASE}/include
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
-USE_AUTOTOOLS= autoconf
-USES= gmake pkgconfig
-USE_XORG= xpm xft
-USE_BZIP2= yes
-WANT_GNOME= yes
+CONFIGURE_ARGS= --disable-mandoc --without-gnome
+USES= gmake perl5 pkgconfig tar:bzip2
+USE_XORG= xcursor xft xinerama xpm xrender
OPTIONS_DEFINE= ICONS ICONV STROKE RPLAY SESSION_MGMT PNG SVG BIDI NLS IMLIB
-OPTIONS_DEFAULT= ICONV ICONV PNG
+OPTIONS_DEFAULT=ICONS ICONV SESSION_MGMT PNG
+OPTIONS_SUB= yes
+
STROKE_DESC= support for mouse gestures
RPLAY_DESC= RPlay support in FvwmEvent
SESSION_MGMT_DESC= Session Management support
BIDI_DESC= Asian bi-directional text support
IMLIB_DESC= imlib library (requires gtk12)
-NO_STAGE= yes
+PLIST_SUB= FVWM_VERSION="${PORTVERSION}"
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MICONS}
@@ -44,16 +43,14 @@ FVWM_ICONS= fvwm_icons-20070101
DISTFILES+= ${FVWM_ICONS}.tar.bz2
.endif
-.if ! ${PORT_OPTIONS:MICONV}
-CONFIGURE_ARGS+= --disable-iconv
-.else
+.if ${PORT_OPTIONS:MICONV}
USES+= iconv
-CONFIGURE_ARGS+= --with-iconv-library=${ICONV_PREFIX}/lib \
- --with-iconv-includes=${ICONV_PREFIX}/include
+.else
+CONFIGURE_ARGS+= --disable-iconv
.endif
.if ${PORT_OPTIONS:MSTROKE}
-LIB_DEPENDS+= stroke.0:${PORTSDIR}/devel/libstroke
+LIB_DEPENDS+= libstroke.so:${PORTSDIR}/devel/libstroke
CONFIGURE_ARGS+= --with-stroke-library=${LOCALBASE}/lib \
--with-stroke-includes=${LOCALBASE}/include
.else
@@ -61,19 +58,21 @@ CONFIGURE_ARGS+= --without-stroke-library
.endif
.if ${PORT_OPTIONS:MRPLAY}
-LIB_DEPENDS+= rplay.1:${PORTSDIR}/audio/rplay
+LIB_DEPENDS+= librplay.so:${PORTSDIR}/audio/rplay
CONFIGURE_ARGS+= --with-rplay-library=${LOCALBASE}/lib \
--with-rplay-includes=${LOCALBASE}/include
.else
CONFIGURE_ARGS+= --without-rplay-library
.endif
-.if ! ${PORT_OPTIONS:MSESSION_MGMT}
+.if ${PORT_OPTIONS:MSESSION_MGMT}
+USE_XORG+= sm
+.else
CONFIGURE_ARGS+= --disable-sm
.endif
.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-png-includes=${LOCALBASE}/include \
--with-png-library=${LOCALBASE}/lib
.else
@@ -87,80 +86,53 @@ CONFIGURE_ARGS+= --disable-rsvg
.endif
.if ${PORT_OPTIONS:MBIDI}
-LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+= --enable-bidi \
--with-bidi-bindir=${LOCALBASE}/bin
.else
CONFIGURE_ARGS+= --disable-bidi
.endif
-PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
-
-.if ${PORT_OPTIONS:MIMLIB} && !defined(WITHOUT_GTK)
+.if ${PORT_OPTIONS:MIMLIB}
USE_GNOME+= imlib
-CONFIGURE_ARGS+= --enable-gtktest --enable-imlibtest
-PLIST_SUB+= GTK=""
-MAN1+= FvwmGtk.1
.else
-CONFIGURE_ARGS+= --disable-gtktest --disable-imlibtest \
- --with-gtk-prefix=/no/dir --with-imlib-prefix=/no/dir
-PLIST_SUB+= GTK="@comment not installed: "
-WITHOUT_GNOME= true
+CONFIGURE_ARGS+=--disable-gtk
.endif
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CONFIGURE_ARGS+= --with-intl-library=${LOCALBASE}/lib \
--with-intl-includes=${LOCALBASE}/include
-PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment not installed: "
.endif
-CONFIGURE_ARGS+= --without-gnome
-
-MAN1+= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
- FvwmCommand.1 FvwmConsole.1 FvwmConsoleC.pl.1 FvwmCpp.1 FvwmDebug.1 \
- FvwmDragWell.1 FvwmEvent.1 FvwmForm.1 FvwmIconBox.1 \
- FvwmIconMan.1 FvwmIdent.1 FvwmM4.1 FvwmPager.1 FvwmRearrange.1 \
- FvwmSave.1 FvwmSaveDesk.1 FvwmScript.1 FvwmScroll.1 FvwmTaskBar.1 \
- FvwmTheme.1 FvwmWharf.1 FvwmWinList.1 fvwm-menu-desktop.1 \
- fvwm-menu-directory.1 fvwm-menu-headlines.1 fvwm-menu-xlock.1 \
- fvwm.1 fvwm-root.1 fvwm-config.1 fvwm-bug.1 \
- fvwm-convert-2.4.1 fvwm-convert-2.6.1 \
- FvwmPerl.1 fvwm-perllib.1 FvwmProxy.1 FvwmTabs.1 FvwmWindowMenu.1 \
- FvwmGtkDebug.1
+.include <bsd.port.pre.mk>
-MLINKS= fvwm.1 fvwm2.1 \
- fvwm-root.1 xpmroot.1
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=--without-iconv-library
+.else
+CONFIGURE_ARGS+=--with-iconv-library=${ICONV_PREFIX}/lib \
+ --with-iconv-includes=${ICONV_PREFIX}/include
+.endif
.if ${PORT_OPTIONS:MICONS}
-PLIST_SUB+= ICONS=""
post-extract:
@${MKDIR} ${WRKDIR}/icons
@${TAR} -xzf ${DISTDIR}/${FVWM_ICONS}.tar.bz2 -C ${WRKDIR}/icons
-.else
-PLIST_SUB+= ICONS="@comment not installed: "
.endif
post-patch:
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' \
- ${WRKSRC}/modules/FvwmM4/FvwmM4.c \
- ${WRKSRC}/configure
+ ${WRKSRC}/modules/FvwmM4/FvwmM4.c
post-install:
- @${INSTALL_DATA} ${WRKSRC}/sample.fvwmrc/system.fvwm2rc \
- ${PREFIX}/etc/system.fvwm2rc.dist
- @if [ ! -e ${PREFIX}/etc/system.fvwm2rc ]; then \
- ${INSTALL_DATA} ${WRKSRC}/sample.fvwmrc/system.fvwm2rc \
- ${PREFIX}/etc/system.fvwm2rc; \
- fi
-
+ ${INSTALL_DATA} ${WRKSRC}/sample.fvwmrc/system.fvwm2rc \
+ ${STAGEDIR}${PREFIX}/etc/system.fvwm2rc.dist
.if ${PORT_OPTIONS:MICONS}
- @${MKDIR} ${PREFIX}/share/fvwm/pixmaps
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/fvwm/pixmaps
${INSTALL_DATA} ${WRKDIR}/icons/${FVWM_ICONS}/*.xpm \
- ${PREFIX}/share/fvwm/pixmaps
+ ${STAGEDIR}${PREFIX}/share/fvwm/pixmaps
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/fvwm2/files/patch-bin::Makefile.in b/x11-wm/fvwm2/files/patch-bin::Makefile.in
deleted file mode 100644
index 1a05697f3500..000000000000
--- a/x11-wm/fvwm2/files/patch-bin::Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- bin/Makefile.in.orig 2008-05-06 22:22:48.000000000 -0700
-+++ bin/Makefile.in 2008-12-12 19:35:30.533121271 -0800
-@@ -734,9 +734,7 @@
-
- install-data-local:
- @rm -f $(DESTDIR)$(mandir)/man1/xpmroot.1
-- @$(LN_S) fvwm-root.1 $(DESTDIR)$(mandir)/man1/xpmroot.1 || \
-- echo "Minor warning: $(mandir)/man1/xpmroot.1 symlink was not created"
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/x11-wm/fvwm2/files/patch-configure b/x11-wm/fvwm2/files/patch-configure
new file mode 100644
index 000000000000..40f38a05bb1b
--- /dev/null
+++ b/x11-wm/fvwm2/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2012-04-20 13:03:57.000000000 +0200
++++ configure 2014-03-28 17:42:24.000000000 +0100
+@@ -6492,7 +6492,6 @@
+ switch (*p = p = *c) { case 0: printf("%Q", c, p); }
+ *c = &i; c = p;
+ while (1 || (unsigned int)3 >= 0 || ((int)-1) == ((unsigned int)1));
+- return;
+ ;
+ return 0;
+ }
diff --git a/x11-wm/fvwm2/files/patch-configure.ac b/x11-wm/fvwm2/files/patch-configure.ac
deleted file mode 100644
index d3ab2bb26373..000000000000
--- a/x11-wm/fvwm2/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.bak 2013-02-01 10:35:04.191557713 +0100
-+++ configure.ac 2013-02-01 10:35:12.513558507 +0100
-@@ -225,7 +225,7 @@
- switch (*p = p = *c) { case 0: printf("%Q", c, p); }
- *c = &i; c = p;
- while (1 || (unsigned int)3 >= 0 || ((int)-1) == ((unsigned int)1));
-- return;], , AC_MSG_ERROR("
-+ return 0;], , AC_MSG_ERROR("
- configure is not able to compile programs with warnings. Please
- remove all offending options like -Werror from the CFLAGS and
- CPPFLAGS variables and run configure again."))
diff --git a/x11-wm/fvwm2/files/patch-libs-Ficonv.c b/x11-wm/fvwm2/files/patch-libs-Ficonv.c
new file mode 100644
index 000000000000..302368735184
--- /dev/null
+++ b/x11-wm/fvwm2/files/patch-libs-Ficonv.c
@@ -0,0 +1,11 @@
+--- libs/Ficonv.c.orig 2011-08-16 09:05:53.000000000 +0200
++++ libs/Ficonv.c 2014-03-29 17:17:54.000000000 +0100
+@@ -36,7 +36,7 @@
+ #if defined(USE_LIBICONV) && !defined (_LIBICONV_H)
+ #error libiconv in use but included iconv.h not from libiconv
+ #endif
+-#if !defined(USE_LIBICONV) && defined (_LIBICONV_H)
++#if !defined(USE_LIBICONV) && defined (_LIBICONV_H) && !defined (LIBICONV_PLUG)
+ #error libiconv not in use but included iconv.h is from libiconv
+ #endif
+ #endif /* FiconvSupport */
diff --git a/x11-wm/fvwm2/pkg-plist b/x11-wm/fvwm2/pkg-plist
index 568dd97e87db..9956e34b2412 100644
--- a/x11-wm/fvwm2/pkg-plist
+++ b/x11-wm/fvwm2/pkg-plist
@@ -33,7 +33,7 @@ libexec/fvwm/%%FVWM_VERSION%%/FvwmDebug
libexec/fvwm/%%FVWM_VERSION%%/FvwmDragWell
libexec/fvwm/%%FVWM_VERSION%%/FvwmEvent
libexec/fvwm/%%FVWM_VERSION%%/FvwmForm
-%%GTK%%libexec/fvwm/%%FVWM_VERSION%%/FvwmGtk
+%%IMLIB%%libexec/fvwm/%%FVWM_VERSION%%/FvwmGtk
libexec/fvwm/%%FVWM_VERSION%%/FvwmGtkDebug
libexec/fvwm/%%FVWM_VERSION%%/FvwmIconBox
libexec/fvwm/%%FVWM_VERSION%%/FvwmIconMan
@@ -55,6 +55,52 @@ libexec/fvwm/%%FVWM_VERSION%%/FvwmTile
libexec/fvwm/%%FVWM_VERSION%%/FvwmWharf
libexec/fvwm/%%FVWM_VERSION%%/FvwmWinList
libexec/fvwm/%%FVWM_VERSION%%/FvwmWindowMenu
+man/man1/FvwmAnimate.1.gz
+man/man1/FvwmAuto.1.gz
+man/man1/FvwmBacker.1.gz
+man/man1/FvwmBanner.1.gz
+man/man1/FvwmButtons.1.gz
+man/man1/FvwmCommand.1.gz
+man/man1/FvwmConsole.1.gz
+man/man1/FvwmConsoleC.pl.1.gz
+man/man1/FvwmCpp.1.gz
+man/man1/FvwmDebug.1.gz
+man/man1/FvwmDragWell.1.gz
+man/man1/FvwmEvent.1.gz
+man/man1/FvwmForm.1.gz
+%%IMLIB%%man/man1/FvwmGtk.1.gz
+man/man1/FvwmGtkDebug.1.gz
+man/man1/FvwmIconBox.1.gz
+man/man1/FvwmIconMan.1.gz
+man/man1/FvwmIdent.1.gz
+man/man1/FvwmM4.1.gz
+man/man1/FvwmPager.1.gz
+man/man1/FvwmPerl.1.gz
+man/man1/FvwmProxy.1.gz
+man/man1/FvwmRearrange.1.gz
+man/man1/FvwmSave.1.gz
+man/man1/FvwmSaveDesk.1.gz
+man/man1/FvwmScript.1.gz
+man/man1/FvwmScroll.1.gz
+man/man1/FvwmTabs.1.gz
+man/man1/FvwmTaskBar.1.gz
+man/man1/FvwmTheme.1.gz
+man/man1/FvwmWharf.1.gz
+man/man1/FvwmWinList.1.gz
+man/man1/FvwmWindowMenu.1.gz
+man/man1/fvwm-bug.1.gz
+man/man1/fvwm-config.1.gz
+man/man1/fvwm-convert-2.4.1.gz
+man/man1/fvwm-convert-2.6.1.gz
+man/man1/fvwm-perllib.1.gz
+man/man1/fvwm-menu-desktop.1.gz
+man/man1/fvwm-menu-directory.1.gz
+man/man1/fvwm-menu-headlines.1.gz
+man/man1/fvwm-menu-xlock.1.gz
+man/man1/fvwm-root.1.gz
+man/man1/fvwm.1.gz
+man/man1/fvwm2.1.gz
+man/man1/xpmroot.1.gz
%%ICONS%%%%DATADIR%%/pixmaps/Jlock.xpm
%%ICONS%%%%DATADIR%%/pixmaps/Jnews.xpm
%%ICONS%%%%DATADIR%%/pixmaps/Jrecycle.xpm