aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/herbstluftwm
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-01-30 06:31:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-01-30 06:31:40 +0000
commitc0d8e116ce11498996a3115353ca029d3e5b31b5 (patch)
treec1bfb69da8ce717bc279f4b7fd1667cfa6f0a88c /x11-wm/herbstluftwm
parent083d2da0ab1f04c09ba0db0a99b8a6f5747fb7bb (diff)
downloadports-c0d8e116ce11498996a3115353ca029d3e5b31b5.tar.gz
ports-c0d8e116ce11498996a3115353ca029d3e5b31b5.zip
Add herbstluftwm, a manual tiling window manager for X11 using Xlib and Glib.
PR: ports/171378 Submitted by: Christian Brassat
Notes
Notes: svn path=/head/; revision=311201
Diffstat (limited to 'x11-wm/herbstluftwm')
-rw-r--r--x11-wm/herbstluftwm/Makefile61
-rw-r--r--x11-wm/herbstluftwm/distinfo2
-rw-r--r--x11-wm/herbstluftwm/pkg-descr17
-rw-r--r--x11-wm/herbstluftwm/pkg-plist35
4 files changed, 115 insertions, 0 deletions
diff --git a/x11-wm/herbstluftwm/Makefile b/x11-wm/herbstluftwm/Makefile
new file mode 100644
index 000000000000..0a7f9feac248
--- /dev/null
+++ b/x11-wm/herbstluftwm/Makefile
@@ -0,0 +1,61 @@
+# $FreeBSD$
+
+PORTNAME= herbstluftwm
+PORTVERSION= 0.5.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://wwwcip.cs.fau.de/~re06huxa/herbstluftwm/tarballs/
+
+MAINTAINER= crshd@mail.com
+COMMENT= Manual tiling window manager for X11
+
+LICENSE= BSD
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_GMAKE= yes
+USE_XORG= x11 xinerama
+USE_GNOME= glib20
+
+MAKE_ARGS= PREFIX=${PREFIX} SYSCONFDIR=${PREFIX}/etc \
+ DOCSDIR=${DOCSDIR} EXAMPLESDIR=${EXAMPLESDIR} \
+ MANDIR=${PREFIX}/man
+
+MAN1= herbstclient.1 herbstluftwm.1
+MAN7= herbstluftwm-tutorial.7
+
+OPTIONS_DEFINE= BASH ZSH DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MBASH}
+PLIST_SUB+= BASH=""
+.else
+PLIST_SUB+= BASH="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MZSH}
+PLIST_SUB+= ZSH=""
+.else
+PLIST_SUB+= ZSH="@comment "
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e '/-[LI]\/usr/s,usr,${LOCALBASE},' \
+ ${WRKSRC}/config.mk
+ ${REINPLACE_CMD} -e '/LICENSEDIR/d' ${WRKSRC}/Makefile
+ ${GREP} -Rl --null '^#!/bin/bash' ${WRKSRC} | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's,/bin/bash,/usr/bin/env bash,'
+.if ! ${PORT_OPTIONS:MBASH}
+ ${REINPLACE_CMD} -e '/BASHCOMPLETIONDIR/d' ${WRKSRC}/Makefile
+.endif
+.if ! ${PORT_OPTIONS:MZSH}
+ ${REINPLACE_CMD} -e '/ZSHCOMPLETIONDIR/d' ${WRKSRC}/Makefile
+.endif
+.if ! ${PORT_OPTIONS:MDOCS}
+ ${REINPLACE_CMD} -e '/DOCDIR/d' ${WRKSRC}/Makefile
+.endif
+.if ! ${PORT_OPTIONS:MEXAMPLES}
+ ${REINPLACE_CMD} -e '/EXAMPLESDIR/d' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/herbstluftwm/distinfo b/x11-wm/herbstluftwm/distinfo
new file mode 100644
index 000000000000..87e2275edb3b
--- /dev/null
+++ b/x11-wm/herbstluftwm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (herbstluftwm-0.5.1.tar.gz) = d42c78ab06414839b65e660e91ee93f0397fc13ab76f697519ef343abc323e1f
+SIZE (herbstluftwm-0.5.1.tar.gz) = 168282
diff --git a/x11-wm/herbstluftwm/pkg-descr b/x11-wm/herbstluftwm/pkg-descr
new file mode 100644
index 000000000000..cedd324cb5bf
--- /dev/null
+++ b/x11-wm/herbstluftwm/pkg-descr
@@ -0,0 +1,17 @@
+herbstluftwm is a manual tiling window manager for X11 using Xlib and Glib.
+Its main features can be described with:
+
+ - The layout is based on splitting frames into subframes which can be
+ split again or can be filled with windows (similar to i3 or musca)
+
+ - Tags (or workspaces, or virtual desktops) can be added/removed at
+ runtime. Each tag contains an own layout
+
+ - Exactly one tag is viewed on each monitor. The tags are monitor
+ independent (similar to xmonad)
+
+ - It is configured at runtime via IPC calls from herbstclient. So the
+ configuration file is just a script which is run on startup. (Similar
+ to wmii or musca)
+
+WWW: http://wwwcip.cs.fau.de/~re06huxa/herbstluftwm/
diff --git a/x11-wm/herbstluftwm/pkg-plist b/x11-wm/herbstluftwm/pkg-plist
new file mode 100644
index 000000000000..ac6275c9d936
--- /dev/null
+++ b/x11-wm/herbstluftwm/pkg-plist
@@ -0,0 +1,35 @@
+bin/herbstclient
+bin/herbstluftwm
+etc/xdg/herbstluftwm/autostart
+etc/xdg/herbstluftwm/panel.sh
+etc/xdg/herbstluftwm/restartpanels.sh
+%%BASH%%etc/bash_completion.d/herbstclient-completion
+%%BASH%%@dirrmtry etc/bash_completion.d
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/herbstclient.html
+%%PORTDOCS%%%%DOCSDIR%%/herbstluftwm.html
+%%PORTDOCS%%%%DOCSDIR%%/herbstluftwm-tutorial.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dmenu.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dumpbeautify.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exec_on_tag.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execwith.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/herbstcommander.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/keychain.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/layout.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lasttag.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/loadstate.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/q3terminal.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/savestate.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wselect.sh
+share/xsessions/herbstluftwm.desktop
+@dirrmtry share/xsessions
+%%ZSH%%share/zsh/functions/Completion/X/_herbstclient
+%%ZSH%%@dirrmtry share/zsh/functions/Completion/X
+%%ZSH%%@dirrmtry share/zsh/functions/Completion
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm etc/xdg/herbstluftwm
+@dirrmtry etc/xdg