aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/hikari
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-05-21 21:24:02 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-05-21 21:24:02 +0000
commitd6bf27d900f040039e527bc0780d8d99033edc2f (patch)
tree11e14c617c1e7174f189714b0946d5f4d45cf0bf /x11-wm/hikari
parent971e90dc09989378b84c31a8020d1b81089f3d70 (diff)
downloadports-d6bf27d900f040039e527bc0780d8d99033edc2f.tar.gz
ports-d6bf27d900f040039e527bc0780d8d99033edc2f.zip
Add hikari.desktop for display/login managers.
While here: - Include bsd.port.pre.mk before checking the value of WITH_DEBUG so that WITH_DEBUG_PORTS is respected. - Mention that the format of config.h may change across versions. PR: 238019 Submitted by: Alexander Sieg <alex@xanderio.de>
Notes
Notes: svn path=/head/; revision=502236
Diffstat (limited to 'x11-wm/hikari')
-rw-r--r--x11-wm/hikari/Makefile13
-rw-r--r--x11-wm/hikari/files/hikari.desktop.in7
2 files changed, 18 insertions, 2 deletions
diff --git a/x11-wm/hikari/Makefile b/x11-wm/hikari/Makefile
index a5e8ead398ad..ddb2c89608e3 100644
--- a/x11-wm/hikari/Makefile
+++ b/x11-wm/hikari/Makefile
@@ -2,6 +2,7 @@
PORTNAME= hikari
DISTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= https://acmelabs.space/~raichoo/
@@ -20,11 +21,16 @@ USE_XORG= xcb x11
NO_WRKSUBDIR= yes
+SUB_FILES= hikari.desktop
+SUB_LIST= COMMENT="${COMMENT}"
PLIST_FILES= bin/hikari \
- man/man1/hikari.1.gz
+ man/man1/hikari.1.gz \
+ share/xsessions/hikari.desktop
PORTDATA= config.def.h
PORTDOCS= README.md
+.include <bsd.port.pre.mk>
+
.if defined(WITH_DEBUG)
ALL_TARGET= debug
.else
@@ -36,6 +42,7 @@ OPTIONS_DEFINE= DOCS
pre-everything::
@${ECHO_MSG} "You can build hikari with your own config.h using the HIKARI_CONF knob:"
@${ECHO_MSG} "make HIKARI_CONF=/path/to/hikari/config.h install clean"
+ @${ECHO_MSG} "Note: Pre-${PORTVERSION} config.h files may not work."
post-patch:
.if defined(HIKARI_CONF)
@@ -50,9 +57,11 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/hikari.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDATA} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/xsessions
+ ${INSTALL_DATA} ${WRKDIR}/hikari.desktop ${STAGEDIR}${PREFIX}/share/xsessions
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/hikari/files/hikari.desktop.in b/x11-wm/hikari/files/hikari.desktop.in
new file mode 100644
index 000000000000..97000c4d74e3
--- /dev/null
+++ b/x11-wm/hikari/files/hikari.desktop.in
@@ -0,0 +1,7 @@
+# $FreeBSD$
+[Desktop Entry]
+Name=hikari
+Comment=%%COMMENT%%
+TryExec=hikari
+Exec=hikari
+Type=Application