aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/hs-xmonad
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-05-25 21:44:12 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-05-25 21:44:12 +0000
commitfff1aa535b4a18a05d872de7c9afb3dbf9f6013b (patch)
tree86e71c0056b8414191c8b421101694a177fec03e /x11-wm/hs-xmonad
parentb782168218ce43588149523e6d12003aa68ad324 (diff)
downloadports-fff1aa535b4a18a05d872de7c9afb3dbf9f6013b.tar.gz
ports-fff1aa535b4a18a05d872de7c9afb3dbf9f6013b.zip
Update lang/ghc 8.4.2 and the hs-* ports the newer versions
* Update lang/ghc to 8.4.2 * Update the boostrap compiler to 8.4.1 * Update the many hs-* ports * Bump the rest Thanks a lot to arrowd for doing all the heavy lifting :) PR: 227968 Exp-run by: antoine Submitted by: arrowd Differential Revision: https://reviews.freebsd.org/D15005
Notes
Notes: svn path=/head/; revision=470870
Diffstat (limited to 'x11-wm/hs-xmonad')
-rw-r--r--x11-wm/hs-xmonad/Makefile4
-rw-r--r--x11-wm/hs-xmonad/files/patch-8.4.1-support61
2 files changed, 63 insertions, 2 deletions
diff --git a/x11-wm/hs-xmonad/Makefile b/x11-wm/hs-xmonad/Makefile
index a2c19f0ad174..9f7367d4742a 100644
--- a/x11-wm/hs-xmonad/Makefile
+++ b/x11-wm/hs-xmonad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmonad
PORTVERSION= 0.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= Tiling window manager
LICENSE= BSD3CLAUSE
-USE_CABAL= extensible-exceptions mtl setlocale utf8-string X11
+USE_CABAL= extensible-exceptions mtl semigroups setlocale utf8-string X11
USE_XORG= x11
MAN1PAGES= xmonad.1
diff --git a/x11-wm/hs-xmonad/files/patch-8.4.1-support b/x11-wm/hs-xmonad/files/patch-8.4.1-support
new file mode 100644
index 000000000000..2dcf5baf645b
--- /dev/null
+++ b/x11-wm/hs-xmonad/files/patch-8.4.1-support
@@ -0,0 +1,61 @@
+--- src/XMonad/Core.hs.orig 2017-02-09 02:46:45 UTC
++++ src/XMonad/Core.hs
+@@ -39,6 +39,7 @@ import qualified Control.Exception.Extensible as E
+ import Control.Applicative
+ import Control.Monad.State
+ import Control.Monad.Reader
++import Data.Semigroup
+ import Data.Default
+ import System.FilePath
+ import System.IO
+@@ -56,7 +57,7 @@ import Graphics.X11.Xlib.Extras (getWindowAttributes,
+ import Data.Typeable
+ import Data.List ((\\))
+ import Data.Maybe (isJust,fromMaybe)
+-import Data.Monoid
++import Data.Monoid hiding ((<>))
+
+ import qualified Data.Map as M
+ import qualified Data.Set as S
+@@ -151,6 +152,9 @@ instance Applicative X where
+ pure = return
+ (<*>) = ap
+
++instance Semigroup a => Semigroup (X a) where
++ (<>) = liftM2 (<>)
++
+ instance (Monoid a) => Monoid (X a) where
+ mempty = return mempty
+ mappend = liftM2 mappend
+@@ -164,6 +168,9 @@ newtype Query a = Query (ReaderT Window X a)
+
+ runQuery :: Query a -> Window -> X a
+ runQuery (Query m) w = runReaderT m w
++
++instance Semigroup a => Semigroup (Query a) where
++ (<>) = liftM2 (<>)
+
+ instance Monoid a => Monoid (Query a) where
+ mempty = return mempty
+--- xmonad.cabal.orig 2017-02-10 22:07:40 UTC
++++ xmonad.cabal
+@@ -32,7 +32,8 @@ tested-with:
+ GHC==7.6.3,
+ GHC==7.8.4,
+ GHC==7.10.3,
+- GHC==8.0.1
++ GHC==8.0.1,
++ GHC==8.2.2
+
+ data-files: man/xmonad.hs, man/xmonad.1, man/xmonad.1.html
+
+@@ -78,7 +79,8 @@ library
+ process,
+ unix,
+ utf8-string >= 0.3 && < 1.1,
+- X11>=1.8 && < 1.9
++ X11>=1.8 && < 1.9,
++ semigroups
+
+ if true
+ ghc-options: -funbox-strict-fields -Wall