aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/i3-gaps
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2020-11-21 12:14:14 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2020-11-21 12:14:14 +0000
commit3cbe234525e91c20d9a5530509ace6d6ec688fcc (patch)
treea5547d837689cef342da237371222d5245c97dfc /x11-wm/i3-gaps
parent1a0be3d9eb7ba189669a7c1dc93a23e1377dbfd3 (diff)
downloadports-3cbe234525e91c20d9a5530509ace6d6ec688fcc.tar.gz
ports-3cbe234525e91c20d9a5530509ace6d6ec688fcc.zip
x11-wm/i3-gaps: Unbreak build when both DOCS and MANPAGES are selected
Notes
Notes: svn path=/head/; revision=555963
Diffstat (limited to 'x11-wm/i3-gaps')
-rw-r--r--x11-wm/i3-gaps/Makefile2
-rw-r--r--x11-wm/i3-gaps/files/patch-meson.build34
2 files changed, 35 insertions, 1 deletions
diff --git a/x11-wm/i3-gaps/Makefile b/x11-wm/i3-gaps/Makefile
index 84f36ca24b24..622ddb94e4c1 100644
--- a/x11-wm/i3-gaps/Makefile
+++ b/x11-wm/i3-gaps/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS= p5-AnyEvent-I3>=0:devel/p5-AnyEvent-I3 \
p5-JSON-XS>=0:converters/p5-JSON-XS \
p5-Try-Tiny>=0:lang/p5-Try-Tiny
-USES= compiler:c11 gettext-runtime gmake gnome iconv localbase:ldflags \
+USES= compiler:c11 gettext-runtime gnome iconv localbase:ldflags \
meson perl5 pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= Airblader
diff --git a/x11-wm/i3-gaps/files/patch-meson.build b/x11-wm/i3-gaps/files/patch-meson.build
new file mode 100644
index 000000000000..3fd04947eb76
--- /dev/null
+++ b/x11-wm/i3-gaps/files/patch-meson.build
@@ -0,0 +1,34 @@
+Upstream PR: https://github.com/i3/i3/pull/4264
+--- meson.build.orig 2020-11-15 18:11:08 UTC
++++ meson.build
+@@ -428,7 +428,9 @@ command_parser = custom_target(
+ command: [perl, parser_gen, '--input=@INPUT@', '--prefix=command'],
+ )
+
+-i3srcs += command_parser
++command_parser_dep = declare_dependency(
++ sources : [command_parser]
++)
+
+ config_parser = custom_target(
+ 'config_parser',
+@@ -441,7 +443,9 @@ config_parser = custom_target(
+ command: [parser_gen, '--input=@INPUT@', '--prefix=config'],
+ )
+
+-i3srcs += config_parser
++config_parser_dep = declare_dependency(
++ sources : [config_parser]
++)
+
+ # src/log.c uses threading primitives for synchronization
+ thread_dep = dependency('threads')
+@@ -472,6 +476,8 @@ common_deps = [
+ gobject_dep,
+ ev_dep,
+ config_h,
++ command_parser_dep,
++ config_parser_dep
+ ]
+
+ executable(