aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/i3
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2017-09-27 13:13:13 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2017-09-27 13:13:13 +0000
commit97f6e2dc388e7ee08e89d8dfb9d0b4b17f4fdd54 (patch)
tree4695f9a3458769801d908c3b8832b1f752e06654 /x11-wm/i3
parent8e2eadf6c4f0efc81428fd5ff677fb3ec6610bdd (diff)
downloadports-97f6e2dc388e7ee08e89d8dfb9d0b4b17f4fdd54.tar.gz
ports-97f6e2dc388e7ee08e89d8dfb9d0b4b17f4fdd54.zip
x11-wm/i3: import patch from upstream, bump PORTREVISION
The patch fixes https://github.com/i3/i3/issues/2846 Approved by: bapt (maintainer)
Notes
Notes: svn path=/head/; revision=450736
Diffstat (limited to 'x11-wm/i3')
-rw-r--r--x11-wm/i3/Makefile1
-rw-r--r--x11-wm/i3/files/patch-pull284927
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index 669f6800ab9d..85ebe7f79ce5 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= i3
DISTVERSION= 4.14.1
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://i3wm.org/downloads/
diff --git a/x11-wm/i3/files/patch-pull2849 b/x11-wm/i3/files/patch-pull2849
new file mode 100644
index 000000000000..ced829ce747c
--- /dev/null
+++ b/x11-wm/i3/files/patch-pull2849
@@ -0,0 +1,27 @@
+From bfc6e1217265c8c77a8382f5c7970d049e958250 Mon Sep 17 00:00:00 2001
+From: Dan Elkouby <streetwalkermc@gmail.com>
+Date: Sun, 30 Jul 2017 18:49:42 +0300
+Subject: [PATCH] Create a new split container when switching a workspace
+ container to split layout
+
+The behavior before 52ce8c8 was to do it regardless of what layout we're
+switching to.
+
+Fixes #2846
+---
+ src/con.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/con.c b/src/con.c
+index d346b9f45..94bfa6e9e 100644
+--- src/con.c.orig
++++ src/con.c
+@@ -1719,7 +1719,7 @@ void con_set_layout(Con *con, layout_t layout) {
+ con->workspace_layout = ws_layout;
+ DLOG("Setting layout to %d\n", layout);
+ con->layout = layout;
+- } else if (layout == L_STACKED || layout == L_TABBED) {
++ } else if (layout == L_STACKED || layout == L_TABBED || layout == L_SPLITV || layout == L_SPLITH) {
+ DLOG("Creating new split container\n");
+ /* 1: create a new split container */
+ Con *new = con_new(NULL, NULL);