aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/icewm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-23 16:04:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-23 16:04:51 +0000
commit60880dc81ea1f497ad1c55285f752c2fc988fa12 (patch)
tree947b714701f203a11bd91bb968e8cabe9cc8c30b /x11-wm/icewm
parent3c0ba34945b49d59f9fdb8aff80fd63d50764e02 (diff)
downloadports-60880dc81ea1f497ad1c55285f752c2fc988fa12.tar.gz
ports-60880dc81ea1f497ad1c55285f752c2fc988fa12.zip
- Update to 1.3.8
- Convert to USES - Stage support PR: 186738 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=345744
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Makefile112
-rw-r--r--x11-wm/icewm/distinfo4
-rw-r--r--x11-wm/icewm/files/patch-src__Makefile.in11
-rw-r--r--x11-wm/icewm/files/patch-src__aapm.cc10
-rw-r--r--x11-wm/icewm/files/patch-src__apppstatus.cc17
-rw-r--r--x11-wm/icewm/files/patch-src__wmapp.cc20
-rw-r--r--x11-wm/icewm/files/patch-src__wmapp.h11
-rw-r--r--x11-wm/icewm/files/patch-src__yarray.h16
-rw-r--r--x11-wm/icewm/files/patch-src_base.h15
-rw-r--r--x11-wm/icewm/pkg-message12
-rw-r--r--x11-wm/icewm/pkg-plist4
11 files changed, 85 insertions, 147 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 7e92cfa1716a..1ae2615256ae 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -2,66 +2,58 @@
# $FreeBSD$
PORTNAME= icewm
-PORTVERSION= 1.3.7
-PORTREVISION= 3
+PORTVERSION= 1.3.8
CATEGORIES= x11-wm
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Window Manager designed for speed, usability and consistency
LICENSE= GPLv2
-WANT_GNOME= yes
-USE_XORG= x11 ice xinerama xext xrandr sm
-USE_GNOME= gtk20 # gdkpixbuf really :-)
+USES= gmake iconv pkgconfig
+USE_XORG= ice sm x11 xext
+USE_GNOME= gdkpixbuf2
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USES= gmake pkgconfig
-CONFIGURE_ARGS= --enable-shaped-decorations \
- --enable-guievents \
+CONFIGURE_ARGS= --enable-guievents \
--with-cfgdir=${DATADIR} \
--with-libdir=${DATADIR} \
--with-kdedatadir=${LOCALBASE}/share \
--with-docdir=${PREFIX}/share/doc \
--with-mkfontdir=${NONEXISTENT}
-OPTIONS_DEFINE= GNOME ESOUND XFT XINERAMA ASM BEASTIE NLS LITE MENUFIX
-OPTIONS_DEFAULT= XFT XINERAMA ASM BEASTIE NLS MENUFIX
-BEASTIE_DESC= Use Beastie'fied startup button
-MENUFIX_DESC= MenuIconSize fix
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MGNOME}
-USE_GNOME+= gnomedesktop libgnomeui
-CONFIGURE_ARGS+=--enable-menus-gnome2
-INSTALL_TARGET= install
-PLIST_SUB+= GNOMEDESKTOP=""
-.else
-PLIST_SUB+= GNOMEDESKTOP="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MESOUND}
-USE_GNOME+= esound
-CONFIGURE_ARGS+=--with-icesound=esound
-.else
-CONFIGURE_ARGS+=--with-icesound=oss
-.endif
-
-.if ${PORT_OPTIONS:MXFT}
-LIB_DEPENDS+= Xft:${PORTSDIR}/x11-fonts/libXft
-CONFIGURE_ARGS+=--enable-gradients
-.else
-CONFIGURE_ARGS+=--enable-corefonts --disable-xfreetype
-.endif
-
-.if empty(PORT_OPTIONS:MXINERAMA)
-CONFIGURE_ARGS+=--disable-xinerama
-.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-.if ${ARCH} == "i386" && ${PORT_OPTIONS:MASM}
+OPTIONS_DEFINE= BEASTIE ESOUND GNOME LITE MENUFIX NLS XFT XINERAMA \
+ XRANDR
+OPTIONS_DEFINE_i386= ASM
+OPTIONS_DEFAULT= BEASTIE MENUFIX NLS XFT XINERAMA XRANDR
+OPTIONS_DEFAULT_i386= ASM
+OPTIONS_SUB= yes
+
+BEASTIE_DESC= Use Beastie'fied startup button
+ESOUND_USE= GNOME=esound
+ESOUND_CONFIGURE_ON= --with-icesound=esound
+ESOUND_CONFIGURE_OFF= --with-icesound=oss
+GNOME_DESC= Display GNOME 2 menus
+GNOME_USE= GNOME=gnomedesktop,libgnomeui
+GNOME_CONFIGURE_ENABLE= menus-gnome2
+LITE_CONFIGURE_ENABLE= lite
+MENUFIX_DESC= MenuIconSize fix
+MENUFIX_EXTRA_PATCHES= ${FILESDIR}/extra-menu-icon-fix.patch
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+XFT_LIB_DEPENDS= libXft.so:${PORTSDIR}/x11-fonts/libXft
+XFT_CONFIGURE_OFF= --enable-corefonts --disable-xfreetype
+XINERAMA_USE= XORG=xinerama
+XINERAMA_CONFIGURE_ENABLE= xinerama
+XRANDR_USE= XORG=xrandr
+XRANDR_CONFIGURE_ENABLE= xrandr
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MASM}
CONFIGURE_ARGS+=--enable-x86-asm
.else
CONFIGURE_ARGS+=--disable-x86-asm
@@ -73,20 +65,10 @@ STARTUP_PIXMAP= ${DATADIR}/taskbar/bsd-daemon.xpm
STARTUP_PIXMAP= icewm-logo.xpm
.endif
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls --disable-i18n
-PLIST_SUB+= NLS="@comment "
-.endif
-
.if ${PORT_OPTIONS:MLITE}
-MAKE_ENV+= LITE=1
-.endif
-
-.if ${PORT_OPTIONS:MMENUFIX}
-EXTRA_PATCHES+= ${FILESDIR}/extra-menu-icon-fix.patch
+PLIST_SUB+= NOLITE="@comment "
+.else
+PLIST_SUB+= NOLITE=""
.endif
post-extract:
@@ -102,9 +84,15 @@ post-patch:
s|/usr/share/app|${LOCALBASE}/share/app|g ; \
s|/usr/share/gnome|${LOCALBASE}/share/gnome|g' \
${WRKSRC}/src/gnome2.cc
-
-post-configure:
- ${REINPLACE_CMD} -e 's|icewm-set-gnomewm||g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|SHELL=.*|SHELL=@SHELL@| ; \
+ s|icewm-set-gnomewm||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|icewm-$$(VERSION)|icewm| ; \
+ s|`pkg-config fontconfig --cflags`|| ; \
+ s|`pkg-config fontconfig --libs`|| ; \
+ /@echo/s|^|#| ; \
+ s|@$$(|$$(|' ${WRKSRC}/src/Makefile.in
post-install:
.for dir in taskbar themes/Infadel2/taskbar
@@ -116,4 +104,4 @@ post-install:
. endfor
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/icewm/distinfo b/x11-wm/icewm/distinfo
index 93cdf226e60e..7e6baef797a9 100644
--- a/x11-wm/icewm/distinfo
+++ b/x11-wm/icewm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icewm-1.3.7.tar.gz) = ca1a78046ae340c324c441ce24a9675c24a8bafd3eb6ed8205345785da08887b
-SIZE (icewm-1.3.7.tar.gz) = 898197
+SHA256 (icewm-1.3.8.tar.gz) = 17588d9e0bbbb23587bc04c83da9dd94fd4da6894ecfee6d7f3ed50d780dcd18
+SIZE (icewm-1.3.8.tar.gz) = 905680
diff --git a/x11-wm/icewm/files/patch-src__Makefile.in b/x11-wm/icewm/files/patch-src__Makefile.in
deleted file mode 100644
index 2b4be0d2b11f..000000000000
--- a/x11-wm/icewm/files/patch-src__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/Makefile.in.orig 2011-04-22 23:41:38.690448253 +0200
-+++ ./src/Makefile.in 2011-04-22 23:41:53.522445343 +0200
-@@ -32,7 +32,7 @@
- -DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
- -DICESMEXE='"icewm-session$(EXEEXT)"' \
- -DICEHELPEXE='"icehelp$(EXEEXT)"' \
-- -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
-+ -DICEHELPIDX='"$(DOCDIR)/icewm/icewm.html"'
-
- CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
- @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`
diff --git a/x11-wm/icewm/files/patch-src__aapm.cc b/x11-wm/icewm/files/patch-src__aapm.cc
deleted file mode 100644
index 9ed5ed66228d..000000000000
--- a/x11-wm/icewm/files/patch-src__aapm.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/aapm.cc.orig 2010-10-31 10:09:36.000000000 -0400
-+++ ./src/aapm.cc 2010-11-02 19:56:53.000000000 -0400
-@@ -243,6 +243,7 @@
- }
-
- void YApm::AcpiStr(char *s, bool Tool) {
-+ size_t len;
- char buf[80], buf2[80], bat_info[250];
- FILE *fd;
- //name of the battery
diff --git a/x11-wm/icewm/files/patch-src__apppstatus.cc b/x11-wm/icewm/files/patch-src__apppstatus.cc
deleted file mode 100644
index f3251b866b8a..000000000000
--- a/x11-wm/icewm/files/patch-src__apppstatus.cc
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix clang build errors
-
-http://icewm.cvs.sourceforge.net/viewvc/icewm/icewm-1.2/src/apppstatus.cc?r1=1.24.2.1.2.4&r2=1.24.2.1.2.5&pathrev=icewm-1-3-BRANCH
-
---- src/apppstatus.cc 2009/11/08 19:24:08 1.24.2.1.2.4
-+++ src/apppstatus.cc 2010/12/25 15:29:53 1.24.2.1.2.5
-@@ -82,7 +82,9 @@
- }
-
- NetStatus::~NetStatus() {
-- delete[] color;
-+ delete color[0];
-+ delete color[1];
-+ delete color[2];
- delete[] ppp_in;
- delete[] ppp_out;
- delete fUpdateTimer;
diff --git a/x11-wm/icewm/files/patch-src__wmapp.cc b/x11-wm/icewm/files/patch-src__wmapp.cc
new file mode 100644
index 000000000000..a0fce7715d6b
--- /dev/null
+++ b/x11-wm/icewm/files/patch-src__wmapp.cc
@@ -0,0 +1,20 @@
+--- src/wmapp.cc.orig
++++ src/wmapp.cc
+@@ -337,7 +337,7 @@
+ int ndirs; // ------------------- retrieve the old X's font path ---
+ char ** fontPath(XGetFontPath(xapp->display(), &ndirs));
+
+- char ** newFontPath = new char *[ndirs + 1];
++ const char ** newFontPath = new const char *[ndirs + 1];
+ newFontPath[ndirs] = fontsdir;
+
+ if (fontPath)
+@@ -383,7 +383,7 @@
+ XChangeProperty(xapp->display(), manager->handle(),
+ XA_ICEWM_FONT_PATH, XA_STRING, 8, PropModeReplace,
+ (unsigned char *) fontsdir, strlen(fontsdir));
+- XSetFontPath(xapp->display(), newFontPath, ndirs + 1);
++ XSetFontPath(xapp->display(), (char **) newFontPath, ndirs + 1);
+
+ if (fontPath) XFreeFontPath(fontPath);
+ delete[] fontsdir;
diff --git a/x11-wm/icewm/files/patch-src__wmapp.h b/x11-wm/icewm/files/patch-src__wmapp.h
new file mode 100644
index 000000000000..ebdf320d131a
--- /dev/null
+++ b/x11-wm/icewm/files/patch-src__wmapp.h
@@ -0,0 +1,11 @@
+--- src/wmapp.h.orig
++++ src/wmapp.h
+@@ -78,7 +78,7 @@
+ Window managerWindow;
+ };
+
+-#if 0
++#ifdef CONFIG_GUIEVENTS
+ extern YWMApp * wmapp;
+ #endif
+
diff --git a/x11-wm/icewm/files/patch-src__yarray.h b/x11-wm/icewm/files/patch-src__yarray.h
deleted file mode 100644
index 72137a4b3fc9..000000000000
--- a/x11-wm/icewm/files/patch-src__yarray.h
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix build with clang
-
-http://icewm.cvs.sourceforge.net/viewvc/icewm/icewm-1.2/src/yarray.h?r1=1.5.4.3&r2=1.5.4.4&pathrev=icewm-1-3-BRANCH
-
---- src/yarray.h 2009/06/01 17:10:07 1.5.4.3
-+++ src/yarray.h 2010/12/25 15:29:53 1.5.4.4
-@@ -152,7 +152,8 @@
- }
-
- virtual void remove(const typename YArray<DataType *>::SizeType index) {
-- if (index < YArray<DataType *>::getCount()) delete getItem(index);
-+ if (index < YArray<DataType *>::getCount())
-+ delete YArray<DataType *>::getItem(index);
- YArray<DataType *>::remove(index);
- }
-
diff --git a/x11-wm/icewm/files/patch-src_base.h b/x11-wm/icewm/files/patch-src_base.h
deleted file mode 100644
index 1120fd5a19cf..000000000000
--- a/x11-wm/icewm/files/patch-src_base.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/base.h.orig 2010-10-31 15:09:36.000000000 +0100
-+++ src/base.h 2013-05-25 12:39:49.498390711 +0200
-@@ -1,12 +1,6 @@
- #ifndef __BASE_H
- #define __BASE_H
-
--#if ( __GNUC__ == 3 && __GNUC_MINOR__ > 0 ) || __GNUC__ > 3
--#define deprecated __attribute__((deprecated))
--#else
--#define deprecated
--#endif
--
- /*** Atomar Data Types ********************************************************/
-
- #ifdef NEED_BOOL
diff --git a/x11-wm/icewm/pkg-message b/x11-wm/icewm/pkg-message
deleted file mode 100644
index 396783364812..000000000000
--- a/x11-wm/icewm/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-==============================================================================
-
-IceWM has been installed.
-
-If you want more themes see:
-
-* http://themes.freshmeat.net/browse/925/
-
-If you do not see icons in the tray when they should be there, please try
-rebuilding with the "IMLIB" option enabled.
-
-==============================================================================
diff --git a/x11-wm/icewm/pkg-plist b/x11-wm/icewm/pkg-plist
index a415367ab769..90b05fe0680a 100644
--- a/x11-wm/icewm/pkg-plist
+++ b/x11-wm/icewm/pkg-plist
@@ -1,8 +1,8 @@
-bin/icehelp
+%%NOLITE%%bin/icehelp
bin/icesh
bin/icesound
bin/icewm
-%%GNOMEDESKTOP%%bin/icewm-menu-gnome2
+%%GNOME%%bin/icewm-menu-gnome2
bin/icewm-session
bin/icewmbg
bin/icewmhint