aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/icewm
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-06-16 02:49:07 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-06-16 02:49:07 +0000
commitbe8bf72894bc11b325140d364c50d75120c5ffa7 (patch)
tree9a8a73c15cad6437f58a267a3661f873e03cd13b /x11-wm/icewm
parenteb0b0867c95e8e58d82958c533458a47345c3ee7 (diff)
downloadports-be8bf72894bc11b325140d364c50d75120c5ffa7.tar.gz
ports-be8bf72894bc11b325140d364c50d75120c5ffa7.zip
x11-wm/icewm: Fix build with Clang 6
While here - Fix license - Add missing dependencies PR: 228317 Submitted by: Chris Hutchinson <portmaster@bsdforge.com> (based on) Kudos to: krion (for patiently test building many iterations of it)
Notes
Notes: svn path=/head/; revision=472514
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Makefile10
-rw-r--r--x11-wm/icewm/files/patch-src__wmapp.cc15
2 files changed, 19 insertions, 6 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 6919e3ed56ec..5c5f17d88c0f 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -3,19 +3,23 @@
PORTNAME= icewm
PORTVERSION= 1.3.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTVERSION}
MAINTAINER= portmaster@bsdforge.com
COMMENT= Window Manager designed for speed, usability and consistency
-LICENSE= GPLv2
+LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
USES= gmake iconv:translit localbase pkgconfig
-USE_XORG= ice sm x11 xext
+USE_CXXSTD= c++98
USE_GNOME= gdkpixbuf2
+USE_XORG= ice sm x11 xext xrender
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-guievents \
--with-cfgdir=${DATADIR} \
diff --git a/x11-wm/icewm/files/patch-src__wmapp.cc b/x11-wm/icewm/files/patch-src__wmapp.cc
index a0fce7715d6b..d63001b337f7 100644
--- a/x11-wm/icewm/files/patch-src__wmapp.cc
+++ b/x11-wm/icewm/files/patch-src__wmapp.cc
@@ -1,6 +1,15 @@
---- src/wmapp.cc.orig
+--- src/wmapp.cc.orig 2013-11-17 16:54:39 UTC
+++ src/wmapp.cc
-@@ -337,7 +337,7 @@
+@@ -221,7 +221,7 @@ static void registerProtocols2(Window xid) {
+ #endif
+
+ long pid = getpid();
+- const char wmname[] = "IceWM "VERSION" ("HOSTOS"/"HOSTCPU")";
++ const char wmname[] = "IceWM " VERSION " (" HOSTOS "/" HOSTCPU ")";
+
+ #ifdef GNOME1_HINTS
+ XChangeProperty(xapp->display(), xid,
+@@ -337,7 +337,7 @@ static void initFontPath(IApp *app) {
int ndirs; // ------------------- retrieve the old X's font path ---
char ** fontPath(XGetFontPath(xapp->display(), &ndirs));
@@ -9,7 +18,7 @@
newFontPath[ndirs] = fontsdir;
if (fontPath)
-@@ -383,7 +383,7 @@
+@@ -383,7 +383,7 @@ static void initFontPath(IApp *app) {
XChangeProperty(xapp->display(), manager->handle(),
XA_ICEWM_FONT_PATH, XA_STRING, 8, PropModeReplace,
(unsigned char *) fontsdir, strlen(fontsdir));